
pdfviewerocx/bin/install.bat
regsvr32 pdfview.ocx



pdfviewerocx/bin/install.vbs
'REM -------------------------------------------
'REM Please run a cmd window by administrator privilege, and then run following command line to register OCX component
'REM -------------------------------------------
'
'  regsvr32.exe pdfview.ocx
'

strFolder = ExtractFilePath(WScript.ScriptFullName)
strOCX = """" & strFolder & "\pdfview.ocx" & """"

Set UAC = CreateObject("Shell.Application")
UAC.ShellExecute "cmd.exe", "/c regsvr32.exe " & strOCX, "", "runas", 1

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
Function ExtractFilePath(PathName)
   For x = Len(PathName) To 1 Step -1
      If Mid(PathName, x, 1) = "\" Then Exit For
   Next
   ExtractFilePath = Left (PathName, x - 1)
End Function





pdfviewerocx/bin/pdfview.ocx


pdfviewerocx/bin/pdfviewer.exe


pdfviewerocx/bin/test.pdf
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1 Introducing PDF Editor 


Welcome to PDF Editor. PDF Editor provides a convenient way for you to open and 
work with PDF documents. Using PDF Editor, you can add your own comments, 
contents to your PDF file. Directly edit the contents of PDF documents. 


1.1 What are PDF files? 


A Portable Document Format (PDF) file captures all the elements that make up a 
page, such as text, graphics and page layout, and displays them exactly as they 
appeared on the original page. Use PDF Editor to view a PDF file, add comments to 
it and edit its content. 


 


1.2 Features in PDF Editor 


In the PDF Editor, you can find the following features that guide you achieve your 
aim: 
 Open, view and print PDF documents. 
 Convert PDF format files to Text files, BMP files, TIF files, GIF files and so on. 
 Use bookmarks, page thumbnails to navigate a PDF document. 
 Add comments and comment text with stamps, notes, draws and text boxes. 


Share them with other PDF Editor users using the import/export comments. 
 Edit and add content in the PDF document. 
 Select texts and snapshot an area to copy to the clipboard. 
 Convert other format files to PDF files. 
 Add contents with texts and draws. 
 Email your PDF file.  


1.3 About this help 


This manual is a guide to using VeryPDF PDF Editor and is mainly comprised of the 
following sections. 
 Getting to know PDF Editor describes the PDF Editor application window and the 


tools that are available to you when working with PDF documents. 
 Working with PDF Editor describes how to open, create, print and save PDF 


documents. 
 Working with Text describes how you can select and copy text. 
 Working with Comments describes how you can add comments to your PDF 


documents. 
 Working with Contents describes how you can edit and add contents to your PDF 
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documents. 
 Working with Bookmarks describes how you can use bookmark to review the PDF 


document pages. 
 


1.4 Contacting us 


VeryPDF is a leading provider of PDF creation and manipulation tools. Our products 
are easy to use, enabling you to create PDF files that are compatible with 3rd party 
PDF tools. Please contact us 
Web site:http://www.verypdf.com  
Email: support@verypdf.com  


1.5 PDF Editor Technical support 


At veryPDF, we are committed to providing you with timely answers to all of your 
technical support questions. 
For current hours of operation and details about support offerings, please visit our 
website at www.verypdf.com


 


1.6 Document Feedback 


VeryPDF strives to produce quality technical documentation. If you have comments 
regarding our help files, PDF or print manuals, please send an email to 
support@verypdf.com. 
Please include the following information in your message: 
 Product name and version number 
 Print manual, PDF or help file 
 Section or Topic title 
 Brief description of content 
 Your suggestion for improvement or correction if you have. 
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2 Installing PDF Editor 


This part describes how to install PDF Editor. 


2.1 Installing procedure 


 Download PDF Editor from http://www.verypdf.com 
 Double-click the installation program to start the installation wizard which will 


navigate you to install. 
 Select the folder where you would like to install the software. 
 Click Next to install the program files and click Finish to close the wizard. 


 


 
Figure 2.1 Installing PDF Editor 
 


Note: If you want to convert Word, Excel, etc. documents and other printable 
documents to PDF files, you need to install PDFcamp Printer (www.verypdf.com) 
first. 


2.2 PDF Editor system requirement 


If you have the necessary system components, you can install PDF Editor. 
 Operating System:Win2000/Xp/2003 
 Processor: Minimum Pentium, 50MHz 
 Memory: Minimum 64MB 
 Disk space:16MB of free space 
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2.3 Entering your PDF Editor registration key 


After you have installed PDF Editor, you need to input your name and license 
number before you can use it at the first time if you have purchased. If you don’t 
want to buy it, you can only use the evaluation version. 


 


 


Figure 2.2 Entering registration key 


2.4 Uninstalling PDF Editor 


If you want to uninstall the PDF Editor, there are two ways to do this.  
The first way is, 
 Click windows Start. 
 Click All Programs >VeryPDF PDF Editor V1.1 > Uninstall VeryPDF PDF 


Editor V1.1 
The second way is, 
 Open windows Control Panel. 
 Double click Add or Remove Programs and select VeryPDF PDF Editor V1.1 


from the currently installed programs list. 
 Click Change/Remove to remove PDF Editor.  
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3 Getting to know PDF Editor 


This part describes PDF Editor application window and the tools that are available to 
you when working with PDF documents. 


3.1 PDF Editor’s application window 


PDF Editor’s application window includes a document pane for viewing PDF 
documents and a navigation pane showing bookmarks, thumbnails and comments. 
A menu bar, status bar and several toolbars around the outside of the window 
provide other controls you need to work with documents.  
 


 
Figure 3.1 PDF Editor application window 


 
 PDF Editor title: Shows the program name and current document name. 
 Menu area: Shows menus. 
 Toolbars area: Shows the docked toolbars that are currently selected. You 
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can undock a toolbar by dragging it off the Toolbars area, or to dock a toolbar, 
drag it back to the Toolbars area. If a particular toolbar is not displayed, click 
View > Toolbars and select the appropriate check box from the list of toolbars 
that are available. 


 Navigation Pane: Displays a list of bookmarks, pages and comments that are 
present in the document. You can choose bookmark, pages or comments by 
clicking the Tab Palettes beside navigation pane. 


 Document Pane: Displays the current PDF document page. This page can be 
resized to suit your viewing preference using the tools in the Document 
navigation toolbars or View Toolbars. You can drag the vertical bar between the 
Document Pane and Document Navigation Pane to change their widths. You can 
drag the lower right corner to resize the entire window.  


 Status Toolbars: Show tools which allow you to resize the page and change 
the pages displayed at the same time. 


 Navigation and Zoom Status Toolbars: Show tools which allow you to 
resize the page and navigate through a document. 


 X and Y coordinates: Shows the current position of the cursor in the 
document pane. 


 Show/Hide button: Shows or hides navigation pane. 


3.2 Customizing PDF Editor 


To suit your working preferences, toolbars can be customized in PDF Editor. For 
example, you can show and hide toolbars, add and remove buttons from toolbars. 


3.2.1 Undocking toolbars 


There are five kinds of toolbars can be moved: File toolbars, Basic toolbars, 
Comment toolbars, Content toolbars and Select toolbars in the toolbar area. 
There is a move bar on the left of each toolbars with which the toolbar can be 
undocked and moved from their default position in the PDF Editor application 
window. Once the toolbar is undocked it can be positioned anywhere on your screen, 
and may be placed at the most convenient location as you work with a document. 
The toolbars can also be layout in vertical direction. 


 


File toolbars Basic Toolbars Comment 
Toolbars


Content Toolbars Select Toolbars


Move bar  
Figure 3.2 Toolbars and move bars 


 
To undock a toolbar 


Copyright © 2005 VeryPDF.com Inc 10







                                   http://www.verypdf.com 


 Click and hold your cursor on the move bar of the toolbar. 
 With the mouse button held down, drag the toolbar to anyplace of the working 


field and then release the mouse button. 


 


Figure 3.3 Toolbars undocked 


3.2.2 Hide or show the Document Navigation Pane 


 Click the little button  on the lower left corner of Document Pane, the 
Document Navigation Pane can be hided or showed.   


 


3.2.3 Customizing the toolbars 


The five movable toolbars can be added on or removed from the toolbars area. 
 Click View > Toolbar to add or remove File, Basic, Comment, Content or 


Select toolbars. 


3.3 PDF Editor toolbars 


These are toolbars you can use in PDF Editor. 


3.3.1 File toolbars 


Use these tools to open, save, print and email a PDF file. 
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Figure 3.4 File toolbars 
Please see 4 Working with PDF Editor. 


3.3.2 Basic toolbars 


Use the basic tools to shift different functions. 
 


 
Figure 3.5 Basic toolbars 
 
From left to right, the following tools are: 
Hand | Comment | Content 
 Use Hand tool to browse your PDF documents.  
 Click Comment tool, the Comment toolbars can be enabled.  
 Click Content tool, the Content toolbars can be enabled. But Comment 


toolbars and Content toolbars can’t be active at the same time.  
 


3.3.3 Comment toolbars 


Use comment tools to add comment to the PDF document. 
 


 


Figure 3.6 Comment toolbars 
 


From left to right, the following tools are: 
Text Box | Note | Stamp | Draw 
There are four kinds of draw tools: Pencil, Line, Rectangle and Ellipse. You can 
select one of them by clicking the button right to the Draw. 
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Figure 3.7 Comment draw tools 
 
About the usage of comment, please see 6 Working with Comments. 


3.3.4 Content toolbars 


Use the content tools to add content to your PDF document. 


 
Figure 3.8 Content toolbars 


 
From left to right is Text | Draw. 
There are also four kinds of draw tools: Add Line, Add Rectangle, Add Ellipse 
and Add Polyline. You can select a kind of draws by clicking the button right to the 
Draw. 


 


 
Figure 3.9 Content draw tools 


 
See 7 Working with Contents to get the way to use them. 


 


3.3.5 Select toolbars 


Use these tools to copy a segment including an area of text or image to the 
clipboard. 
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Figure 3.10 Select toolbars 
 


From left to right is Select Text | Snapshot Tool.  
See 5 Working with Text. 


 


3.3.6 Navigation toolbars 


Use these tools to move through pages of a PDF document. 
 


 


Figure 3.11 Navigation toolbars 
 


From left to right, the tools are: 
First Page | Previous Page | Page_of_ | Next Page | Last Page 
See 4.4.2 Scrolling pages for more details. 


 


3.3.7 Zoom toolbars 


Use zoom tools to resize the pages in a PDF document. 
 


 
Figure 3.12 Zoom toolbars 


 
These zoom tools are Zoom out | Zoom Levels | Zoom in | Actual Size | Fit 
Page | Fit Width. 
See 4.4.1 Resizing pages for more details. 


 


3.3.8 Continuous Page Mode toolbars 


Use the toolbars to control continuous page mode. 
 


 
Figure 3.13 Continuous Page Mode toolbars 
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These tools are Single Page | Continuous | Continuous-Facing 
See 4.4.2 Scrolling pages for the usage detail. 
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4 Working with PDF Editor 


This section describes the basics of working with PDF documents: opening a PDF 
file, navigating through a document, printing pages, saving your comments and 
view PDF document information and so on. 


4.1 Tools for working with PDF Editor  


Tools for working with PDF Editor can be found in the File toolbars. 
 


 


Figure 4.1 File toolbars 
 


If you don’t have these tools available, click View > Toolbar > File to add them 
into toolbar area. 


4.2 Creating PDF document 


If the document you want to see is EMF, BMP, WMF, JPEG, GIF, TIFF, PNG, TGA 
or PCX, PDF Editor can firstly convert its format into PDF and then open it for you 
to read. PDF Editor can also combine multiple files into one PDF document.  
 
To create PDF from one file 
 Click File > Create PDF > From File… 


 
Figure 4.2 Create PDF from file: Open a file 
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 Select a file and click Open. Then the file is opened, at the same time the 
program creates a PDF file for it. For example, the file name is “Blue hills.jpg”, 
after it is opened, another file “Blue hills.pdf” is created in the same path. 
Usually the default zoom level is 100% which is larger than the original size. 


 


 
Figure 4.3 Create PDF from file: A created PDF file 


 
To combine multiple files into one PDF file 
 Click File > Create PDF > From Multiple Files…, then the dialog Create PDF 


From Multiple Documents pops out, 


 
Figure 4.4 Create PDF from multiple documents 


 
 Add Files: To add multiple files you want to see. Click Browse, and the Open 


dialog pops out. Select the file type and files and click Open. 
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Figure 4.5 Select multiple documents 
 


All of the files will be listed in Files To Combine box. 


 
Figure 4.6 Files listed in the combine box 
 


 Arrange Files: To remove the files listed in combine box or change their 
located position in the combined file. 
Remove: Select one file and click Remove to delete it. 
Move Up: Select one file and click Move Up to move it up to its former file. If 
the file is already the first one, you can’t move it. 
Move Down: Select one file and click Move Down to move it under to its next 
file. If the file is already the last one, you can’t move it. 


 Output File: Enter the path and file name you want to create. Or you can click 
Save to select a path. 


 Save: To notify a path and enter the file name you want to create. In this 
example,  


 Click Save and the Save As dialog pops up.  
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Figure 4.7 Save the combined PDF file 
 


 Enter the file name, and the file type is pdf. Then click Save.  


 


Figure 4.8 Output file path in the output file box 
 


 The path and file name are displayed in the Output File box. 
 Click OK if you want to create or Cancel to cancel the operation. Then 


a PDF file is created. 
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Figure 4.9 The created PDF file 


 
To create PDF from any printable document 
PDF Editor program can Create PDF file from any printable document including 
Microsoft Word, MS Excel, MS PowerPoint, MS Project Files, Text files, WPS files and 
so on.  
 Click Create PDF > From Any Printable Document, then select a file type 


and file name in Open dialog and click OK. 
Note: You need to download PDFcamp Printer first to fulfill this task at  
http: //www.verypdf.com/pdfcamp/pdfcamp_setup.exe 


 
To create PDF from clipboard image 
You can create a PDF file directly from the clipboard.  
 Paste an image on the clipboard. You can use Print Screen key to grab the 


screen to the clipboard. 
 Click Create PDF > From Clipboard Image, then the program will create a 


temp PDF file, you can click File > Save As to save this file. 
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Figure 4.10 Create PDF from clipboard image 


4.3 Opening a PDF file 


In PDF Editor there are several ways to open a PDF file: 
 Right-click the PDF file you want to read and click Open if you have set PDF 


Editor as your default application or click Open with to choose PDF Editor in 
the program list. 


 Click File > Open: when the Open dialog is popped out, select a PDF file name 
and click Open. 


 Click Open tool on the toolbars area and select a PDF file name. 
 Select the PDF file from the list of recently opened PDF files: this option is only 


valid if you have already used one of the other three methods to open the same 
PDF file. 


 
You can open more than one PDF files and see them at the same time. Resize the 
window and position them in the window to meet your need. For example, you have 
opened two PDF files, but the default window only shows the last opened one, 
 Click Window, you can see the currently opened files’ name. 
 If you want to see them at the same time, click Window > Cascade or Tile, 


and then click one of the open file interfaces and drag it to any position you like. 
The window’s title name will be the file’s name you are reading. 
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Figure 4.11 Cascade files 
 


 


Figure 4.12 Tile files 


4.4 Reading a PDF document 


PDF Editor provides tools that can help you read a PDF file and find your way around 
a large document. Pages can be resized to make them easier to see, and you can 
jump directly to a page number, step through a document page by page, or scroll 
the pages as you read them. 


4.4.1 Resizing pages 


Due to the nature of PDF documents, pages can be resized to a high magnification 
without loss of quality to the text. Vector graphics can also be enlarged without 
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losing image quality, however, you may notice a slight degrading of quality when 
enlarging bitmap images. 
Use the page zoom tools and resize tools to resize your pages. 


 


Figure 4.13 Page zoom tools and resize tools 
 


From left to right, the tools are Zoom out | Zoom Level | Zoom in | Actual Size 
| Fit Page | Fit Width. 
The PDF Editor supports zoom resolutions from 12.5% - 500%, good enough for 
you to see the perfect details on a page. 
 Click Zoom out on the toolbar or View > Zoom out on the menu to scale the 


page in decrements of 10% each time. Or you can directly click Ctrl and – to 
reduce the page size.  


 Click Zoom in on the toolbar or View > Zoom in on the menu to enlarge the 
page in increments of 10% each time. Or you can directly click Ctrl and + to 
increase the page size. 


 Right-click the document pane, a floating item menu appears, and then you can 
select Zoom in or Zoom out. 


 


Figure 4.14 Floating item 
 


 You can directly input the scale number in zoom level tool. 
 Click Actual Size or View > Actual Size, the size will be 100% of the actual 


one, no matter what the size of application window. You can also click Ctrl+1. 
 Click Fit Page or View > Fit Page, one whole page will be displayed in the 


document pane, and its scale proportion is according to the application window 
size. Click Ctrl+2 can quickly restore the page size to a fit one. 


 Click Fit Width or View > Fit Width, the page size will be regulated to a fit 
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width to the application window. Or click Ctrl+3 to get the fit width. 


4.4.2 Scrolling pages 


Use the navigation toolbars and continuous page mode toolbars to read the pages.  
 You can use the Scroll tool to drag pages up or down, left or right with your 


mouse. There are three kind continuous page modes: Single Page, 
Continuous and Continuous-Facing. You can select one of them on the 
toolbars or click View > Single Page or Continuous or Continuous-Facing. 
The tools are the following 


 


 
Figure 4.15 Continuous page modes 
 
Before you can drag the page, ensure which continuous page mode you have 
selected. 
You can also use keyboard shortcuts Alt+1 or Alt+2 or Alt+3 to select the 
mode. 


 The navigation toolbar can help you quickly navigate a page at a time, jump to 
the first or last page, or move to previous page or next page. You can input a 
page number to straightforward read the desired page. 


 


Figure 4.16 Navigation toolbars 


 Click Hand tool  , directly drag the page in the document pane to the part 


you want to read.  
 Right-click the document pane, a floating toolbar appears, click the First Page, 


or Last Page, or Previous Page or Next Page to quickly turn the page.  


4.4.3 Using bookmarks, comments and page thumbnails 


You can also navigate the pages in a PDF document by clicking a bookmark, 
comment or page thumbnail to jump directly to the referenced page. 
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Figure 4.17 Navigation pane 


4.5 Printing a PDF document 


There are several ways to print a PDF document in PDF Editor: 
 Click Print button on the File toolbar, this time the whole document will be 


printed out by the default printer. 
 Click File > Print, select a printer and set its properties, and set the print range 


and number of copies, then click OK. 
 Click Ctrl + P, select the printer and set its properties, and print range and 


number of copies, then click OK. 
 Right click the mouse, when a little floating toolbar appears click Print, then 


select the printer and set its properties, print range and number of copies, and 
click OK. 


4.6 Saving a PDF file 


There are several ways to save a PDF document. 
 
To save the current PDF file: 
 Click the Save button on the File toolbars, or click File > Save, or use the 


keyboard shortcut Ctrl+S. 
 
To save a copy of the current PDF file: 
 Click File > Save As and select a new location or enter a new name. 


 
Note: If the document hasn’t been added any comment or content, or hasn’t been 
made any edit, it couldn’t be saved because only changed documents can be saved.  
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4.7 Saving the PDF file to other format file 


You can save the file to another PDF file or convert the PDF format file to an image 
file such as BMP, WMF, JPEG, GIF, TIFF, PNG, TGA, PCX files and so on. All of 
the image files saved can be selected their page range and resolution. The PDF file 
can also be saved as TEXT files which page range can be set. 
 Click File > Save As, and select a type you want. 


 
Figure 4.18 Save a PDF file to a TIFF file 
 


 Enter a new name and select a new path. Then click Save. 
For example, save file “Introducing PDF.pdf” as a TIFF file. 


 
Figure 4.19 Set page range and resolution 
 


We can select part of them by setting the Page range. Since it is saved as an image 
file, so its resolution can be input as we need. 
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4.8 Closing a PDF file 


There are several ways to close a document in PDF Editor: 
 Click File > Close to close the current PDF file, if you have changed the file and 


haven’t save the changes yet, the application will first ask you whether to save 
the change, you can click Yes then the file will cover the old one, or click No if 
you don’t want to save the changes, or click Cancel to refuse to close. 


 Click the close button  on the right of the menu bar, the application will also 


ask you whether to save the changes or not if you have made. 


4.9 Reverting a PDF file 


PDF Editor allows users add comments or contents to the PDF document or edit the 
content. PDF Editor provides reverting function to let users cancel all of the 
comments or contents editing and back to the original status when the document is 
opened. 
 Click File > Revert, then a message box will be popped out, 


 


Figure 4.20 Revert message box 
 


 Click OK to back to the original status, or click Cancel to refuse. 


4.10 Exiting PDF Editor 


Click File > Exit or the window’s close button  in the top left of the application 


window, PDF Editor will close all of the opened files before checking that all the 
changes have been saved. 


4.11 Document properties 


PDF Editor allows you to view some basic information of the currently opened PDF 
document, including title, author, page number, security and so on. 
 Click File > Document Properties to view its description and security 
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information.  
For example, open a PDF file and read its document properties. 


 
Figure 4.21 Document Properties—Description 
 
The dialog box shows the PDF document’s information, including its created 
date and time, modified date and time, file size, page size, number of pages, 
the file’s path and so on. You can input its title, author, subject and keywords. 


 
Figure 4.22 Document Properties—Security 
 
The document security information can be viewed in the Document 
Restriction Summary list. 


4.12 Emailing 


 Click File > Email, then the program will link internet and email the currently 
reading document. The email subject will be the name of file as a default one, 
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you can also change it as your need. 


4.13 Import comments 


Please see 6 Working with comments. 


4.14 Export comments 


Please see 6 Working with comments. 
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5 Working with Text 


This part describes how you work with text.  


5.1 Tools for working with text 


The tools are Select tools in the toolbars. 
 


 
Figure 5.1 Select toolbars 
 
If you don’t have these tools, click View > Toolbar > Select. 
Note: These tools can only be used in browsing status, so you must enable them 


first them by clicking Hand tool . 


5.2 Selecting and copying text 


Use Select Text, you can select and copy a piece of text to the clipboard, and paste 
it into another format file, such as word, notebook or other else. Use Snapshot 
Tool to copy a piece of text or image to the clipboard, and then you can paste it into 
another image file or a word file. 


5.2.1 Use Select Text tool to copy text  


If you want to copy parts of the PDF file, 


 Click Select Text button  on the toolbar or click Tool > Select Text. 


 Move the cursor to the top left of text you want to copy, and drag the cursor to 
lower right of the text, a text box will appear to show you the selected area, and 
the box’s size is showed in the center of the box. When you loose your finger, a 
message box pops out 
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Figure 5.2 Select text message box 
 


 Open another Windows application such as a notebook file, then paste into it. 


 Click Hand tool  to cancel the function. 


Note: This tool can only copy text format, and once the text is copied to another file, 
you can edit it. If you want to copy a piece of text as a graphic or remain the file’s 
original format, you can use Snapshot Tool to grab what you have seen. 


 


5.2.1.1 Use Select Text tool to copy a PDF table to text file 
Using Select Text tool, you can copy a piece of table and directly add it into a text 
file or an excel file. For example, open a PDF file 
 


 


Figure 5.3 Select text example (1) 
 
Click Select Text tool to copy the table to clipboard. 
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Figure 5.4 Select text example (2) 
 
Open a blank text file to paste the table 


 
Figure 5.5 Select text example (3) 
 


5.2.1.2 Use Select Text tool to copy PDF table to Excel file 
Open MS Excel application to paste the table 
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Figure 5.6 Select text example (4) 
 
Note: If you can’t paste the data in its original format in MS Excel application, you 


can click  to select Use Text Import Wizard to regulate. 


 


5.2.2 Use Snapshot Tool to copy text or graphic as an image 


You can use snapshot tool to copy a piece of any PDF file to MS Word or an image 
file  


 Click Snapshot Tool or Tool > Snapshot. 


 Move the cursor to the top left of the graphic and drag the cursor to lower right 
of it, a text box will appear to show you the selected area, and the area size is 
showed in the center of the box. When you loose your finger, a floating window 
pops out 


 


 
Figure 5.7 Snapshot message box 
 


 Open another Windows application such as a Word file, then paste into it. 
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 Click Hand tool  to cancel the function.   


For example, we open a PDF file and use snapshot tool to grab a picture or data to 
copy to MS Word file. 
 Open a PDF file 


 
Figure 5.8 Snapshot example (1) 
 


 Click Snapshot Tool and select an area the file 


 


Figure 5.9 Snapshot example (2) 
 


 Then paste the picture into a MS Word file. 
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Figure 5.10 Snapshot example (3) 
 


Note: You cannot paste an image into a notebook file. 
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6 Working with Comments 


PDF Editor provides comment tools to allow you review and comment the PDF 
documents. You can add your own comments to the PDF file and save it as a file, 
and you can also open the comment file written by others. PDF Editor provides the 
following comment types: 
 Stamp 
 Notes 
 Draw ( including Pencil, Line, Rectangle and Ellipse) 
 Text Box 


6.1 Tools for working with comments 


The comment toolbar follows as: 
 


 


Figure 6.1 Comment toolbars 
 
Every type of comment has its tool, as showed above in the toolbar: Text box, 
Notes, Stamp and Draw. 
If you don’t have this toolbar, click View > Toolbar > Comment to add it into the 
toolbars. 


6.2 How to add comments 


The comments only can be added in the comment mode. Usually the comment 
default status is off, so you need to active it.  


 Click the Comment button  in the basic toolbar or click Tools > Edit 


Comment to open the comment status. 
 


6.2.1 How to add textbox comments 


This part shows the way to add textbox comments. 
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6.2.1.1 Adding textbox comment 


 Click the Comment button  in the basic toolbar or click Tools > Edit 


Comment to open the comment status. 


 Click Text Box button on the toolbar or click Tools > Comment > Text 


Box. 
 Move the cursor to the position you want to add textbox and drag the cursor to 


a rectangle box 


The drawn Text 
box


 
Figure 6.2 Drawing a text box 


6.2.1.2 Editing in the textbox 
 Double-click the text box, then the color of border of the box becomes to red, 


and you can regulate its width and height by dragging the angle or the middle 
of the edge.  
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Figure 6.3 Editing in the text box 
 


• Input text into the text box,  


 
Figure 6.4 Input text into text box 


The text box can scroll its size if the text doesn’t fit the box. 
 


6.2.1.3 Editing textbox and setting properties 
 Left-click the mouse when the cursor is pointing the textbox, don’t loose it, you 


can drag the textbox to any position of document pane. Or you can use ←,↑,→ 
or ↓ key on the keyboard to move the textbox. 


 Right-click the textbox, a floating item will appear to let you edit the textbox 
and set its properties 


 
Figure 6.5 Right-click textbox 
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 Copy: To copy the textbox to the clipboard and click Edit > Paste to 


encapsulate it. Or you can use Ctrl+C. 
 Cut: To cut the textbox to the clipboard. Or you can use Ctrl+X. 
 Delete: To delete the textbox. Or you can use Delete key on the keyboard. 
 Set to Background: If there are two comments overlapped, set this 


comment to be a background comment. 
 Set to Foreground: If there are two comments overlapped, set this 


comment to be a foreground comment. 
 Make Properties Default: To save the properties you have set, each time 


when add a new textbox, its original properties will be the saved one. 
 Lock/Unlock: If there are several comments close together, when you 


want to edit one of them, you can click Lock/Unlock to lock other 
comments to avoid them being selected. You can cancel the lock status by 
re-clicking Lock/Unlock item. 


 Properties: To set the textbox’s properties.  


 
Figure 6.6 Appearance control panel 


 
There are two control panels Appearance and General in the Properties. In 
Appearance control panel, the text box appearance can be set. 


 Style: To control the border line style of the text box. There are five 
styles: Solid, Dashed1, Dashed2, Dashed3, Dashed4 and Dashed5. 
The default one is Solid. 


 Thickness: To regulate the thickness of the border. The resolution is 
from 0 to 12. You can select the value or just input one.  


 Border Color: To set the color of the border. 
If you don’t need border, just click its checkbox to cancel the property. 


 Fill Color: Select it to change the color of the text box. If you don’t 
need it, just click its checkbox to cancel the property. 


 Text Color: To set the color of text. 
 Font: To set the font of text. 
 Font Size: To change the font size of text. The size value ranges from 


1 to 200 from you to select, and you can also enter a value. 
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 Opacity: Drag the slider  to the right, the opacity degree can be 
increased, or to the left, it can be decreased. The degree is showed in 
the text label. If opacity is less than 100%, both the comment and 
document content can be seen. 


 


General control panel contains the basic information of the text box. 


 
Figure 6.7 General control panel 
 


 Author: The name of the people who add the comments. The default 
name is from the computer. You can enter another name. 


 Subject: The comment’s subject. You can enter another subject to help 
you identify the subject. 


 Modified: To record the last modified date. 
 Close: To save properties you have changed and exit the Properties 


dialog. 
If you want to reserve the properties next time when you add a new text box, just 
right-click the text box and select Make Properties Default.  


6.2.2 How to add Note comments 


6.2.2.1 Adding note comment 


 Click the Comment button  in the basic toolbar or click Tools > Edit 


Comment to open the comment status. 


 Click the Note button on the toolbar or click Tools > Comment > Note, a 


note will be displayed in the middle of the document pane as its default place. 
 Click the note and drag it to any place in the document pane. Or you can use 


←,↑,→ or ↓ key on the keyboard to move the note icon. 
Note: The note icon size is fixed. If you want the note to be more appealing, you 
can change its color and shape to meet your needs. Please see 6.2.2.2 Editing note and 
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setting properties. 


6.2.2.2 Editing note and setting properties 
 Right-click the note icon, a floating item will appear to let you edit the note and 


set its properties 
 Copy: To copy the note to the clipboard and click Edit > Paste to 


encapsulate it. Or you can use Ctrl+C. 
 Cut: To cut the note to the clipboard. Or you can use Ctrl+X. 
 Delete: To delete the note. Or you can use Delete key on the keyboard. 
 Set to Background: If there are two comments overlapped, set this 


comment to be a background comment. 
 Set to Foreground: If there are two comments overlapped, set this 


comment to be a foreground comment. 
 Make Properties Default: To save the properties you have set, each time 


when add a new note, its original properties will be the saved one. 
 Lock/Unlock: If there are several comments close together, when you 


want to edit one of them, you can click Lock/Unlock to lock other 
comments to avoid them being selected. You can cancel the lock status by 
re-clicking Lock/Unlock item. 


 Properties: To set the textbox’s properties. 
 Right-click the note, select Properties in the popped float item, then 


Properties pane will be showed like this, 
In Appearance control pane, the note appearance can be set. 
 Icon: To set the icon type. There are many types icon to choose, such 


as Checkmark, Circle, Comment, Paragraph and so on. You can 
select one according to your need. 


 Color: To set the color of the note. 
 Opacity: To set the opacity degree of the note. 


The basic information of the note is in the General pane. 
 Author: The name of the people who add the comments. The default 


name is from the computer. You can enter another name 
 Subject: The comment’s subject. You can enter another subject to help 


you identify the subject 
 Modified: To record the last modified date and time. 
 Close: To save properties you have changed and exit the Properties 


dialog. 
If you want to reserve the properties next time when you add a new note, just 
right-click the note icon and select Make Properties Default.  


6.2.2.3 Adding comment to the note 
We can write the explanation or annotation into the textbox, but we can’t do that 
for other three comment tools: note, stamp and drawing. The PDF Editor provides 
comment for each comment except textbox for user to write some specification. To 
do this, just double-click the comment, and a small commenting window can be 
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popped. 
For example, double-click the note icon, an commenting window appears which is 
always pointing to the note it comments. 


 
Figure 6.8 Note icon and its commenting window 
 


 
Figure 6.9 Note commenting window 


 
You can enter text into this pop-up window. If the text doesn’t fit this window, the 
text scrolls. Or you can also resize the window dragging the lower right box. 
 
To edit a note comment: 


 Click the commenting area, enter the text. After you have finished, click the 
close box or click anywhere outside the commenting window. 


 The color is the same as the note, so if you change the property of note, the 
commenting window will be changed with it. 


If the commenting window is closed, next time you want to read it, just double-click 
the note icon. 


6.2.3 How to add stamp comments 


You can add a predefined stamp to your PDF file. The stamp can be a BMP file, JPG 
file, TIF file and so on. Every stamp can be added comment as a note. 
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6.2.3.1 Adding a stamp 


 Click the Comment button  in the basic toolbar or click Tools > Edit 


Comment to open the comment status. 


 Click Stamp button on the toolbar or click Tools > Comment > Stamp. 


Then Open dialog will be popped out. 
 


 
Figure 6.10 Open a stamp 
 


 Select a bmp file or other files, and click Open. For example, open file “Stamp”, 


 


Figure 6.11 Stamp example 
 
The stamp will appear in the default place. You can change its size to fit the 
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document page by dragging one of its. Also drag the stamp to anywhere you 
like when you let the cursor point to inside of the stamp. 


6.2.3.2 Adding comment to stamp 
When you add stamp to the PDF document, you can also comment on it.  


 
Figure 6.12 Add comment to a stamp 
 
 Similar to adding comment to note, double-click the stamp, a commenting 


window will pop up.  
 Edit the text in the commenting area. 
 Drag the commenting window to anyplace you like. 
 Change its size by dragging its corner or edge. 
 Click the close box on the upper right corner to close the comment. Double-click 


the stamp if you want to open its comment. 


6.2.3.3 Editing stamp and setting the properties  
You can set the properties of stamp. Unlike to those of a note, the color of the stamp 
can’t be changed, but you can set its comment’s color. 
 Left-click the mouse when the cursor is pointing the stamp, don’t loose it, you 


can drag the stamp to any position of document pane. Or you can use ←,↑,→ or 
↓ key on the keyboard to move the stamp. 


 Right-click the stamp, a floating item will appear to let you edit the textbox and 
set its properties 
 Copy: To copy the stamp to the clipboard and click Edit > Paste to 


encapsulate it. Or you can use Ctrl+C. 
 Cut: To cut the stamp to the clipboard. Or you can use Ctrl+X. 
 Delete: To delete the stamp. Or you can use Delete key on the keyboard. 
 Set to Background: If there are two comments overlapped, set this 


comment to be a background comment. 
 Set to Foreground: If there are two comments overlapped, set this 


comment to be a foreground comment. 
 Make Properties Default: To save the properties you have set, each time 
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when add a new stamp, its original properties will be the saved one. 
 Lock/Unlock: If there are several comments close together, when you 


want to edit one of them, you can click Lock/Unlock to lock other 
comments to avoid them being selected. You can cancel the lock status by 
re-clicking Lock/Unlock item. 


 Properties: To set the stamp’s properties.  
 


 


Figure 6.13 Stamp Appearance control panel 
 
In Appearance control pane, set the color, opacity and transparent color: 
 Color: Set the color of stamp’s comment but not the stamp itself. 
 Opacity: Change the opacity degree of the stamp to suit your needs by 


dragging . The comment’s opacity couldn’t be changed. 
 Transparent Color: To set the transparent color. 


In General control pane, we can view the basic information about the 
comment. 
 Author: The name of the people who add the comments. The default 


name is from the computer. You can enter another name 
 Subject: The comment’s subject. You can enter another subject to help 


you identify the subject 
 Modified: To record the last modified date and time. 
 Close: To save properties you have changed and exit the Properties 


dialog. 
If you want to reserve the properties next time when you add a new stamp, just 
right-click the stamp and select Make Properties Default.  


6.2.4 How to add Draw comments 


Another type of comments is Draw. The draw comments include Pencil , 


Line , Rectangle  and Ellipse . You can use these drawing tools to 
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comment your PDF document.  


6.2.4.1 How to use Pencil tool to draw lines  
Use Pencil tool to create a line into the PDF document. 


6.2.4.1.1 Using the pencil tool to draw lines 


 Click the Comment button  in the basic toolbar or click Tools > Edit 


Comment to open the comment status. 


 Click button on the toolbar. If you can’t see it, you can select it from the 


Draw tool menu. Or click Tools > Comment > Draw > Pencil. This time the 
shape of cursor changes when you let it move in the document pages. 


 


 


Figure 6.14 Drawing comment tools 
 
 Move the cursor to the place you want to draw the line. Left-click the mouse 


and drag it to anyplace you like, and then there appears a line along the cursor 
path. If you want to draw more than one line, you can stop your dragging and 
move the cursor to another place and repeat to draw another line. The line is 
black color when you are drawing it. 


The drawn 
lines


 
Figure 6.15 Drawing comment pencil lines 
 


 When you finish the drawing, double-click in the end point. Or click Esc key on 
the keyboard to exit the drawing. 
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Figure 6.16 Comment pencil lines 


6.2.4.1.2 Editing the pencil lines 


To change the lines’ shape 
When you select one of the lines, all of the lines you draw this time can be edited. 
You can move them to anyplace and drag the corner or the middle of the edge to 
change their length and their distance between each other can be changed 
accordingly.  


Dragging point


 
Figure 6.17 Dragging point 


 
Note: You can’t move a single line if you have drawn more than one line. If you 
don’t need one of the lines, you should delete all of the lines and redraw it. 


 
To change the lines’ position: 


 Left-click the line and don’t loose it, you can drag the lines to any position of 
document pane. Or you can use  ←,↑,→ and ↓ keys on the keyboard to move 
the lines. 


 
To edit the line 


 Right-click the line, a floating item will appear to let you edit the line and set its 
properties 
 Copy: To copy the line to the clipboard and click Edit > Paste to 


encapsulate it. Or you can use Ctrl+C. 
 Cut: To cut the line to the clipboard. Or you can use Ctrl+X. 
 Delete: To delete the line. Or you can use Delete key on the keyboard. 
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 Set to Background: If there are two comments overlapped, set this 
comment to be a background comment. 


 Set to Foreground: If there are two comments overlapped, set this 
comment to be a foreground comment. 


 Make Properties Default: To save the properties you have set, each time 
when add a new line, its original properties will be the saved one. 


 Lock/Unlock: If there are several comments close together, when you 
want to edit one of them, you can click Lock/Unlock to lock other 
comments to avoid them being selected. You can cancel the lock status by 
re-clicking Lock/Unlock item. 


 Properties: To set the line’s properties. See 6.2.4.1.4 Setting pencil lines 
properties. 


 
To delete the line 
Use one of the following ways to delete the lines: 
 Click one of the lines and use Delete key. 
 Right-click the lines, then select Cut or Delete. 
 Click keyboard shortcut Ctrl+X to cut the lines. 
 Click one of the lines, then click Edit > Cut or Delete. 


6.2.4.1.3 Adding comments to the pencil lines 


When you have drawn lines, you can add comments to them. 
 Double-click the lines, and a commenting window pops out. 


 
Figure 6.18 Adding comment to pencil lines 


 
 Edit the text in the commenting area. If the text doesn’t fit this window, the text 


scrolls. You can resize commenting window dragging the lower right box or 
each edge 


 Drag the commenting window to anyplace you like. 
 Change its size by dragging its corner or edge. 


Copyright © 2005 VeryPDF.com Inc 48







                                   http://www.verypdf.com 


 Click the close box on the upper right corner to close the comment. Double-click 
the lines if you want to open its comment. 


 


6.2.4.1.4 Setting pencil lines properties 


Right-click the lines or its commenting window, the Properties panel will be 
opened: 
In Appearance control panel, you can set the color of line and its comment, line’s 
thickness and opacity: 
 Color: Change the color of the line, and the commenting window’s color will be 


changed to the same with the line at the moment. 
 Thickness: Set the thickness of the line. The value ranges from 0 to 12.  
 Opacity: Change the opacity degree of the line to suit your needs by dragging 


. The comment’s opacity couldn’t be changed. 


In General control panel, we can view the basic information about the line: 
 Author: The name of the people who add the comments. The default name is 


from the computer. You can enter another name 
 Subject: The comment’s subject. You can enter another subject to help you 


identify the subject 
 Modified: To record the last modified date and time. 
 Close: To save properties you have changed and exit the Properties dialog. Or 


you can click the  on the up right corner of the pane to close the Properties. 


If you want to reserve the properties next time when you add new pencil lines, just 
right-click the pencil line and select Make Properties Default.  


6.2.4.2 How to use Line tool to draw lines 
Use Line tool to draw lines to your PDF document.  


6.2.4.2.1 Using the line tool to draw a line 


 Click the Comment button  in the basic toolbar or click Tools > Edit 


Comment to open the comment status. 


 Click Line tool button  on the toolbar. If you don’t have this tool on the 


toolbar, select it from the Draw tool menu (see Figure 6.14 Drawing comment 
tools). Or click Tools > Comment > Draw > Line.  


 Move the cursor to the place you want to draw the line. Left-click the mouse and 
drag it to anyplace you like, and then there appears a line along the cursor path. 
The point you begin the line is called Start point and the point you stop the line 
is called End point. 
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Figure 6.19 Drawing a comment line 
 


Note: The line you draw with line tool is different from that drawn with pencil tool. 
You can only draw a single line once, while the latter can draw multiple lines.  


6.2.4.2.2 Editing the line 


To change the line’s layout: 
 Left-click the line and don’t loose it, you can drag the line to any position of 


document pane. Or you can use  ←,↑,→ or ↓ key on the keyboard to move it. 
 Drag one of the terminal points to turn the line or change its length. 


          
Figure 6.20 Turn the line and change its length 
 


To edit the line 
 Right-click the line, a floating item will appear to let you edit the line and set its 


properties 
 Copy: To copy the line to the clipboard and click Edit > Paste to 


encapsulate it. Or you can use Ctrl+C. 
 Cut: To cut the line to the clipboard. Or you can use Ctrl+X. 
 Delete: To delete the line. Or you can use Delete key on the keyboard. 
 Set to Background: If there are two comments overlapped, set this 


comment to be a background comment. 
 Set to Foreground: If there are two comments overlapped, set this 


comment to be a foreground comment. 
 Make Properties Default: To save the properties you have set, each time 


when add a new line, its original properties will be the saved one. 
 Lock/Unlock: If there are several comments close together, when you 


want to edit one of them, you can click Lock/Unlock to lock other 
comments to avoid them being selected. You can cancel the lock status by 
re-clicking Lock/Unlock item. 


 Properties: To set the line’s properties. See 6.2.4.2.4 Setting line properties. 
 


To delete the line 
Use one of the following ways to delete the lines: 
 Click one of the lines and use Delete key. 
 Right-click the lines, then select Cut or Delete. 
 Click keyboard shortcut Ctrl+X to cut the lines. 
 Click one of the lines, then click Edit > Cut or Delete. 
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6.2.4.2.3 Adding comments to the line 


We can add comments to the line.  
 Double-click the lines, a commenting window pops out. 


 


 


Figure 6.21 Add comment to the line 
 


 Edit the text in the commenting area. If the text doesn’t fit this window, the text 
scrolls. You can resize commenting window dragging the lower right box or 
each edge 


 Drag the commenting window to anyplace you like. 
 Change its size by dragging its corner or edge. 
 Click the close box on the upper right corner to close the comment. Double-click 


the line if you want to open its comment. 


6.2.4.2.4 Setting line properties 


Right-click the lines or its commenting window, the Properties pane will be opened: 
In Appearance control panel, you can set the color of line and its comment, set the 
shape of line’s start point or end point, line’s thickness and opacity and so on: 
 Start: Set the shape of start point. There are three choices: None, 


OpenArrow and ClosedArrow. 
None: No arrow on the start point. 
OpenArrow: To add an open arrow to the start point. 
ClosedArrow: To add an closed arrow to the start point. 


 End: Set the shape of end point. The choices are the same with Start. 
 Style: Set the style of the line. There are four styles: Solid, Dashed1, 


Dashed2, Dashed3 and Dashed4 to choose. 
 Color: Set the color of the line, and the commenting window’s color will be 


changed to the same with the line at the moment. 
 Thickness: Set the thickness of the line. The value ranges from 0 to 12.  
 Opacity: Change the opacity degree of the line to suit your needs by dragging 


. The comment’s opacity couldn’t be changed. 


In General control panel, we can view the basic information:  
 Author: The name of the people who add the comments. The default name is 


from the computer. You can enter another name 
 Subject: The comment’s subject. You can enter another subject to help you 
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identify the subject 
 Modified: To record the last modified date and time. 
 Close: To save properties you have changed and exit the Properties dialog. Or 


you can click the  on the up right corner of the pane to close the Properties. 


If you want to reserve the properties next time when you add a new line, just 
right-click the line and select Make Properties Default.  


6.2.4.3 How to use Rectangle tool to draw a rectangle 
Use Rectangle tool to draw rectangles to your PDF document.  


6.2.4.3.1 Using the rectangle tool to draw a rectangle 


 Click the Comment button  in the basic toolbar or click Tools > Edit 


Comment to open the comment status. 


 Click Rectangle tool button  on the toolbar. If you don’t have this tool on 


the toolbar, select it from the Draw tool menu (see Figure 6.14 Drawing 
comment tools). Or click Tools > Comment > Draw > Rectangle.  


 Move the cursor to the place you want to draw the rectangle. Left-click the 
mouse and drag it to anyplace you like, then a rectangle appears.  


 


Figure 6.22 The drawn rectangle comment 


6.2.4.3.2 Editing the rectangle 


To change the rectangle’s layout 
 Dragging the corner of the rectangle or the middle of its edge to change its 


height and width. 
 Left-click the line and don’t loose it, you can drag the line to any position of 


document pane. Or you can use  ←,↑,→ or ↓ key on the keyboard to move it. 
Note: Be sure that you have activated the rectangle, the shape of cursor is not like 


Hand  , otherwise you just scroll the document page. 


 
To edit the rectangle 
 Right-click the rectangle, a floating item will appear to let you edit the line and 


set its properties 
 Copy: To copy the line to the clipboard and click Edit > Paste to 
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encapsulate it. Or you can use Ctrl+C. 
 Cut: To cut the line to the clipboard. Or you can use Ctrl+X. 
 Delete: To delete the line. Or you can use Delete key on the keyboard. 
 Set to Background: If there are two comments overlapped, set this 


comment to be a background comment. 
 Set to Foreground: If there are two comments overlapped, set this 


comment to be a foreground comment. 
 Make Properties Default: To save the properties you have set, each time 


when add a new line, its original properties will be the saved one. 
 Lock/Unlock: If there are several comments close together, when you 


want to edit one of them, you can click Lock/Unlock to lock other 
comments to avoid them being selected. You can cancel the lock status by 
re-clicking Lock/Unlock item. 


 Properties: To set the line’s properties. See 6.2.4.3.4 Setting rectangle 
properties. 


 
To delete the rectangle 
Use one of the following ways to delete it: 
 Click the rectangle and use Delete key. 
 Right-click the rectangle, then select Cut or Delete. 
 Click keyboard shortcut Ctrl+X to cut it. 
 Click Edit > Cut or Delete. 


6.2.4.3.3 Adding comments to the rectangle 


We can add comments to the rectangle.  
 Double-click the rectangle, a commenting window pops out. 


 
Figure 6.23 Add a comment to the rectangle 
 


 Edit the text in the commenting area. If the text doesn’t fit this window, the text 
scrolls. You can resize commenting window dragging the lower right box or 
each edge. 


 Drag the commenting window to anyplace you like. 
 Change its size by dragging its corner or edge. 
 Click the close box on the upper right corner to close the comment. Double-click 


the lines if you want to open its comment. 


6.2.4.3.4 Setting rectangle properties 
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Right-click the rectangle or its commenting window, the Properties panel will be 
opened: 
In Appearance control panel, you can set the color of the rectangle and its 
comment, fill color into it and set the rectangle’s thickness and opacity: 
 Color: Set the color of the rectangle, and the commenting window’s color will 


be changed to the same with the line at the moment. 
 Fill Color: Click Fill color box, then the status is on. This time you can select a 


kind of color from the color table to fill inside the rectangle. 
 Thickness: Set the thickness of the line. The value ranges from 0 to 12.  
 Style: Set the line style of the rectangle. There are four styles: Solid, 


Dashed1, Dashed2, Dashed3 and Dashed4 to choose. 
 Opacity: Change the opacity degree of the whole rectangle including its filled 


color to suit your needs by dragging . The comment’s opacity couldn’t be 


changed. 
In General Panel, we can view the basic information:  
 Author: The name of the people who add the comments. The default name is 


from the computer. You can enter another name 
 Subject: The comment’s subject. You can enter another subject to help you 


identify the subject 
 Modified: To record the last modified date and time. 
 Close: To save properties you have changed and exit the Properties dialog. Or 


you can click the  on the up right corner of the pane to close the Properties. 


Note: Be sure that the cursor is pointed to the rectangle’s edge when you want to 
open the Properties pane. 
If you want to reserve the properties next time when you add a new rectangle, just 
right-click the rectangle and select Make Properties Default.  


 


6.2.4.4 How to use Ellipse tool to draw ellipses 
Use Ellipse tool to draw ellipses to your PDF document.  


6.2.4.4.1 Using the Ellipse tool to draw a ellipse 


 Click the Comment button  in the basic toolbar or click Tools > Edit 


Comment to open the comment status. 


 Click Ellipse tool button  on the toolbar. If you don’t have this tool on the 


toolbar, select it from the Draw tool menu (see Figure 6.14 Drawing comment 
tools). Or click Tools > Comment > Draw > Ellipse.  


 Move the cursor to the place you want to draw the ellipse. Left-click the mouse 
and drag it to anyplace you like, then an ellipse appears.  
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Figure 6.24 The drawn ellipse comment 


6.2.4.4.2 Editing the ellipse 


To change ellipse’s layout 
You can use any of the following ways to edit the rectangle: 


 
Figure 6.25 Rectangle frame 
 
 Dragging the corner of the rectangle-frame or the middle of its edge to change 


its height and width. 
 Left-click the ellipse and don’t loose it, you can drag it to any position of 


document pane. Or you can use  ←,↑,→ or ↓ key on the keyboard to move it. 
 


To edit ellipse 
 Right-click the ellipse, a floating item will appear to let you edit the line and set 


its properties 
 Copy: To copy the ellipse to the clipboard and click Edit > Paste to 


encapsulate it. Or you can use Ctrl+C. 
 Cut: To cut it to the clipboard. Or you can use Ctrl+X. 
 Delete: To delete it. Or you can use Delete key on the keyboard. 
 Set to Background: If there are two comments overlapped, set this 


comment to be a background comment. 
 Set to Foreground: If there are two comments overlapped, set this 


comment to be a foreground comment. 
 Make Properties Default: To save the properties you have set, each time 


when add a new line, its original properties will be the saved one. 
 Lock/Unlock: If there are several comments close together, when you 


want to edit one of them, you can click Lock/Unlock to lock other 
comments to avoid them being selected. You can cancel the lock status by 
re-clicking Lock/Unlock item. 


 Properties: To set the line’s properties. See 6.2.4.4.4 Setting ellipse properties. 
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To delete ellipse 
Use one of the following ways to delete it: 
 Click the ellipse and use Delete key. 
 Right-click it, then select Cut or Delete. 
 Click keyboard shortcut Ctrl+X to cut it. 
 Click Edit > Cut or Delete. 


 
Note: Be sure you have enabled the ellipse, on that occasion a rectangle frame is 
enclosing the ellipse. You can drag the points on it to regulate the ellipse’s size. 


 


6.2.4.4.3 Adding comments to the ellipse 


We can add comments to the ellipse.  
 Double-click the ellipse, and then a commenting window pops out. 


 


Figure 6.26 Add comment to ellipse 
 


 Edit the text in the commenting area. If the text doesn’t fit this window, the text 
scrolls. You can resize commenting window dragging the lower right box or 
each edge. 


 Drag the commenting window to anyplace you like. 
 Change its size by dragging its corner or edge. 
 Click the close box on the upper right corner to close the comment. Double-click 


the ellipse if you want to open its comment. 


6.2.4.4.4 Setting ellipse properties 


Right-click the ellipse or its commenting window, the Properties panel will be 
opened: 
In Appearance control panel, you can set the color of the ellipse and its comment, 
fill color into it and set the ellipse’s thickness and opacity: 
 Color: Set the color of the rectangle, and the commenting window’s color will 
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be changed to the same with the line at the moment. 
 Fill Color: Click Fill color box, then the status is on. This time you can select a 


kind of color from the color table to fill inside the rectangle. 
 Thickness: Set the thickness of the line. The value ranges from 0 to 12.  
 Style: Set the line style of the rectangle. There are four styles: Solid, 


Dashed1, Dashed2, Dashed3 and Dashed4 to choose. 
 Opacity: Change the opacity degree of the whole rectangle including its filled 


color to suit your needs by dragging . The comment’s opacity couldn’t be 


changed. 
In General Panel, we can view the basic information:  
 Author: The name of the people who add the comments. The default name is 


from the computer. You can enter another name 
 Subject: The comment’s subject. You can enter another subject to help you 


identify the subject 
 Modified: To record the last modified date and time. 
 Close: To save properties you have changed and exit the Properties dialog. Or 


you can click the  on the up right corner of the pane to close the Properties. 


Note: Be sure that the cursor is pointed to the ellipse’s edge when you want to open the 
Properties pane. 
If you want to remain the properties next time when you add a new note, just right-click 
the ellipse and select Make Properties Default.  


6.3 How to remove comments 


You can use one of the following ways to remove the comments 
 Right-click the comment you to remove, then a floating item appears, click Cut 


or Delete. 
 Click the comment and use key Delete. 
 Click the comment and click Edit > Delete. 
 Right-click the comment title in the comment navigation pane and select 


Delete. 


6.4 Selecting/Deselecting comments 


If you want to select all of the comments, you can do one of the following ways: 
 Click Edit > Select All. 
 Use keyboard shortcut Ctrl+A. 


To deselect all comments, do one of the followings: 
 Click Edit > Deselect All. 
 Use keyboard shortcut Shift+Ctrl+A. 


You can also use Ctrl + left click the comment to select the comments one by one 


Copyright © 2005 VeryPDF.com Inc 57







                                   http://www.verypdf.com 


if you want to choose some of them. And use Ctrl+Shift+left click the comment to 
deselect it. 


6.5 Using Comment Navigation Pane to view comment 


All of the information about the comment added will be listed in the Comment 
Navigation Pane, including page number, comment type, creating date and time. 
  
To open comment navigation pane 
 Click Comments in the navigation pane.  


If you can’t see the navigation pane, click button  in the lower left document 


pane. 


Page number


Comment title


Comment list


 
Figure 6.27 Comment navigation pane 


 
There are two levels in Comments navigation. The first level is the page+ number, 
which represents the page comments be added in. The second level is a comment 
list contains all of the comments in the current page.  


6.5.1 Navigating the comment 


 Click + to see the comments list. Every comment title is like the form 
Author-subject-date and time. You can see any of the comments by clicking 
the comment title. 


Copyright © 2005 VeryPDF.com Inc 58







                                   http://www.verypdf.com 


6.5.2 Deleting the comment 


 Right-click the comment title and select Delete. 


6.5.3 Setting the comment properties 


 Right-click the comment title and select Properties. If you want to save the 
properties, you can select Make Properties Default. 


6.6 Importing and exporting comments 


PDF Editor allows you to save your comments to a file and import them into another 
PDF document, thus you can reuse the same comment in different PDF document. 
When different people have reviewed the same document and added their own 
comments, they can save their commenting PDF file.  


6.6.1 Importing comments 


You can import comments into a PDF document. Existing comments will not be 
changed or removed when you import new comments. 


 Click the Comment button  in the basic toolbar or click Tools > Edit 


Comment to open the comment status. 
 Click File > Import comments, the Open dialog pops out. 
 Select a Comment file and click Open. 


Note: You can only import the *.comment file that you export from the PDF 
document edited by PDF Editor. 


6.6.2 Exporting comments 


PDF Editor allows you save your comments by exporting them and save them as 
*.comment type files. 


 Click the Comment button  in the basic toolbar or click Tools > Edit 


Comment to open the comment status. 
 Click File > Export comments when you have finished your comments to open 


Save As dialog box. 
 Enter a name for your comments file. 
 Click OK to create the file and close the dialog box. 
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7 Working with Contents 


PDF Editor provides content tools to allow you directly edit the content of the PDF 
document you are reading. The function of Content tools is different from that of 
Comment tools though they are a bit similar. You can add comments into your PDF 
document and save them as another file. But using the Content means you can 
change the PDF file itself, similar to editing a Word file. Comment tools and Content 
tools can’t be used at the same time. PDF Editor provides the following content 
types: 


 Text 
 Draw(including Line, Rectangle, Ellipse and Polyline) 


7.1 How to edit content 


The contents can be added in content mode. Usually the content default status is off, 
so you need to enable it.  


 Click the Content button  in the basic toolbar or click Tools > Edit 


Content to open the content status. 


7.1.1 Editing the content of PDF document 


You can do any of the followings to edit your PDF file: 


 
Figure 7.1 Edit content example (1) 
 


 Click the content, then it can be selected by a red function frame.  


 
Figure 7.2 Edit content example (2) 
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 Drag the cursor to move the selected area to the position you like. 


 
Figure 7.3 Edit content example (3) 
 


 Right-click the content to review its property. 


 
Figure 7.4 Edit content example (4) 
 
A property dialog will pop up: 


 


Figure 7.5 Content property example 
 


In General form, you can edit the text and change its font, font size and color. 
 Text: To edit the text in textbox.  


 
Figure 7.6 Edit content text 


 
 Font: To select a font in the list box. 
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Figure 7.7 Set content font 
 


 Font Size: To change the Font size in Font Size textbox. 


 


Figure 7.8 Enter content font size 
 


 Color: To select a color in the color table 
 Then click  on the upper right corner of the dialog to save the change and 


exit editing. Or you can click anyplace outside of the edit box to save. 


 
Figure 7.9 Edited content 


 
In Transform form, you can enter X and Y coordinates of the start of the text. 
You can use Esc key on the keyboard to cancel the edit each time.  


 Delete the content you selected. Use Delete key or right-click the content to 
select Delete or click Edit > Delete, or click Edit > Cut to copy it to the 
clipboard. 


 Copy the content to clipboard by clicking Edit > Copy. 
 Paste content into the document by clicking Edit > Paste. 
 You can select all of the content by dragging the cursor to the area you want,  


 


Figure 7.10 Select all of the content 
 
Then all the contents are selected 
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Figure 7.11 All contents selected 


 Or use Ctrl + left click the content to select multiple contents. To deselect any 
content, you can use Ctrl + left click the content. 


7.2 Tools for working with Contents 


The content toolbar follows as: 
 


 
Figure 7.12 Content toolbars 


 
Every type of content has its tool, as showed above in the toolbar: Text and Draw. 
If you don’t have the toolbar, click View > Toolbar > Content to add it into 
toolbars. 


7.3 How to add contents 


This part describes how to add contents. 


7.3.1 How to add Text 


This part shows the way to add text. 


7.3.1.1 Adding text 


 Click the Content button  in the basic toolbar or click Tools > Edit 


Content to open the content status. 


 Click Add Text button on the toolbar or click Tools > Content> Text. The 


Add Text dialog pops out. 


Copyright © 2005 VeryPDF.com Inc 63







                                   http://www.verypdf.com 


 


Figure 7.13 Add text dialog box 
 You can enter text and set font style and size, color and text’s location. 


Font: Choose a font style. 
Font Size: Enter a size value you want. 
Font Color: Select a color for the text. 
X and Y Position: Set the text start position. 


 Click OK to finish the text editing. 
For example, input the text and change its size 


 


 
Figure 7.14 Add text example (1) 


 
Click OK, 
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Figure 7.15 Add text example (2) 


7.3.1.2 Moving the text 
 Let the cursor point to the text, you can drag it to any position in the document 


pages.  


7.3.1.3 Deleting the text 
You can use one of the following ways to delete the text you have added: 
 Right-click the text frame, and select Delete. 
 Click the text, then click Edit > Undo or use shortcut key Ctrl+Z. 
 Click the text, directly delete with Delete key on the keyboard. 


7.3.1.4 Editing the content 
 The text you add can be edited, and its property can be reset by right-clicking 


the text.  


 
Figure 7.16 Right click the text 


 
 Click Property, and the Content Editor-Text dialog pops out, 
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Figure 7.17 Content property example 
 
In General form, you can edit the text and change its font, font size and color. 
In Transform form, you can enter X and Y coordinates of the start of the text. 
Please see 7.1.1 Editing the content of PDF document. 


7.3.2 How to add drawings 


This part shows the way to add drawings. 


7.3.2.1 How to add lines 
You can draw lines in the PDF document by using Add line tool.  


7.3.2.1.1 Using Add line tool to draw lines 


 Click the Content button  in the basic toolbar or click Tools > Edit 


Content to open the content status. 


 Click Add line button  on the content toolbar. If you can’t see it, you can 


select it from the Draw tool menu. Or click Tools > Content > Draw > Line. 


 


Figure 7.18 Content drawing tools 
 


 Move the cursor to the place you want to draw the line. Left-click the line and 
drag it to anyplace you like, and then there appears a line along with the cursor 
path.  


 
Figure 7.19 Add a line in PDF document 


7.3.2.1.2 Relocating the line 


You can do one of the following ways to relocate the line: 
 Let the cursor point to the line frame, you can drag it to any position in the 


document pages.  
 Change the line X and Y coordinates in Content Editor-Line form. See Editing 


the drawn line in this part. 
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7.3.2.1.3Deleting the line 


You can use one of the following ways to delete the line you have drawn: 
 Right-click the line frame, and select Delete. 
 Click the line, then click Edit > Undo or use shortcut key Ctrl+Z. 
 Click the line, directly delete with Delete key on the keyboard. 


7.3.2.1.4 Editing the drawn line 


You can change the line’s color, width and location. 
 Right-click the line frame and select Property, and the Content Editor-Line 


dialog pops out. 
In General form, you can change the line color and its width. In this example, 
 Click Color box and select a color in the color table 


 
Figure 7.20 Select a color  
 


 Click the Line Width textbox and enter a value 


 


Figure 7.21 Enter line width 
 


 Then click  on the upper right corner of the dialog to save the change and exit 
editing. You can see the result, 


 


Figure 7.22 Edit result 
 


In Transform form, you can set the line’s location and its width and height 


 


Figure 7.23 Set line’s layout 
 


 Change the value in the box, and then click  on the upper right corner of the 
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dialog to save the change. 


7.3.2.2 How to add rectangles 
You can draw rectangles in the PDF document by using Add Rectangle tool.  


7.3.2.2.1 Using Add Rectangle tool to draw rectangles 


 Click the Content button  in the basic toolbar or click Tools > Edit 


Content to open the content status. 


 Click Add Rectangle button  on the content toolbar. If you can’t see it, you 


can select it from the Draw tool menu(see Figure 7.18 Content drawing tools). 
Or click Tools > Content > Draw > Rectangle. 


 Move the cursor to the position you want to draw the rectangle. Left-click the 
mouse and drag it to anyplace you like, then a rectangle can be drawn with the 
cursor moving. 


 
Figure 7.24 Add a rectangle in PDF document 


7.3.2.2.2 Relocating the rectangle 


You can do one of the following ways to relocate the rectangle: 
 Let the cursor point to the rectangle, you can drag it to any position in the 


document pages.  
 Change the rectangle’s X and Y coordinates in Content Editor-Rectangle form. 


See 7.3.2.2.4 Editing the drawn rectangle. 


7.3.2.2.3 Deleting the rectangle 


You can use one of the following ways to delete the rectangle you have drawn: 
 Right-click the rectangle, and select Delete. 
 Click the rectangle, then click Edit > Undo or use shortcut key Ctrl+Z. 
 Click the rectangle, directly delete with Delete key on the keyboard. 


7.3.2.2.4 Editing the drawn rectangle 


You can change the rectangle’s color, width and location, and fill color into the 
rectangle. 
 Right-click the line frame and select Property, then the Content 


Editor-Rectangle dialog pops out. 
In General form, you can change the rectangle line color and width, and fill color 
inside the rectangle. In this example, 
 Click Color box and select a color in the color table 
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Figure 7.25 Select a color for rectangle line 
 


 Click Fill box if you want to fill color into the rectangle. The default value False 
means no filled color. Select True to fill color. 


 


Figure 7.26 Set whether to fill color inside rectangle 
 


 Click Fill Color box, and select a filled color in color table if you have select 
True in the Fill box. 


   
Figure 7.27 Set fill color 
 


 Click the Line Width box and enter a value 


 


Figure 7.28 Enter line width 
 


 Then click  on the upper right corner of the dialog to save the change and exit 
editing. You can see the result, 


 


Figure 7.29 Rectangle result 
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In Transform form, you can set the rectangle’s location and its width and height 
 


 
Figure 7.30 Set rectangle’s layout 


 
 Change the value in the box, and then click  on the upper right corner of the 


dialog to save the change. 


7.3.2.3 How to add ellipses 
You can draw ellipses in the PDF document by using Add Ellipse tool.  


7.3.2.3.1 Using Add Ellipse tool to draw ellipses 


 Click the Content button  in the basic toolbar or click Tools > Edit 


Content to open the content status. 


 Click Add Ellipse button  on the content toolbar. If you can’t see it, you can 


select it from the Draw tool menu(see Figure 7.18 Content drawing tools). Or 
click Tools > Content > Draw > Ellipse. 
 


 Move the cursor to the position you want to draw the ellipse. Left-click the 
mouse and drag it to anyplace you like, then an ellipse can be drawn with the 
cursor moving. 


 
Figure 7.31 Add ellipse in PDF document 


7.3.2.3.2 Relocating the ellipse 


You can do one of the following ways to relocate the ellipse: 
 Let the cursor point to the ellipse, you can drag it to any position in the 


document pages.  
 Change the ellipse’s X and Y coordinates in Content Editor-Ellipse form. See 


Editing the drawn ellipse in this part. 
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7.3.2.3.3 Deleting the ellipse 


You can use one of the following ways to delete the rectangle you have drawn: 
 Right-click the rectangle, and select Delete. 
 Click the ellipse, then click Edit > Undo or use shortcut key Ctrl+Z. 
 Click the ellipse, directly delete with Delete key on the keyboard. 


7.3.2.3.4 Editing the drawn ellipse 


You can change the ellipse’s color, width and location, and fill color into the ellipse. 
 Right-click the ellipse and select Property, then the Content Editor-Ellipse 


dialog pops out, and you can drag one of its edge of make it wider or higher. 
In General form, you can change the ellipse’s line color and width, and fill color 
inside the ellipse. In this example, 
 Click Color box and select a color in the color table 


 
Figure 7.32 Set color for the ellipse 
 


 Click Fill box if you want to fill color into the ellipse. The default value False 
means no filled color. Select True to fill color. 


 


Figure 7.33 Set whether to fill color in the ellipse 
 


 Click Fill Color box, and select a filled color in color table if you have select 
True in the Fill box. 


   
Figure 7.34 Select a fill color 
 


 Click the Line Width box and enter a value 
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Figure 7.35 Enter line width 
 


 Then click  on the upper right corner of the dialog to save the change and exit 
editing. You can see the result, 


 
Figure 7.36 Ellipse result  
 


In Transform form, you can set the ellipse’s location and its width and height 


 
Figure 7.37 Set ellipse’s layout 
 


 Change the value in the box, and then click  on the upper right corner of the 
dialog to save the change or click any position outside of the dialog frame. If 
you want to cancel this input, you can also put down Esc key on the keyboard. 


 


7.3.2.4 How to add polylines 
You can draw polylines in the PDF document by using Add line tool.  


7.3.2.4.1 Using Add polyline tool to draw lines 


 Click the Content button  in the basic toolbar or click Tools > Edit 


Content to open the content status. 


 Click Add polyline button  on the content toolbar. If you can’t see it, you can 


select it from the Draw tool menu(see Figure 7.18 Content drawing tools). Or 
click Tools > Content > Draw > Polyline. 


 Move the cursor to the place you want to draw the line. Left-click the mouse and 
drag it to anyplace you like, and then there appears a line along with the cursor 
path. Pause your finger and change the moving direction to create an open 
shape with multiple segments.  


 Double-click the cursor or click Esc key on the keyboard to exit drawing, or else 
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the cursor always drags the line to anyplace it moves. Then you can see the line, 
for example, 


 
Figure 7.38 Add polyline in PDF document 


7.3.2.4.2 Relocating the line 


You can do one of the following ways to relocate the line: 
 Let the cursor point to the line frame, you can drag it to any position in the 


document pages.  
 Change the line X and Y coordinates in Content Editor-Line form. See 7.3.2.1.4 


Editing the drawn line. 


7.3.2.4.3 Deleting the line 


You can use one of the following ways to delete the line you have drawn: 
 Right-click the line frame, and select Delete. 
 Click the line, then click Edit > Undo or use shortcut key Ctrl+Z. 
 Click the line, directly delete with Delete key on the keyboard. 


7.3.2.4.4 Editing the drawn line 


Please see 7.3.2.1.4 Editing the drawn line. 


7.4 Selecting/Deselecting contents 


You can use Ctrl + left click the content to select the contents. Use Ctrl + Shift 
+left click the content to deselect it. 
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8 Working with Bookmarks 


PDF Editor provides bookmark navigation pane to help you quickly locate the 
section you want to review.  
 
To open bookmark 
 Click Bookmarks in the navigation pane.  


If you can’t see the navigation pane, click button  in the lower left document 


pane. 


 
Figure 8.1 Bookmark navigation pane 


8.1 Using bookmark to navigate the document 


Depending on how the bookmarks have been set up in a document, bookmarks 
may contain branches and sub-branches, as shown in Figure 8.1. Click the + to 
expand a bookmark and view its sub-branches. Every branch or sub-branch may be 
the title or subject of the section it represents. Click the branch to find the title you 
are interested in, then the content may be displayed in the Document Pane. 


8.2 Editing bookmark 
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Figure 8.2 Bookmark edit menu 
 
You can edit the bookmark by selecting bookmark editing menu.  
 Right click one of the title, then a small menu may be popped out.  


 Go to Bookmark: To go to the correspond document. 
 Expand Current Bookmark: To expand the current branch the cursor 


points to see its every sub-branch if the current branch is fold. Or you can 
also click + to expand the branch. To collapse the current branch’s 
sub-branch if the current branch is unfold. Or you can also click – to 
collapse the branch. 


 Expand All Bookmark: To expand all branches and sub-branches if 
there are at least one branch is collapsed. To collapse all branch and 
sub-branch if there is at least a branch is expanded. 


 Fontsize: To control the font size of bookmark. There are three choices: 
Increase: Enlarge the font size. 
Decrease: Subtract the font size. 
Default: To set the size as a default one. 
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9 Keyboard shortcuts 


Table 1 lists the default keyboard shortcuts used by PDF Editor. 
 


Command Shortcut 


Actual Size Ctrl+1 


Close Ctrl+W 


Continuous Alt+2 


Continuous-Facing Alt+3 


Copy Ctrl+C 


Create PDF file From file Ctrl+N 


Cut Ctrl+X 


Delete Delete 


Deselect All Comments Shift+Ctrl+ A 


Document Properties Ctrl+D 


First Page Ctrl+PageUp 


Fit Page  Ctrl+2 


Fit Width Ctrl+3 


Last Page Ctrl+PageDown 


Next Page PageDown 


Open Ctrl+O 


Paste Ctrl+V 


Previous Page PageUp 


Print Ctrl+P 
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Redo Ctrl+Y 


Save Ctrl+S 


Save As Shift+Ctrl+S 


Select All Comments Ctrl+A 


Single Page Alt+1 


Undo Ctrl+Z 


Zoom In Ctrl+Num + 


Zoom Out Ctrl+Num - 


Table 1 PDF Editor keyboard shortcut 
 


Table 2 lists the line style in PDF Editor 
 


Line Style Line Shape 


Solid  


Dashed1  


Dashed2  


Dashed3  


Dashed4  


Table 2 Line Style 
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10 PDF Editor License 


This is a legal agreement between you (either an individual or an entity) and 
VeryPDF.com Inc. By installing or using the software, you agree to be bound by 
the terms of this agreement. If you do not agree to the terms of this agreement, 
remove the product from your hard drive and permanently erase all copies of the 
product. If the software has been delivered to you on physical media, such as CD or 
diskette, you must promptly return the software with proof of purchase to the place 
where it was purchased for a full refund of the amount paid.  
 
This copy of PDF Editor may either be used by a single person who uses the 
software personally on one or more computers, or installed on a single workstation 
used nonsimultaneously by multiple people, but not both. This is not a concurrent 
use license. 
 
You may access this copy through a network, provided that you have obtained an 
individual PDF Editor license for each workstation that will access PDF Editor 
through the network.  
 
Any liability of VeryPDF.com Inc. will be limited exclusively to refund of purchase 
price. In addition, in no event shall VeryPDF.com Inc., or its principals, 
shareholders, officers, employees, affiliates, contractors, subsidiaries, or parent 
organizations, be liable for any incidental, consequential, or punitive damages 
whatsoever relating to the use of PDF Editor, or your relationship with 
VeryPDF.com Inc. 
 
This Agreement is the complete statement of the Agreement between the parties 
on the subject matter, and merges and supersedes all other or prior understandings, 
purchase orders, agreements and arrangements. This Agreement shall be 
governed by the laws. Exclusive jurisdiction and venue for all matters relating to 
this Agreement shall be in courts, and you consent to such jurisdiction and venue. 
All rights of any kind in PDF Editor which are not expressly granted in this License 
are entirely and exclusively reserved to and by VeryPDF.com Inc. You may not 
rent, lease, modify, translate, reverse engineer, decompile, disassemble or create 
derivative works based on PDF Editor. You may not make access to PDF Editor 
available to others in connection with a service bureau, application service provider, 
or similar business.  There are no third party beneficiaries of any promises, 
obligations or representations made by VeryPDF.com Inc. herein. 
 
Copyright © 2003-2005 by VeryPDF.com Inc. All rights reserved 
Homepage: http://www.verypdf.com
Email: support@verypdf.com
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11 Copyright Notice 


Copyright © 2003-2005 by VeryPDF.com Inc. All rights reserved. 
Part modules of PDF Editor software is based on the work of independent JPEG 
workgroup. 


 
Homepage: http://www.verypdf.com
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pdfviewerocx/bin/uninstall.vbs
'REM -------------------------------------------
'REM Please run a cmd window by administrator privilege, and then run following command line to unregister OCX component
'REM -------------------------------------------
'
'  regsvr32.exe /u pdfview.ocx
'

strFolder = ExtractFilePath(WScript.ScriptFullName)
strOCX = """" & strFolder & "\pdfview.ocx" & """"

Set UAC = CreateObject("Shell.Application")
UAC.ShellExecute "cmd.exe", "/c regsvr32.exe /u " & strOCX, "", "runas", 1

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
Function ExtractFilePath(PathName)
   For x = Len(PathName) To 1 Step -1
      If Mid(PathName, x, 1) = "\" Then Exit For
   Next
   ExtractFilePath = Left (PathName, x - 1)
End Function
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pdfviewerocx/C#/WindowsFormsApplication/Form1.cs
using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Linq;
using System.Text;
using System.Windows.Forms;

namespace WindowsFormsApplication
{
    public partial class Form1 : Form
    {
        int nViewMode = 0;
        public Form1()
        {
            InitializeComponent();
        }

        private void Open_Click(object sender, EventArgs e)
        {
            OpenFileDialog dlgOpen = new OpenFileDialog();
            if (dlgOpen.ShowDialog() == DialogResult.OK)
            {
                axPdfview1.OpenPDF(dlgOpen.FileName, "", "");
            }
        }

        private void NextPage_Click(object sender, EventArgs e)
        {
            axPdfview1.ViewNextPage();
        }

        private void ActualSize_Click(object sender, EventArgs e)
        {
            axPdfview1.ZoomActualPage();
        }

        private void PreviousPage_Click(object sender, EventArgs e)
        {
            axPdfview1.ViewPreviousPage();
        }

        private void FitPage_Click(object sender, EventArgs e)
        {
            axPdfview1.ZoomFitPage();
        }

        private void FitWidth_Click(object sender, EventArgs e)
        {
            axPdfview1.ZoomFitWidth();
        }

        private void ZoomIn_Click(object sender, EventArgs e)
        {
            axPdfview1.ZoomIn();
        }

        private void ZoomOut_Click(object sender, EventArgs e)
        {
            axPdfview1.ZoomOut();
        }

        private void ViewMode_Click(object sender, EventArgs e)
        {
            if (nViewMode == 0)
                axPdfview1.ViewModeSinglePage();
            else if (nViewMode == 1)
                axPdfview1.ViewModeFacing();
            else if (nViewMode == 2)
                axPdfview1.ViewModeContinuous();
            else if (nViewMode == 3)
                axPdfview1.ViewModeContinuousFacing();
            nViewMode++;
            if (nViewMode >= 4)
                nViewMode = 0;
        }

        private void RotateLeft_Click(object sender, EventArgs e)
        {
            axPdfview1.RotateViewLeft();
        }

        private void RotateRight_Click(object sender, EventArgs e)
        {
            axPdfview1.RotateViewRight();
        }

        private void Search_Click(object sender, EventArgs e)
        {
            axPdfview1.SetFindText(SearchString.Text);
            axPdfview1.FindNextText();
        }

        private void SearchNext_Click(object sender, EventArgs e)
        {
            axPdfview1.FindNextText();
        }
    }
}
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namespace WindowsFormsApplication
{
    partial class Form1
    {
        /// <summary>
        /// 必需的设计器变量。
        /// </summary>
        private System.ComponentModel.IContainer components = null;

        /// <summary>
        /// 清理所有正在使用的资源。
        /// </summary>
        /// <param name="disposing">如果应释放托管资源，为 true；否则为 false。</param>
        protected override void Dispose(bool disposing)
        {
            if (disposing && (components != null))
            {
                components.Dispose();
            }
            base.Dispose(disposing);
        }

        #region Windows 窗体设计器生成的代码

        /// <summary>
        /// 设计器支持所需的方法 - 不要
        /// 使用代码编辑器修改此方法的内容。
        /// </summary>
        private void InitializeComponent()
        {
            System.ComponentModel.ComponentResourceManager resources = new System.ComponentModel.ComponentResourceManager(typeof(Form1));
            this.axPdfview1 = new AxPDFVIEWLib.AxPdfview();
            this.Open = new System.Windows.Forms.Button();
            this.NextPage = new System.Windows.Forms.Button();
            this.ActualSize = new System.Windows.Forms.Button();
            this.FitPage = new System.Windows.Forms.Button();
            this.FitWidth = new System.Windows.Forms.Button();
            this.ZoomIn = new System.Windows.Forms.Button();
            this.ZoomOut = new System.Windows.Forms.Button();
            this.ViewMode = new System.Windows.Forms.Button();
            this.RotateLeft = new System.Windows.Forms.Button();
            this.RotateRight = new System.Windows.Forms.Button();
            this.label1 = new System.Windows.Forms.Label();
            this.SearchString = new System.Windows.Forms.TextBox();
            this.Search = new System.Windows.Forms.Button();
            this.SearchNext = new System.Windows.Forms.Button();
            this.PreviousPage = new System.Windows.Forms.Button();
            ((System.ComponentModel.ISupportInitialize)(this.axPdfview1)).BeginInit();
            this.SuspendLayout();
            // 
            // axPdfview1
            // 
            this.axPdfview1.Enabled = true;
            this.axPdfview1.Location = new System.Drawing.Point(0, 0);
            this.axPdfview1.Name = "axPdfview1";
            this.axPdfview1.OcxState = ((System.Windows.Forms.AxHost.State)(resources.GetObject("axPdfview1.OcxState")));
            this.axPdfview1.Size = new System.Drawing.Size(590, 499);
            this.axPdfview1.TabIndex = 0;
            // 
            // Open
            // 
            this.Open.Location = new System.Drawing.Point(607, 3);
            this.Open.Name = "Open";
            this.Open.Size = new System.Drawing.Size(95, 24);
            this.Open.TabIndex = 1;
            this.Open.Text = "Open";
            this.Open.UseVisualStyleBackColor = true;
            this.Open.Click += new System.EventHandler(this.Open_Click);
            // 
            // NextPage
            // 
            this.NextPage.Location = new System.Drawing.Point(607, 34);
            this.NextPage.Name = "NextPage";
            this.NextPage.Size = new System.Drawing.Size(95, 24);
            this.NextPage.TabIndex = 2;
            this.NextPage.Text = "Next Page";
            this.NextPage.UseVisualStyleBackColor = true;
            this.NextPage.Click += new System.EventHandler(this.NextPage_Click);
            // 
            // ActualSize
            // 
            this.ActualSize.Location = new System.Drawing.Point(607, 96);
            this.ActualSize.Name = "ActualSize";
            this.ActualSize.Size = new System.Drawing.Size(95, 24);
            this.ActualSize.TabIndex = 3;
            this.ActualSize.Text = "Actual Size";
            this.ActualSize.UseVisualStyleBackColor = true;
            this.ActualSize.Click += new System.EventHandler(this.ActualSize_Click);
            // 
            // FitPage
            // 
            this.FitPage.Location = new System.Drawing.Point(607, 127);
            this.FitPage.Name = "FitPage";
            this.FitPage.Size = new System.Drawing.Size(95, 24);
            this.FitPage.TabIndex = 4;
            this.FitPage.Text = "Fit Page";
            this.FitPage.UseVisualStyleBackColor = true;
            this.FitPage.Click += new System.EventHandler(this.FitPage_Click);
            // 
            // FitWidth
            // 
            this.FitWidth.Location = new System.Drawing.Point(607, 158);
            this.FitWidth.Name = "FitWidth";
            this.FitWidth.Size = new System.Drawing.Size(95, 24);
            this.FitWidth.TabIndex = 5;
            this.FitWidth.Text = "Fit Width";
            this.FitWidth.UseVisualStyleBackColor = true;
            this.FitWidth.Click += new System.EventHandler(this.FitWidth_Click);
            // 
            // ZoomIn
            // 
            this.ZoomIn.Location = new System.Drawing.Point(607, 189);
            this.ZoomIn.Name = "ZoomIn";
            this.ZoomIn.Size = new System.Drawing.Size(95, 24);
            this.ZoomIn.TabIndex = 6;
            this.ZoomIn.Text = "Zoom In";
            this.ZoomIn.UseVisualStyleBackColor = true;
            this.ZoomIn.Click += new System.EventHandler(this.ZoomIn_Click);
            // 
            // ZoomOut
            // 
            this.ZoomOut.Location = new System.Drawing.Point(607, 220);
            this.ZoomOut.Name = "ZoomOut";
            this.ZoomOut.Size = new System.Drawing.Size(95, 24);
            this.ZoomOut.TabIndex = 7;
            this.ZoomOut.Text = "Zoom Out";
            this.ZoomOut.UseVisualStyleBackColor = true;
            this.ZoomOut.Click += new System.EventHandler(this.ZoomOut_Click);
            // 
            // ViewMode
            // 
            this.ViewMode.Location = new System.Drawing.Point(607, 251);
            this.ViewMode.Name = "ViewMode";
            this.ViewMode.Size = new System.Drawing.Size(95, 24);
            this.ViewMode.TabIndex = 8;
            this.ViewMode.Text = "View Mode";
            this.ViewMode.UseVisualStyleBackColor = true;
            this.ViewMode.Click += new System.EventHandler(this.ViewMode_Click);
            // 
            // RotateLeft
            // 
            this.RotateLeft.Location = new System.Drawing.Point(607, 282);
            this.RotateLeft.Name = "RotateLeft";
            this.RotateLeft.Size = new System.Drawing.Size(95, 24);
            this.RotateLeft.TabIndex = 9;
            this.RotateLeft.Text = "Rotate Left";
            this.RotateLeft.UseVisualStyleBackColor = true;
            this.RotateLeft.Click += new System.EventHandler(this.RotateLeft_Click);
            // 
            // RotateRight
            // 
            this.RotateRight.Location = new System.Drawing.Point(607, 313);
            this.RotateRight.Name = "RotateRight";
            this.RotateRight.Size = new System.Drawing.Size(95, 24);
            this.RotateRight.TabIndex = 10;
            this.RotateRight.Text = "Rotate Right";
            this.RotateRight.UseVisualStyleBackColor = true;
            this.RotateRight.Click += new System.EventHandler(this.RotateRight_Click);
            // 
            // label1
            // 
            this.label1.AutoSize = true;
            this.label1.Location = new System.Drawing.Point(614, 353);
            this.label1.Name = "label1";
            this.label1.Size = new System.Drawing.Size(89, 12);
            this.label1.TabIndex = 11;
            this.label1.Text = "Search String:";
            // 
            // SearchString
            // 
            this.SearchString.Location = new System.Drawing.Point(616, 372);
            this.SearchString.Name = "SearchString";
            this.SearchString.Size = new System.Drawing.Size(83, 21);
            this.SearchString.TabIndex = 12;
            // 
            // Search
            // 
            this.Search.Location = new System.Drawing.Point(607, 411);
            this.Search.Name = "Search";
            this.Search.Size = new System.Drawing.Size(95, 24);
            this.Search.TabIndex = 13;
            this.Search.Text = "Search";
            this.Search.UseVisualStyleBackColor = true;
            this.Search.Click += new System.EventHandler(this.Search_Click);
            // 
            // SearchNext
            // 
            this.SearchNext.Location = new System.Drawing.Point(607, 444);
            this.SearchNext.Name = "SearchNext";
            this.SearchNext.Size = new System.Drawing.Size(95, 24);
            this.SearchNext.TabIndex = 14;
            this.SearchNext.Text = "Search Next";
            this.SearchNext.UseVisualStyleBackColor = true;
            this.SearchNext.Click += new System.EventHandler(this.SearchNext_Click);
            // 
            // PreviousPage
            // 
            this.PreviousPage.Location = new System.Drawing.Point(607, 65);
            this.PreviousPage.Name = "PreviousPage";
            this.PreviousPage.Size = new System.Drawing.Size(95, 24);
            this.PreviousPage.TabIndex = 15;
            this.PreviousPage.Text = "Previous Page";
            this.PreviousPage.UseVisualStyleBackColor = true;
            this.PreviousPage.Click += new System.EventHandler(this.PreviousPage_Click);
            // 
            // Form1
            // 
            this.AutoScaleDimensions = new System.Drawing.SizeF(6F, 12F);
            this.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font;
            this.ClientSize = new System.Drawing.Size(708, 499);
            this.Controls.Add(this.PreviousPage);
            this.Controls.Add(this.SearchNext);
            this.Controls.Add(this.Search);
            this.Controls.Add(this.SearchString);
            this.Controls.Add(this.label1);
            this.Controls.Add(this.RotateRight);
            this.Controls.Add(this.RotateLeft);
            this.Controls.Add(this.ViewMode);
            this.Controls.Add(this.ZoomOut);
            this.Controls.Add(this.ZoomIn);
            this.Controls.Add(this.FitWidth);
            this.Controls.Add(this.FitPage);
            this.Controls.Add(this.ActualSize);
            this.Controls.Add(this.NextPage);
            this.Controls.Add(this.Open);
            this.Controls.Add(this.axPdfview1);
            this.Name = "Form1";
            this.Text = "Form1";
            ((System.ComponentModel.ISupportInitialize)(this.axPdfview1)).EndInit();
            this.ResumeLayout(false);
            this.PerformLayout();

        }

        #endregion

        private AxPDFVIEWLib.AxPdfview axPdfview1;
        private System.Windows.Forms.Button Open;
        private System.Windows.Forms.Button NextPage;
        private System.Windows.Forms.Button ActualSize;
        private System.Windows.Forms.Button FitPage;
        private System.Windows.Forms.Button FitWidth;
        private System.Windows.Forms.Button ZoomIn;
        private System.Windows.Forms.Button ZoomOut;
        private System.Windows.Forms.Button ViewMode;
        private System.Windows.Forms.Button RotateLeft;
        private System.Windows.Forms.Button RotateRight;
        private System.Windows.Forms.Label label1;
        private System.Windows.Forms.TextBox SearchString;
        private System.Windows.Forms.Button Search;
        private System.Windows.Forms.Button SearchNext;
        private System.Windows.Forms.Button PreviousPage;
    }
}
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^E:\PDFPSINTER\PDFVIEWER\PRODUCT_RELEASE\PDFVIEWEROCX\C#\WINDOWSFORMSAPPLICATION\FORM1.RESX|E:\PDFPSINTER\PDFVIEWER\PRODUCT_RELEASE\PDFVIEWEROCX\C#\WINDOWSFORMSAPPLICATION\PROPERTIES\RESOURCES.RESX
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E:\PDFPSINTER\PDFVIEWER\PRODUCT_RELEASE\PDFVIEWEROCX\C#\WINDOWSFORMSAPPLICATION\OBJ\X86\DEBUG\WINDOWSFORMSAPPLICATION.PROPERTIES.RESOURCES.RESOURCES
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pdfviewerocx/C#/WindowsFormsApplication/obj/x86/Debug/WindowsFormsApplication.csproj.FileListAbsolute.txt
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Debug\Interop.PDFVIEWLib.dll
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Debug\AxInterop.PDFVIEWLib.dll
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Debug\WindowsFormsApplication.csproj.ResolveComReference.cache
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\bin\x86\Debug\WindowsFormsApplication.exe
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\bin\x86\Debug\WindowsFormsApplication.pdb
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\bin\x86\Debug\Interop.PDFVIEWLib.dll
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\bin\x86\Debug\AxInterop.PDFVIEWLib.dll
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Debug\ResolveAssemblyReference.cache
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Debug\WindowsFormsApplication.Form1.resources
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Debug\WindowsFormsApplication.Properties.Resources.resources
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Debug\ResGen.read.1.tlog
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Debug\ResGen.write.1.tlog
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Debug\WindowsFormsApplication.exe
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Debug\WindowsFormsApplication.pdb
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^E:\PDFPSINTER\PDFVIEWER\PRODUCT_RELEASE\PDFVIEWEROCX\C#\WINDOWSFORMSAPPLICATION\FORM1.RESX
^E:\PDFPSINTER\PDFVIEWER\PRODUCT_RELEASE\PDFVIEWEROCX\C#\WINDOWSFORMSAPPLICATION\PROPERTIES\RESOURCES.RESX
C:\WINDOWS\MICROSOFT.NET\FRAMEWORK64\V2.0.50727\CONFIG\SECURITY.CONFIG
C:\WINDOWS\MICROSOFT.NET\FRAMEWORK64\V2.0.50727\CONFIG\ENTERPRISESEC.CONFIG




pdfviewerocx/C#/WindowsFormsApplication/obj/x86/Release/ResGen.write.1.tlog
^E:\PDFPSINTER\PDFVIEWER\PRODUCT_RELEASE\PDFVIEWEROCX\C#\WINDOWSFORMSAPPLICATION\FORM1.RESX|E:\PDFPSINTER\PDFVIEWER\PRODUCT_RELEASE\PDFVIEWEROCX\C#\WINDOWSFORMSAPPLICATION\PROPERTIES\RESOURCES.RESX
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pdfviewerocx/C#/WindowsFormsApplication/obj/x86/Release/WindowsFormsApplication.csproj.FileListAbsolute.txt
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Release\Interop.PDFVIEWLib.dll
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Release\AxInterop.PDFVIEWLib.dll
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Release\WindowsFormsApplication.csproj.ResolveComReference.cache
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\bin\x86\Release\WindowsFormsApplication.exe
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\bin\x86\Release\WindowsFormsApplication.pdb
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\bin\x86\Release\Interop.PDFVIEWLib.dll
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\bin\x86\Release\AxInterop.PDFVIEWLib.dll
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Release\ResolveAssemblyReference.cache
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Release\WindowsFormsApplication.Form1.resources
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Release\WindowsFormsApplication.Properties.Resources.resources
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Release\ResGen.read.1.tlog
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Release\ResGen.write.1.tlog
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Release\WindowsFormsApplication.exe
E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\C#\WindowsFormsApplication\obj\x86\Release\WindowsFormsApplication.pdb
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pdfviewerocx/C#/WindowsFormsApplication/Program.cs
using System;
using System.Collections.Generic;
using System.Linq;
using System.Windows.Forms;

namespace WindowsFormsApplication
{
    static class Program
    {
        /// <summary>
        /// 应用程序的主入口点。
        /// </summary>
        [STAThread]
        static void Main()
        {
            Application.EnableVisualStyles();
            Application.SetCompatibleTextRenderingDefault(false);
            Application.Run(new Form1());
        }
    }
}




pdfviewerocx/C#/WindowsFormsApplication/Properties/AssemblyInfo.cs
using System.Reflection;
using System.Runtime.CompilerServices;
using System.Runtime.InteropServices;

// 有关程序集的常规信息通过下列属性集
// 控制。更改这些属性值可修改
// 与程序集关联的信息。
[assembly: AssemblyTitle("WindowsFormsApplication")]
[assembly: AssemblyDescription("")]
[assembly: AssemblyConfiguration("")]
[assembly: AssemblyCompany("")]
[assembly: AssemblyProduct("WindowsFormsApplication")]
[assembly: AssemblyCopyright("Copyright ©  2008")]
[assembly: AssemblyTrademark("")]
[assembly: AssemblyCulture("")]

// 将 ComVisible 设置为 false 使此程序集中的类型
// 对 COM 组件不可见。如果需要从 COM 访问此程序集中的类型，
// 则将该类型上的 ComVisible 属性设置为 true。
[assembly: ComVisible(false)]

// 如果此项目向 COM 公开，则下列 GUID 用于类型库的 ID
[assembly: Guid("f999b028-0c63-4ca2-9a02-20fb944abcc7")]

// 程序集的版本信息由下面四个值组成:
//
//      主版本
//      次版本 
//      内部版本号
//      修订号
//
// 可以指定所有这些值，也可以使用“内部版本号”和“修订号”的默认值，
// 方法是按如下所示使用“*”:
// [assembly: AssemblyVersion("1.0.*")]
[assembly: AssemblyVersion("1.0.0.0")]
[assembly: AssemblyFileVersion("1.0.0.0")]




pdfviewerocx/C#/WindowsFormsApplication/Properties/Resources.Designer.cs
//------------------------------------------------------------------------------
// <auto-generated>
//     This code was generated by a tool.
//     Runtime Version:4.0.30319.269
//
//     Changes to this file may cause incorrect behavior and will be lost if
//     the code is regenerated.
// </auto-generated>
//------------------------------------------------------------------------------

namespace WindowsFormsApplication.Properties {
    using System;
    
    
    /// <summary>
    ///   A strongly-typed resource class, for looking up localized strings, etc.
    /// </summary>
    // This class was auto-generated by the StronglyTypedResourceBuilder
    // class via a tool like ResGen or Visual Studio.
    // To add or remove a member, edit your .ResX file then rerun ResGen
    // with the /str option, or rebuild your VS project.
    [global::System.CodeDom.Compiler.GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder", "4.0.0.0")]
    [global::System.Diagnostics.DebuggerNonUserCodeAttribute()]
    [global::System.Runtime.CompilerServices.CompilerGeneratedAttribute()]
    internal class Resources {
        
        private static global::System.Resources.ResourceManager resourceMan;
        
        private static global::System.Globalization.CultureInfo resourceCulture;
        
        [global::System.Diagnostics.CodeAnalysis.SuppressMessageAttribute("Microsoft.Performance", "CA1811:AvoidUncalledPrivateCode")]
        internal Resources() {
        }
        
        /// <summary>
        ///   Returns the cached ResourceManager instance used by this class.
        /// </summary>
        [global::System.ComponentModel.EditorBrowsableAttribute(global::System.ComponentModel.EditorBrowsableState.Advanced)]
        internal static global::System.Resources.ResourceManager ResourceManager {
            get {
                if (object.ReferenceEquals(resourceMan, null)) {
                    global::System.Resources.ResourceManager temp = new global::System.Resources.ResourceManager("WindowsFormsApplication.Properties.Resources", typeof(Resources).Assembly);
                    resourceMan = temp;
                }
                return resourceMan;
            }
        }
        
        /// <summary>
        ///   Overrides the current thread's CurrentUICulture property for all
        ///   resource lookups using this strongly typed resource class.
        /// </summary>
        [global::System.ComponentModel.EditorBrowsableAttribute(global::System.ComponentModel.EditorBrowsableState.Advanced)]
        internal static global::System.Globalization.CultureInfo Culture {
            get {
                return resourceCulture;
            }
            set {
                resourceCulture = value;
            }
        }
    }
}
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//------------------------------------------------------------------------------
// <auto-generated>
//     This code was generated by a tool.
//     Runtime Version:4.0.30319.269
//
//     Changes to this file may cause incorrect behavior and will be lost if
//     the code is regenerated.
// </auto-generated>
//------------------------------------------------------------------------------

namespace WindowsFormsApplication.Properties {
    
    
    [global::System.Runtime.CompilerServices.CompilerGeneratedAttribute()]
    [global::System.CodeDom.Compiler.GeneratedCodeAttribute("Microsoft.VisualStudio.Editors.SettingsDesigner.SettingsSingleFileGenerator", "10.0.0.0")]
    internal sealed partial class Settings : global::System.Configuration.ApplicationSettingsBase {
        
        private static Settings defaultInstance = ((Settings)(global::System.Configuration.ApplicationSettingsBase.Synchronized(new Settings())));
        
        public static Settings Default {
            get {
                return defaultInstance;
            }
        }
    }
}
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Microsoft Visual Studio Solution File, Format Version 11.00
# Visual Studio 2010
Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "WindowsFormsApplication", "WindowsFormsApplication\WindowsFormsApplication.csproj", "{E2D10E2E-44FE-44D5-A3D5-15BA480DD4D2}"
EndProject
Global
	GlobalSection(SolutionConfigurationPlatforms) = preSolution
		Debug|x86 = Debug|x86
		Release|x86 = Release|x86
	EndGlobalSection
	GlobalSection(ProjectConfigurationPlatforms) = postSolution
		{E2D10E2E-44FE-44D5-A3D5-15BA480DD4D2}.Debug|x86.ActiveCfg = Debug|x86
		{E2D10E2E-44FE-44D5-A3D5-15BA480DD4D2}.Debug|x86.Build.0 = Debug|x86
		{E2D10E2E-44FE-44D5-A3D5-15BA480DD4D2}.Release|x86.ActiveCfg = Release|x86
		{E2D10E2E-44FE-44D5-A3D5-15BA480DD4D2}.Release|x86.Build.0 = Release|x86
	EndGlobalSection
	GlobalSection(SolutionProperties) = preSolution
		HideSolutionNode = FALSE
	EndGlobalSection
EndGlobal
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pdfviewerocx/CPP/cdxCSizingDialog.cpp

pdfviewerocx/CPP/cdxCSizingDialog.cpp
// cdxCSizingDialog.cpp : implementation file

// (c)1998 Hans Bühler, codex design

// Designed to be used with MS VC++ 5.0



#define OEMRESOURCE

//#include  <windows.h>



#include "stdafx.h"

#include "cdxCSizingDialog.h"



#ifndef OBM_SIZE

#define OBM_SIZE        32766

// taken from WinresRc.h

// if not used for any reason

#endif



#ifdef _DEBUG

#define new DEBUG_NEW

#undef THIS_FILE

static char THIS_FILE[] = __FILE__;

#endif



/////////////////////////////////////////////////////////////////////////////

// Some static variables

/////////////////////////////////////////////////////////////////////////////



static LPCTSTR  pfEntry_Left    =   _T("Left"),

                    pfEntry_Right   =   _T("Right"),

                    pfEntry_Top     =   _T("Top"),

                    pfEntry_Bottom  =   _T("Bottom"),

                    pfEntry_State   =   _T("State"),

                    pfEntry_IsDone  =   _T("(check)");



#define BAD_ID  ((UINT)~0)

static struct cdxCSizingPropSheet::StandardControls psheetCtrls[]   =

{

    {   ID_WIZNEXT,     cdxCSizingDialog::mdRepos,cdxCSizingDialog::mdRepos },

    {   ID_WIZFINISH,   cdxCSizingDialog::mdRepos,cdxCSizingDialog::mdRepos },

    {   ID_WIZBACK,     cdxCSizingDialog::mdRepos,cdxCSizingDialog::mdRepos },

    {   IDOK,               cdxCSizingDialog::mdRepos,cdxCSizingDialog::mdRepos },

    {   IDCANCEL,       cdxCSizingDialog::mdRepos,cdxCSizingDialog::mdRepos },

    {   ID_WIZNEXT,     cdxCSizingDialog::mdRepos,cdxCSizingDialog::mdRepos },

    {   ID_APPLY_NOW,   cdxCSizingDialog::mdRepos,cdxCSizingDialog::mdRepos },

    {   IDHELP,         cdxCSizingDialog::mdRepos,cdxCSizingDialog::mdRepos },

    {   AFX_IDC_TAB_CONTROL,    cdxCSizingDialog::mdResize,cdxCSizingDialog::mdResize   },

    {   ID_WIZFINISH+1,cdxCSizingDialog::mdResize,cdxCSizingDialog::mdRepos},   /* the bevel line; hope that it will keep this id */

    {   BAD_ID  }

};



/////////////////////////////////////////////////////////////////////////////

// cdxCSizingDialog::ControlInfo::Header

/////////////////////////////////////////////////////////////////////////////



/////////////////////////////////////////////////////////////////////////////

// Functions for my windowos

/////////////////////////////////////////////////////////////////////////////



/*

 * OnInitDialog()

 * Gets initial sizes of the window and makes sizing icon

 */



BOOL cdxCSizingDialog::ControlInfo::Header::OnInitDialog(UINT addSzByPcnt)

{

    ASSERT(IsValid() && (m_iClientWid == -1));



    CRect                   r;

    WINDOWPLACEMENT wpl;



    m_pWnd->GetClientRect(&r);

    m_iClientWid    =   r.right - r.left;

    m_iClientHi =   r.bottom - r.top;



    m_pWnd->GetWindowPlacement(&wpl);

    m_iMinWid   =   wpl.rcNormalPosition.right - wpl.rcNormalPosition.left;

    m_iMinHi        =   wpl.rcNormalPosition.bottom - wpl.rcNormalPosition.top;



    // set up sizing icon



    if(m_bSizeIcon)

    {

        if(!m_bmSizeIcon.LoadOEMBitmap(OBM_SIZE))

        {

            TRACE0(_T("*** ERROR[cdxCSizingDialog::ControlInfo::Header::OnInitDialog()]: LoadOEMBitmap() failed.\n"));

            m_bSizeIcon =   false;

        }

        else

        {

            CRect   szr(r.Width()-24,r.Height()-24,r.Width(),r.Height());

            if(!m_wndSizeIcon.Create(NULL,WS_CHILD|SS_BITMAP,szr,m_pWnd) ||

                !m_wndSizeIcon.ModifyStyleEx(0,WS_EX_TRANSPARENT) )

            {

                TRACE0(_T("*** ERROR[cdxCSizingDialog::ControlInfo::Header::OnInitDialog()]: Can't create static icon control\n"));

                m_bSizeIcon =   false;

            }

            else

            {

                m_wndSizeIcon.SetBitmap(m_bmSizeIcon);



                // now the icon has been resized to the real size of the icon



                if(!m_wndSizeIcon.GetWindowPlacement(&wpl))

                {

                    TRACE0(_T("*** ERROR[cdxCSizingDialog::ControlInfo::Header::OnInitDialog()]: Can't get windowplacement for sizeicon.\n"));

                    m_bSizeIcon =   false;

                }

                else

                {

                    wpl.flags   =   0;

                    wpl.rcNormalPosition.left   =   r.Width() - (wpl.rcNormalPosition.right - wpl.rcNormalPosition.left);

                    wpl.rcNormalPosition.right  =   r.Width();

                    wpl.rcNormalPosition.top    =   r.Height() - (wpl.rcNormalPosition.bottom - wpl.rcNormalPosition.top);

                    wpl.rcNormalPosition.bottom=    r.Height();

                    if(!m_wndSizeIcon.SetWindowPlacement(&wpl))

                    {

                        TRACE0(_T("*** ERROR[cdxCSizingDialog::ControlInfo::Header::OnInitDialog()]: Can't set windowplacement for sizeicon.\n"));

                        m_bSizeIcon =   false;

                    }

                    else

                    {

                        AddSzControl(m_wndSizeIcon,mdRepos,mdRepos);

                        m_wndSizeIcon.ShowWindow(SW_SHOW);      // finally - show it

                    }

                }

            }

        }

    }



    if(addSzByPcnt)

        StretchWindow(addSzByPcnt);



    return TRUE;

}



/////////////////////////////////////////////////////////////////////////////



/*

 * OnSize() handler

 * Call before base classes' handler

 */



void cdxCSizingDialog::ControlInfo::Header::OnSize(UINT nType, int cx, int cy) 

{

    if((nType != SIZE_MINIMIZED) && (m_iClientWid != -1))

    {

        ASSERT((m_pWnd != NULL) && ::IsWindow(m_pWnd->m_hWnd));

        ChangeSize(cx,cy);

    }

}



/*

 * tell system what minimum size we have

 * call past original function

 */



void cdxCSizingDialog::ControlInfo::Header::OnGetMinMaxInfo(MINMAXINFO FAR* lpMMI) 

{

    ASSERT(m_pWnd != NULL);



    if(::IsWindow(m_pWnd->m_hWnd) && (m_iClientWid != -1))

    {

        lpMMI->ptMinTrackSize.x =   m_iMinWid;

        lpMMI->ptMinTrackSize.y =   m_iMinHi;

        if(!(m_Freedom & fdVert))

            lpMMI->ptMaxTrackSize.y =   m_iMinHi;

        if(!(m_Freedom & fdHoriz))

            lpMMI->ptMaxTrackSize.x =   m_iMinWid;

    }

}



/////////////////////////////////////////////////////////////////////////////



/*

 * this _really_ sizes/positions the controls

 * call RedrawWindow() afterwards !

 */



bool cdxCSizingDialog::ControlInfo::Header::ChangeSize(int newWid, int newHi)

{

    if(!IsValid() || (m_iClientWid == -1))

        return false;



    register int    deltaX  =   newWid - m_iClientWid,

                        deltaY  =   newHi - m_iClientHi;

    bool                ok  =   true;



    if(deltaX < 0)

    {

        ok  =   false;

        deltaX  =   0;

    }



    if(deltaY < 0)

    {

        deltaY  =   0;

        ok  =   false;

    }



    for(register ControlInfo *ci = m_pFirst; ci; ci = ci->GetNext())

        ci->AdaptControlSize(deltaX,deltaY);

    m_pWnd->RedrawWindow();



    return ok;

}



/*

 * force recalculation

 */



bool cdxCSizingDialog::ControlInfo::Header::ReorganizeControls(void)

{

    ASSERT(IsValid());

    CRect   r;

    m_pWnd->GetClientRect(&r);

    return ChangeSize(r.Width(), r.Height());

}



/*

 * resize dialog in all available directions

 */



void cdxCSizingDialog::ControlInfo::Header::StretchWindow(UINT addSzByPcnt)

{

    ASSERT(IsValid());



    register int        delta;

    WINDOWPLACEMENT wpl;



    if(!m_pWnd->GetWindowPlacement(&wpl))

    {

#ifdef _DEBUG

        CString s;m_pWnd->GetWindowText(s);

        if(s.IsEmpty())

            s.Format(_T("<Address_0x%lx"),(UINT)this);

        TRACE1(_T("*** ERROR[cdxCSizingDialog::ControlInfo::Header::StretchWindow()]: GetWindowPlacement() failed for dialog with caption \"%s\" !\n"),(LPCSTR)s);

#endif

        return;

    }



    if(addSzByPcnt && (m_Freedom & fdHoriz))

    {

        delta   =   ((wpl.rcNormalPosition.right - wpl.rcNormalPosition.left) * addSzByPcnt) / (100/2);

        if((wpl.rcNormalPosition.left -=    delta) < 0)

            wpl.rcNormalPosition.left   =   0;

        wpl.rcNormalPosition.right += delta;

    }

    if(addSzByPcnt && (m_Freedom & fdVert))

    {

        delta   =   ((wpl.rcNormalPosition.bottom - wpl.rcNormalPosition.top) * addSzByPcnt) / (100/2);

        if((wpl.rcNormalPosition.top -= delta) < 0)

            wpl.rcNormalPosition.top    =   0;

        wpl.rcNormalPosition.bottom += delta;

    }

    wpl.flags   =   0;

    m_pWnd->SetWindowPos(&wndBottom,    wpl.rcNormalPosition.left,

                                                wpl.rcNormalPosition.top,

                                                wpl.rcNormalPosition.right - wpl.rcNormalPosition.left,

                                                wpl.rcNormalPosition.bottom - wpl.rcNormalPosition.top,

                                                SWP_NOACTIVATE|SWP_NOOWNERZORDER|SWP_NOREDRAW|SWP_NOZORDER);

}





/////////////////////////////////////////////////////////////////////////////

// cdxCSizingDialog::ControlInfo::Header utility functions: Sizing

/////////////////////////////////////////////////////////////////////////////



/*

 * add a control that might be resized or repositioned

 * (simple)

 */



cdxCSizingDialog::ControlInfo *cdxCSizingDialog::ControlInfo::Header::AddSzControl(CWnd & ctrl, Mode modeX, Mode modeY)

{

    BYTE    dX1pcnt =   exIgnore,

            dX2pcnt =   exIgnore,

            dY1pcnt =   exIgnore,

            dY2pcnt =   exIgnore;



    switch(modeX)

    {

        default :           ASSERT(false);  

        case    mdNone  :   break;

        case    mdRepos :   dX1pcnt =   dX2pcnt =   exMaximum;

                                break;

        case    mdResize    :   dX2pcnt =   exMaximum;

                                break;

        case    mdRelative: dX1pcnt =   dX2pcnt =   exMaximum / 2;

                                break;

    }



    switch(modeY)

    {

        default :           ASSERT(false);  

        case    mdNone  :   break;

        case    mdRepos :   dY1pcnt =   dY2pcnt =   exMaximum;

                                break;

        case    mdResize    :   dY2pcnt =   exMaximum;

                                break;

        case    mdRelative: dY1pcnt =   dY2pcnt =   exMaximum / 2;

                                break;

    }



    return AddSzControlEx(ctrl,dX1pcnt,dX2pcnt,dY1pcnt,dY2pcnt);

}



/*

 * add a control that might be resized or repositioned

 * (ex)

 */



cdxCSizingDialog::ControlInfo *cdxCSizingDialog::ControlInfo::Header::AddSzControlEx(CWnd & ctrl, BYTE dX1pcnt, BYTE dX2pcnt, BYTE dY1pcnt, BYTE dY2pcnt)

{

    if(!IsValid() || !::IsWindow(ctrl.m_hWnd) || (m_iClientWid == -1))

    {

        ASSERT(m_iClientWid != -1);     // call cdxCSizingDialog::InitDialog() first !

        ASSERT(::IsWindow(ctrl.m_hWnd));    // that's not a valid control !

        return NULL;

    }



    if((dX1pcnt == exIgnore) && (dX2pcnt == exIgnore) &&

        (dY1pcnt == exIgnore) && (dY2pcnt == exIgnore) )

    {

#ifdef _DEBUG

        CString s;ctrl.GetWindowText(s);

        if(s.IsEmpty())

            s.Format(_T("No caption; <Address_0x%lx"),(UINT)&ctrl);

        TRACE1(_T("*** WARNING[cdxCSizingDialog::ControlInfo::Header::AddSzControl()]: For control \"%s\", all modifcators are set to NONE (control will not be added).\n"),(LPCTSTR)s);

#endif

        return NULL;

    }



    //

    // check whether we have useful values;

    // NOTE exMaximum == 100

    //



    ASSERT((dX1pcnt <= exMaximum) && (dX2pcnt <= exMaximum) && (dY1pcnt <= exMaximum) && (dY2pcnt <= exMaximum));



    ControlInfo *ci;



    if(!( ci = new ControlInfo(*this,ctrl,dX1pcnt,dX2pcnt,dY1pcnt,dY2pcnt) ))

    {

        ASSERT(false);

        AfxThrowMemoryException();

    }

    CRect   r;m_pWnd->GetClientRect(&r);

    ci->AdaptControlSize(r.Width() - m_iClientWid,r.Height() - m_iClientHi);

    return ci;

}



/////////////////////////////////////////////////////////////////////////////

// Additional utilities

/////////////////////////////////////////////////////////////////////////////



/*

 * store window position to registry

 */



bool cdxCSizingDialog::ControlInfo::Header::StoreWindowPosition(const CString & profileSec)

{

    ASSERT(IsValid() && !profileSec.IsEmpty()); // can't use an empty profile section string; see CWinApp::GetProfileInt() for further information



    if(m_iClientWid != -1)

    {

        WINDOWPLACEMENT wpl;



        if(!m_pWnd->GetWindowPlacement(&wpl))

            return false;



        return  AfxGetApp()->WriteProfileInt(profileSec,    pfEntry_IsDone, ~const_IsDone) &&   // invalidate first

                    AfxGetApp()->WriteProfileInt(profileSec,    pfEntry_Left,       wpl.rcNormalPosition.left) &&

                    AfxGetApp()->WriteProfileInt(profileSec,    pfEntry_Right,      wpl.rcNormalPosition.right) &&

                    AfxGetApp()->WriteProfileInt(profileSec,    pfEntry_Top,        wpl.rcNormalPosition.top) &&

                    AfxGetApp()->WriteProfileInt(profileSec,    pfEntry_Bottom, wpl.rcNormalPosition.bottom) &&

                    AfxGetApp()->WriteProfileInt(profileSec,    pfEntry_State,      wpl.showCmd) &&

                    AfxGetApp()->WriteProfileInt(profileSec,    pfEntry_IsDone, const_IsDone);      // validate position

    }

    return false;

}



/*

 * Load window position from registry

 */



bool cdxCSizingDialog::ControlInfo::Header::RestoreWindowPosition(const CString & profileSec, bool withState)

{

    ASSERT(IsValid() && !profileSec.IsEmpty()); // can't use an empty profile section string; see CWinApp::GetProfileInt() for further information



    WINDOWPLACEMENT wpl;

    bool                    ok;



    if(!m_pWnd->GetWindowPlacement(&wpl))

    {

#ifdef _DEBUG

        CString s;m_pWnd->GetWindowText(s);

        if(s.IsEmpty())

            s.Format(_T("<Address_0x%lx"),(UINT)this);

        TRACE1(_T("*** ERROR[cdxCSizingDialog::ControlInfo::Header::RestoreWindowPosition()]: GetWindowPlacement() failed for dialog with caption \"%s\" !\n"),(LPCSTR)s);

#endif

        return false;

    }



    //

    // first, we check whether the position had been saved successful any time before

    //



    if( ok = (AfxGetApp()->GetProfileInt(profileSec,pfEntry_IsDone,0) == const_IsDone) )

    {

        // load previus session



        wpl.rcNormalPosition.left       =   AfxGetApp()->GetProfileInt(profileSec,  pfEntry_Left,       wpl.rcNormalPosition.left);

        wpl.rcNormalPosition.right      =   AfxGetApp()->GetProfileInt(profileSec,  pfEntry_Right,      wpl.rcNormalPosition.right);

        wpl.rcNormalPosition.top        =   AfxGetApp()->GetProfileInt(profileSec,  pfEntry_Top,        wpl.rcNormalPosition.top);

        wpl.rcNormalPosition.bottom =   AfxGetApp()->GetProfileInt(profileSec,  pfEntry_Bottom, wpl.rcNormalPosition.bottom);

        wpl.showCmd                         =   AfxGetApp()->GetProfileInt(profileSec,  pfEntry_State,      wpl.showCmd);



        if(!withState)

            wpl.showCmd =   0;



        ok  =   m_pWnd->SetWindowPlacement(&wpl) != FALSE;

    }



    return ok;

}



/////////////////////////////////////////////////////////////////////////////

// cdxCSizingDialog::ControlInfo

/////////////////////////////////////////////////////////////////////////////



/////////////////////////////////////////////////////////////////////////////

// construction

/////////////////////////////////////////////////////////////////////////////



/*

 * class basics

 */



cdxCSizingDialog::ControlInfo::ControlInfo(Header & hd, CWnd & wnd, BYTE dX1pcnt, BYTE dX2pcnt, BYTE dY1pcnt, BYTE dY2pcnt)

:   m_rHeader(hd), m_Link(wnd), m_dX1pcnt(dX1pcnt), m_dX2pcnt(dX2pcnt), m_dY1pcnt(dY1pcnt), m_dY2pcnt(dY2pcnt)

{

    WINDOWPLACEMENT wpl;

    wnd.GetWindowPlacement(&wpl);

    

    m_X1    =   wpl.rcNormalPosition.left;

    m_Y1    =   wpl.rcNormalPosition.top;

    m_X2    =   wpl.rcNormalPosition.right;

    m_Y2    =   wpl.rcNormalPosition.bottom;



    if(m_pNext = hd)

        m_pNext->m_pPrev    =   this;

    m_pPrev =   NULL;

    hd          =   this;

}



cdxCSizingDialog::ControlInfo::~ControlInfo()

{

    m_Link.Empty();     // delete all equal controls



    if(!m_pPrev)

    {

        ASSERT( ((ControlInfo *)m_rHeader) == this);        // should be mine :)

        if(m_rHeader = m_pNext)

            m_pNext->m_pPrev    =   NULL;

    }

    else

    {

        if(m_pPrev->m_pNext = m_pNext)

            m_pNext->m_pPrev    =   m_pPrev;

    }

}



/////////////////////////////////////////////////////////////////////////////



void cdxCSizingDialog::ControlInfo::AddEqualCtrl(CWnd & ctrl)

{

    if(!( new EqualCtrl(m_Link,ctrl) ))

    {

        ASSERT(false);

        AfxThrowMemoryException();

    }

}



/////////////////////////////////////////////////////////////////////////////

// do something :)

/////////////////////////////////////////////////////////////////////////////



/*

 * action

 */



void cdxCSizingDialog::ControlInfo::AdaptControlSize(register int deltaX, register int deltaY)

{

    ASSERT((deltaX >= 0) && (deltaY >= 0));

    register int    x1,y1,x2,y2,i;



    // NOTE: Resizing is even needed if both values are zero

    // (to resize the controls to their default position)



    x1  =   m_X1;

    y1  =   m_Y1;

    x2  =   m_X2;

    y2  =   m_Y2;



    if(deltaX)

    {

        if(i = m_dX1pcnt)           // NOTE exIgnore == 0

            x1  +=  (deltaX * i) / 100;

        if(i = m_dX2pcnt)           // NOTE exIgnore == 0

            x2  +=  (deltaX * i) / 100;

    }



    if(deltaY)

    {

        if(i = m_dY1pcnt)           // NOTE exIgnore == 0

            y1  +=  (deltaY * i) / 100;

        if(i = m_dY2pcnt)           // NOTE exIgnore == 0

            y2  +=  (deltaY * i) / 100;

    }

    

    for(register EqualCtrl *ec = &m_Link; ec; ec = ec->GetNext())

    {

        if(::IsWindow(ec->GetCtrl().m_hWnd))

        {

#ifdef _DEBUG

            ASSERT( ec->GetCtrl().SetWindowPos(&wndTop,x1,y1,x2-x1,y2-y1,SWP_NOREDRAW|SWP_NOZORDER) );

#else

            ec->GetCtrl().SetWindowPos(&wndTop,x1,y1,x2-x1,y2-y1,SWP_NOREDRAW|SWP_NOZORDER);

#endif

        }

    }

}





/////////////////////////////////////////////////////////////////////////////

// cdxCSizingDialog dialog

/////////////////////////////////////////////////////////////////////////////



/////////////////////////////////////////////////////////////////////////////

// construction

/////////////////////////////////////////////////////////////////////////////



void cdxCSizingDialog::DoDataExchange(CDataExchange* pDX)

{

    CDialog::DoDataExchange(pDX);

    //{{AFX_DATA_MAP(cdxCSizingDialog)

        // NOTE: the ClassWizard will add DDX and DDV calls here

    //}}AFX_DATA_MAP

}



BEGIN_MESSAGE_MAP(cdxCSizingDialog, CDialog)

    //{{AFX_MSG_MAP(cdxCSizingDialog)

    ON_WM_SIZE()

    ON_WM_GETMINMAXINFO()

    //}}AFX_MSG_MAP

END_MESSAGE_MAP()



/////////////////////////////////////////////////////////////////////////////

// cdxCSizingDialog message handlers

/////////////////////////////////////////////////////////////////////////////



/*

 * set up dialog; this function MUST be called before you add any controls

 * NOTE: The real OnInitDialog() virtual function calls this one by using

 * DEF_STRETCH as a addSzByPcntValue.

 * This value automatically grows the size of the dialog (therefore it

 * won't appear in minimum height what I assume to be worse looking).

 * Call it with a value of 0 to make it as small as you designed it

 * in the resource editor.

 */



BOOL cdxCSizingDialog::OnInitDialog(UINT addSzByPcnt) 

{

    CDialog::OnInitDialog();

    return m_Controls.OnInitDialog(addSzByPcnt);

}



/*

 * perform window sizing and adaption of controls

 */



void cdxCSizingDialog::OnSize(UINT nType, int cx, int cy) 

{

    m_Controls.OnSize(nType,cx,cy);

    CDialog::OnSize(nType, cx, cy);

}



/*

 * tell system what minimum size we have

 */



void cdxCSizingDialog::OnGetMinMaxInfo(MINMAXINFO FAR* lpMMI) 

{

    CDialog::OnGetMinMaxInfo(lpMMI);

    m_Controls.OnGetMinMaxInfo(lpMMI);

}



/////////////////////////////////////////////////////////////////////////////

// Additional utilities

/////////////////////////////////////////////////////////////////////////////



/*

 * pump all messages for this window

 * call it during lengthy operations to ensure

 * sizing takes place

 */



void cdxCSizingDialog::PumpMessages(void)

{

    // Must call Create() before using the dialog

    ASSERT(::IsWindow(m_hWnd));



    MSG msg;

    // Handle dialog messages for all windows 

    while(::PeekMessage(&msg, m_hWnd, 0, 0, PM_REMOVE))

    {

        if(!CDialog::IsDialogMessage(&msg))     // not used by our dialog

        {

            ::TranslateMessage(&msg);               // pass to application

            ::DispatchMessage(&msg);  

        }

    }

}











/////////////////////////////////////////////////////////////////////////////

// cdxCSizingPropSheet

/////////////////////////////////////////////////////////////////////////////



IMPLEMENT_DYNAMIC(cdxCSizingPropSheet, CPropertySheet)



/////////////////////////////////////////////////////////////////////////////

// creation etc.

/////////////////////////////////////////////////////////////////////////////



BEGIN_MESSAGE_MAP(cdxCSizingPropSheet, CPropertySheet)

    //{{AFX_MSG_MAP(cdxCSizingPropSheet)

    ON_WM_CREATE()

    ON_WM_SIZE()

    ON_WM_GETMINMAXINFO()

    //}}AFX_MSG_MAP

END_MESSAGE_MAP()



/////////////////////////////////////////////////////////////////////////////

// cdxCSizingPropSheet message handlers



/*

 * setup controls

 */



BOOL cdxCSizingPropSheet::OnInitDialog(UINT addSzByPcnt) 

{

    BOOL bResult = CPropertySheet::OnInitDialog();  

    m_Controls.OnInitDialog(addSzByPcnt);



    //

    // now we like to add all pages

    //



    int i;

    CWnd    *w  =   CPropertySheet::GetActivePage(),

            *helpBut    =   NULL;



    if(!w || !::IsWindow(w->m_hWnd))

    {

        ASSERT(false);

        // ugly...

        // it will work but will even look quite ugly.

        // reason: No page !

    }

    else

    {

        cdxCSizingDialog::ControlInfo   *ci;

        ci  =   m_Controls.AddSzControl(*w,cdxCSizingDialog::mdResize,cdxCSizingDialog::mdResize);

        if(ci)

        {

            CWnd    *ow;

            for(i=0; i<CPropertySheet::GetPageCount(); ++i)

                if(ow = CPropertySheet::GetPage(i))

                    ci->AddEqualCtrl(*ow);      // thus they'll be sized the same way :)

        }

    }



    //

    // add buttons, tab and bevel line

    //

    

    for(i=0; psheetCtrls[i].id != BAD_ID; ++i)

    {

        if(w = CPropertySheet::GetDlgItem(psheetCtrls[i].id))

        {

            if(psheetCtrls[i].id == IDHELP)

            {

                ASSERT(helpBut == NULL);        // only one ?

                helpBut =   w;

            }

            m_Controls.AddSzControl(*w,psheetCtrls[i].modeX,psheetCtrls[i].modeY);

        }

        else

        {

            TRACE1(_T("*** WARNING[cdxCSizingPropSheet::OnInitDialog()]: Can't find CWnd for ID#%ld !\n"),psheetCtrls[i].id);

        }

    }



    if(helpBut && (w = m_Controls.GetSizeIconCtrl()))

        w->SetWindowPos(helpBut,0,0,0,0,SWP_NOACTIVATE|SWP_NOMOVE|SWP_NOSIZE);



    return bResult;

}





/*

 * add sizing style

 */



int cdxCSizingPropSheet::OnCreate(LPCREATESTRUCT lpCreateStruct) 

{

    if (CPropertySheet::OnCreate(lpCreateStruct) == -1)

        return -1;

    

    ModifyStyle(0,WS_THICKFRAME|WS_SYSMENU);

    return 0;

}



/*

 * change size

 */



void cdxCSizingPropSheet::OnSize(UINT nType, int cx, int cy) 

{

    CPropertySheet::OnSize(nType, cx, cy);

    m_Controls.OnSize(nType,cx,cy);

}



void cdxCSizingPropSheet::OnGetMinMaxInfo(MINMAXINFO FAR* lpMMI) 

{

    CPropertySheet::OnGetMinMaxInfo(lpMMI);

    m_Controls.OnGetMinMaxInfo(lpMMI);

}



/*

 * our overload

 */



void cdxCSizingPropSheet::AddPage( cdxCSizingPropPage & rPage )

{

    CPropertySheet::AddPage(&rPage);

    rPage.Init(*this);

}



/////////////////////////////////////////////////////////////////////////////

// cdxCSizingPropPage

/////////////////////////////////////////////////////////////////////////////



IMPLEMENT_DYNCREATE(cdxCSizingPropPage,CPropertyPage);



/////////////////////////////////////////////////////////////////////////////

// cdxCSizingDialog message handlers

/////////////////////////////////////////////////////////////////////////////



void cdxCSizingPropPage::DoDataExchange(CDataExchange* pDX)

{

    CPropertyPage::DoDataExchange(pDX);

    //{{AFX_DATA_MAP(cdxCSizingPropPage)

        // NOTE: the ClassWizard will add DDX and DDV calls here

    //}}AFX_DATA_MAP

}





BEGIN_MESSAGE_MAP(cdxCSizingPropPage, CPropertyPage)

    //{{AFX_MSG_MAP(cdxCSizingPropPage)

    ON_WM_SIZE()

    //}}AFX_MSG_MAP

END_MESSAGE_MAP()



/////////////////////////////////////////////////////////////////////////////

// cdxCSizingPropPage basics

/////////////////////////////////////////////////////////////////////////////



BOOL cdxCSizingPropPage::OnInitDialog() 

{

    BOOL    bOk =   CPropertyPage::OnInitDialog();

    m_Controls.OnInitDialog(0);

    

    return bOk;

}



void cdxCSizingPropPage::OnSize(UINT nType, int cx, int cy) 

{

    m_Controls.OnSize(nType,cx,cy);

    CPropertyPage::OnSize(nType, cx, cy);

}




pdfviewerocx/CPP/cdxCSizingDialog.h
#if !defined(AFX_CDXCSIZINGDIALOG_H__1D0F68C2_BF90_11D1_A589_444553540000__INCLUDED_)
#define AFX_CDXCSIZINGDIALOG_H__1D0F68C2_BF90_11D1_A589_444553540000__INCLUDED_

#if _MSC_VER >= 1000
#pragma once
#endif // _MSC_VER >= 1000
//
// cdxCSizingDialog.h : header file
// --------------------------------
// Author:  Hans Bühler (hb@codex.ro), Germany/Berlin
//          codex design (http://wwww.codex.ro
// Version: 1.2
// Release: 1 (May 1998 to www.codeguru.com)
// ---------------------------------
// Comments welcome.

/*
 * cdxCSizingDialog[CDialog]
 * =========================
 * A CDialog dervied class that implements a sizable dialog class.

 HOW TO USE:

 - Create your dialog with the minimum size it should have.
   Even create a class for it:
	a) if you are able to use cdxCSizingDialog, use it as base class.
	b) otherwise, use CDialog;
	   open both the header and the implementation file and do a
		find/replace on CDialog => cdxCSizingDialog.
 - In the constructor of your class, use the Freedom parameter
   to decide in what direction (or both) your dialog should
	be changed in size.
	By default, the dialog would be sizable in both x and y direction.
 - If you don't want a little windows-standard sizing icon in your lower
	right corner, set the fourth parameter of the constructor to false.
 - In your OnInitDialog() routine,
   * first call cdxCSizingDialog::OnInitDialog(),
	* then use the AddSzControl() member function for any control that
     should handle window size change.
	  AddSzControl() will allow to reposition, resize and center
	  controls.
	  For more advanced use, have a look at AddSzControlEx().
 - If you use OnSize(), call the base class function first !!

 FURTHER UTILITIES:

 - PumpMessages() empties the windows message queue.
   Use it in lengthy operations to ensure the window will react
	on user size changes.
 - Use StoreWindowPosition() and RestoreWindowPosition() to save and
   load your window's size and position from the registry.

 *
 * (c)Mar.1998 Hans Bühler, codex design; hb@codex.ro | http://www.codex.ro
 *    Note usage license.
 */

class cdxCSizingDialog;
class cdxCSizingPropSheet;
class cdxCSizingPropPage;

/////////////////////////////////////////////////////////////////////////////
// cdxCSizingDialog dialog

class cdxCSizingDialog : public CDialog
{
	/*
	 * some constants
	 */

public:
	enum Mode		// flags for AddSzControl()
	{
		mdNone		=	0,		// does nothing
		mdResize		=	1,		// resize in that dimension
		mdRepos		=	2,		// reposition
		mdRelative	=	3,		// center (size by delta/2 and repos by delta/2)
		md__Num		=	4
	};

	enum Freedom	// for cdxSizingCDialog()
	{
		fdNone		=	0,		// might be used but I don't imagine what you want from this ??
		fdHoriz		=	0x01,				// horizantally sizable only
		fdVert		=	0x02,				// vertically sizable only
		fdAll			=	fdHoriz|fdVert	// sizable in all directions
	};

	enum ExConstants
	{
		exIgnore		=	0,		// ignore this AddSzControlEx() value
		exMaximum	=	100,	// modify coordinate by xnew = xdef + (delta * exMaximum)/dx
		DEF_STRETCH	=	10		// default stretch size
	};

	/*
	 * management storage classes
	 */

public:
	class ControlInfo
	{
	public:
		//
		// the real manager class
		//
		class Header
		{
		private:
			enum { const_IsDone = 0x7f7f };

		protected:
			ControlInfo	*m_pFirst;
			CWnd			*m_pWnd;			// Use Init() !!!!!!!!!
			int			m_iClientWid,m_iClientHi,
							m_iMinWid,m_iMinHi;
			Freedom		m_Freedom;
			CStatic		m_wndSizeIcon;		// the icon control
			CBitmap		m_bmSizeIcon;		// the bitmap
			bool			m_bSizeIcon;		// true if icon is displayed

		public:
			Header(Freedom fd, bool bSizeIcon) : m_pFirst(NULL), m_iClientWid(-1), m_Freedom(fd), m_bSizeIcon(bSizeIcon), m_pWnd(NULL) {}
			virtual ~Header() { Detach(); }

			bool IsValid(void) const { return (m_pWnd != NULL) && ::IsWindow(m_pWnd->m_hWnd); }

			void Init(CWnd & w) { ASSERT(m_pWnd == NULL); m_pWnd = &w; }
			void Detach(void) { while(m_pFirst) delete m_pFirst; }

			operator ControlInfo * () { return m_pFirst; }
			Header & operator=(ControlInfo *c) { m_pFirst = c; return *this; }

			// for our derived classes

			bool RestoreWindowPosition(const CString & profileSec, bool withState);
			bool StoreWindowPosition(const CString & profileSec);
			void StretchWindow(UINT addSzByPcnt);

			bool ReorganizeControls(void);		// call to reposition controls
			void PumpMessages(void);				// just an utility

			ControlInfo *AddSzControl(CWnd & ctrl, Mode modeX, Mode modeY);
			ControlInfo *AddSzControlEx(CWnd & ctrl, BYTE dX1pcnt, BYTE dX2pcnt, BYTE dY1pcnt, BYTE dY2pcnt);

			bool ChangeSize(int newWid, int newHi);

			BOOL OnInitDialog(UINT addSzByPcnt);
			void OnGetMinMaxInfo(MINMAXINFO FAR* lpMMI);
			void OnSize(UINT nType, int cx, int cy);

			// utility

			CStatic *GetSizeIconCtrl(void) { return m_bSizeIcon ? &m_wndSizeIcon : NULL; }
		};

		//
		// for mututally displayed equal sized controls
		// (size will be applied to all but visible)
		//

		class EqualCtrl
		{
		protected:
			EqualCtrl	*m_pNext;
			CWnd			& m_rCtrl;

		public:
			EqualCtrl(CWnd & w) : m_pNext(NULL), m_rCtrl(w) {}
			EqualCtrl(EqualCtrl & prev, CWnd & w) : m_pNext(NULL), m_rCtrl(w)
			{	
				EqualCtrl	*next	=	prev.m_pNext;
				prev.m_pNext = this;
				m_pNext = next;
			}
			virtual ~EqualCtrl()	{ Empty(); }

			CWnd & GetCtrl(void) { return m_rCtrl; }
			EqualCtrl *GetNext(void) { return m_pNext; }

			void Empty(void)  { if(m_pNext) delete m_pNext; m_pNext = NULL; }
		};

	protected:
		ControlInfo	*m_pNext,*m_pPrev;
		Header		& m_rHeader;
		EqualCtrl	m_Link;
		BYTE			m_dX1pcnt,m_dX2pcnt,
						m_dY1pcnt,m_dY2pcnt;	// percentage values of deltaX(Y) to add to coordinate
		DWORD			m_X1,m_Y1,m_X2,m_Y2;	// original positions

	public:
		ControlInfo(Header & hd, CWnd & wnd, BYTE dX1pcnt, BYTE dX2pcnt, BYTE dY1pcnt, BYTE dY2pcnt);
		virtual ~ControlInfo();

		ControlInfo *GetNext(void) { return m_pNext; }
		void AddEqualCtrl(CWnd & ctrl);
		void AdaptControlSize(register int deltaX, register int deltaY);
	};

	/*
	 * members
	 */

private:
	ControlInfo::Header	m_Controls;

	// Construction
protected:
	cdxCSizingDialog(UINT idd, CWnd* pParent = NULL, Freedom fd = fdAll, bool mkSizeIcon = true)
	:	CDialog(idd, pParent), m_Controls(fd,mkSizeIcon) {	m_Controls.Init(*this);	}
public:
	virtual ~cdxCSizingDialog() { DestroyWindow(); }

	// load/store window position to registry
	bool RestoreWindowPosition(const CString & profileSec, bool withState = false) { return m_Controls.RestoreWindowPosition(profileSec,withState); }
	bool StoreWindowPosition(const CString & profileSec) { return m_Controls.StoreWindowPosition(profileSec); }
	bool RestoreWindowPosition(UINT strId, bool withState = false) { CString s;s.LoadString(strId); return RestoreWindowPosition(s,withState); }
	bool StoreWindowPosition(UINT strId) { CString s;s.LoadString(strId); return StoreWindowPosition(s); }

	// stretch window size
	void StretchWindow(UINT addSzByPcnt = DEF_STRETCH) { m_Controls.StretchWindow(addSzByPcnt); }

	// reapply window size
	bool ReorganizeControls(void) { return m_Controls.ReorganizeControls(); }

	// process all messages of the dialog
	void PumpMessages(void);				// just an utility

	// detach controls
	virtual BOOL DestroyWindow(void) { m_Controls.Detach(); return CDialog::DestroyWindow(); }

	//
	// these are those functions you'll be interested in
	//
protected:
	void AddSzControl(CWnd & ctrl, Mode modeX = mdNone, Mode modeY = mdNone) { m_Controls.AddSzControl(ctrl,modeX,modeY); }
	void AddSzXControl(CWnd & ctrl, Mode modeX) { AddSzControl(ctrl,modeX,mdNone); }
	void AddSzYControl(CWnd & ctrl, Mode modeY) { AddSzControl(ctrl,mdNone,modeY); }
	void AddSzControlEx(CWnd & ctrl, BYTE dX1pcnt, BYTE dX2pcnt, BYTE dY1pcnt, BYTE dY2pcnt) { m_Controls.AddSzControlEx(ctrl,dX1pcnt,dX2pcnt,dY1pcnt,dY2pcnt); }
	void AddSzXControlEx(CWnd & ctrl, BYTE dX1pcnt, BYTE dX2pcnt) { AddSzControlEx(ctrl,dX1pcnt,dX2pcnt,exIgnore,exIgnore); }
	void AddSzYControlEx(CWnd & ctrl, BYTE dY1pcnt, BYTE dY2pcnt) { AddSzControlEx(ctrl,exIgnore,exIgnore,dY1pcnt,dY2pcnt); }

private:
	bool ChangeSize(int newWid, int newHi) { return m_Controls.ChangeSize(newWid,newHi); }

// Dialog Data
	//{{AFX_DATA(cdxCSizingDialog)
	enum { IDD = 0 };
		// NOTE: the ClassWizard will add data members here
	//}}AFX_DATA


// Overrides
	// ClassWizard generated virtual function overrides
	//{{AFX_VIRTUAL(cdxCSizingDialog)
	protected:
	virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
	//}}AFX_VIRTUAL

// Implementation
protected:
	virtual BOOL OnInitDialog(UINT addSzByPcnt);
	virtual BOOL OnInitDialog() { return OnInitDialog(exIgnore); }

	// Generated message map functions
	//{{AFX_MSG(cdxCSizingDialog)
	afx_msg void OnGetMinMaxInfo(MINMAXINFO FAR* lpMMI);
	afx_msg void OnSize(UINT nType, int cx, int cy);
	//}}AFX_MSG
	DECLARE_MESSAGE_MAP()
};

/////////////////////////////////////////////////////////////////////////////

/*
 * cdxCSizingPropSheet
 * ===================
 * A friend class that even uses the facilities of a cdxCSizingDialog

 HOW TO USE:

 - Instead of CPropertySheet, derive your class from this class.
 - Derive all your pages from cdxCSizingPropPage, NOT from CPropertyPage.
 - Done :)

 */

class cdxCSizingPropSheet : public CPropertySheet
{
	DECLARE_DYNAMIC(cdxCSizingPropSheet)

public:
	struct StandardControls
	{
		UINT							id;	// ID
		cdxCSizingDialog::Mode	modeX,modeY;
	};

	/*
	 * members
	 */

private:
	cdxCSizingDialog::ControlInfo::Header	m_Controls;

public:
	cdxCSizingPropSheet(UINT nIDCaption, CWnd* pParentWnd = NULL, UINT iSelectPage = 0, cdxCSizingDialog::Freedom fd = cdxCSizingDialog::fdAll, bool mkSizeIcon = false)
	:	CPropertySheet(nIDCaption, pParentWnd, iSelectPage), m_Controls(fd,mkSizeIcon) {	m_Controls.Init(*this); }
	cdxCSizingPropSheet(LPCTSTR pszCaption, CWnd* pParentWnd = NULL, UINT iSelectPage = 0, cdxCSizingDialog::Freedom fd = cdxCSizingDialog::fdAll, bool mkSizeIcon = false)
	:	CPropertySheet(pszCaption, pParentWnd, iSelectPage), m_Controls(fd,mkSizeIcon) {	m_Controls.Init(*this); }
	virtual ~cdxCSizingPropSheet() { DestroyWindow(); }

	// window position in the registry
	bool RestoreWindowPosition(const CString & profileSec, bool withState = false) { return m_Controls.RestoreWindowPosition(profileSec,withState); }
	bool StoreWindowPosition(const CString & profileSec) { return m_Controls.StoreWindowPosition(profileSec); }
	bool RestoreWindowPosition(UINT strId, bool withState = false) { CString s;s.LoadString(strId); return RestoreWindowPosition(s,withState); }
	bool StoreWindowPosition(UINT strId) { CString s;s.LoadString(strId); return StoreWindowPosition(s); }
	// stretch window size
	void StretchWindow(UINT addSzByPcnt = 15) { m_Controls.StretchWindow(addSzByPcnt); }

	// reapply window size
	bool ReorganizeControls(void) { if(!m_Controls.ReorganizeControls()) return false; RedrawWindow(); return true; }

	// add a cdxCSizingPropPage to your sheet
	void AddPage( cdxCSizingPropPage *pPage ) { ASSERT(pPage != NULL); AddPage(*pPage); }
	void AddPage( cdxCSizingPropPage & rPage );

	virtual BOOL DestroyWindow(void) { m_Controls.Detach(); return CPropertySheet::DestroyWindow(); }

private:
	// please don't use this one !
	void AddPage( CPropertyPage *pPage ) { ASSERT(false); CPropertySheet::AddPage(pPage); }

// Operations
public:

// Overrides
	virtual BOOL OnInitDialog(UINT addSzByPcnt);
	virtual BOOL OnInitDialog() { return OnInitDialog(cdxCSizingDialog::DEF_STRETCH); }
	// ClassWizard generated virtual function overrides
	//{{AFX_VIRTUAL(cdxCSizingPropSheet)
	public:
	//}}AFX_VIRTUAL

// Implementation
public:

	// Generated message map functions
protected:
	//{{AFX_MSG(cdxCSizingPropSheet)
	afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
	afx_msg void OnSize(UINT nType, int cx, int cy);
	afx_msg void OnGetMinMaxInfo(MINMAXINFO FAR* lpMMI);
	//}}AFX_MSG
	DECLARE_MESSAGE_MAP()
};

/*
 * cdxCSizingPropPage
 * ==================
 * Base class for all propertypages that are embedded into a
 * cdxCSizingPropSheet
 */

class cdxCSizingPropPage : public CPropertyPage
{
	DECLARE_DYNCREATE(cdxCSizingPropPage)

public:

private:
	cdxCSizingDialog::ControlInfo::Header	m_Controls;
	cdxCSizingPropSheet							*m_pSheet;

private:
	cdxCSizingPropPage()
		:	CPropertyPage(), m_Controls(cdxCSizingDialog::fdAll,false), m_pSheet(NULL) {}
public:
	cdxCSizingPropPage(UINT idd, UINT nIDCaption = 0)
		:	CPropertyPage(idd,nIDCaption), m_Controls(cdxCSizingDialog::fdAll,false), m_pSheet(NULL)  { m_Controls.Init(*this); }
	cdxCSizingPropPage(LPCTSTR lpszTemplateName, UINT nIDCaption = 0)
		:	CPropertyPage(lpszTemplateName,nIDCaption), m_Controls(cdxCSizingDialog::fdAll,false), m_pSheet(NULL)  { m_Controls.Init(*this); }
	virtual ~cdxCSizingPropPage() { DestroyWindow(); }

	//
	// these are used by the cdxCSizingPropSheet -- you never need to make use of them !
	//
	bool IsInitialized(void) const { return m_pSheet != NULL; }
	void Init(cdxCSizingPropSheet & ps) { ASSERT(m_pSheet == NULL); m_pSheet = &ps; }

	//
	// these are those functions you'll be interested in
	//
protected:
	void AddSzControl(CWnd & ctrl, cdxCSizingDialog::Mode modeX = cdxCSizingDialog::mdNone, cdxCSizingDialog::Mode modeY = cdxCSizingDialog::mdNone) { m_Controls.AddSzControl(ctrl,modeX,modeY); }
	void AddSzXControl(CWnd & ctrl, cdxCSizingDialog::Mode modeX) { AddSzControl(ctrl,modeX,cdxCSizingDialog::mdNone); }
	void AddSzYControl(CWnd & ctrl, cdxCSizingDialog::Mode modeY) { AddSzControl(ctrl,cdxCSizingDialog::mdNone,modeY); }
	void AddSzControlEx(CWnd & ctrl, BYTE dX1pcnt, BYTE dX2pcnt, BYTE dY1pcnt, BYTE dY2pcnt) { m_Controls.AddSzControlEx(ctrl,dX1pcnt,dX2pcnt,dY1pcnt,dY2pcnt); }
	void AddSzXControlEx(CWnd & ctrl, BYTE dX1pcnt, BYTE dX2pcnt) { AddSzControlEx(ctrl,dX1pcnt,dX2pcnt,cdxCSizingDialog::exIgnore,cdxCSizingDialog::exIgnore); }
	void AddSzYControlEx(CWnd & ctrl, BYTE dY1pcnt, BYTE dY2pcnt) { AddSzControlEx(ctrl,cdxCSizingDialog::exIgnore,cdxCSizingDialog::exIgnore,dY1pcnt,dY2pcnt); }

	// reapply current size
	bool ReorganizeControls(void) { if(!m_Controls.ReorganizeControls()) return false; RedrawWindow(); return true; }
	// get sheet
	cdxCSizingPropSheet & GetSheet(void) { VERIFY(m_pSheet != NULL); /* you must use a cdxCSizingPropSheet */ return *m_pSheet; }

	// I need these
	virtual BOOL OnSetActive(void) { BOOL bOk = CPropertyPage::OnSetActive(); if(IsInitialized()) m_pSheet->ReorganizeControls(); ReorganizeControls(); return bOk; }
	virtual BOOL DestroyWindow(void) { m_Controls.Detach(); return CPropertyPage::DestroyWindow(); }

// Dialog Data
	//{{AFX_DATA(cdxCSizingPropPage)
	enum { IDD = 0 };
		// NOTE - ClassWizard will add data members here.
		//    DO NOT EDIT what you see in these blocks of generated code !
	//}}AFX_DATA

// Overrides
	// ClassWizard generate virtual function overrides
	//{{AFX_VIRTUAL(cdxCSizingPropPage)
	protected:
	virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
	//}}AFX_VIRTUAL

// Implementation
protected:
	// Generated message map functions
	//{{AFX_MSG(cdxCSizingPropPage)
	afx_msg void OnSize(UINT nType, int cx, int cy);
	virtual BOOL OnInitDialog();
	//}}AFX_MSG
	DECLARE_MESSAGE_MAP()

};


/////////////////////////////////////////////////////////////////////////////
//{{AFX_INSERT_LOCATION}}
// Microsoft Developer Studio will insert additional declarations immediately before the previous line.

#endif // !defined(AFX_CDXCSIZINGDIALOG_H__1D0F68C2_BF90_11D1_A589_444553540000__INCLUDED_)
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// NOTE: Do not modify the contents of this file.  If this class is regenerated by

//  Microsoft Visual C++, your modifications will be overwritten.





#include "stdafx.h"

#include "pdfview.h"



/////////////////////////////////////////////////////////////////////////////

// CPdfview



IMPLEMENT_DYNCREATE(CPdfview, CWnd)



/////////////////////////////////////////////////////////////////////////////

// CPdfview properties



/////////////////////////////////////////////////////////////////////////////

// CPdfview operations



BOOL CPdfview::OpenPDF(LPCTSTR lpszPDFFile, LPCTSTR lpszUserPwd, LPCTSTR lpszOwnerPwd)

{

    BOOL result;

    static BYTE parms[] =

        VTS_BSTR VTS_BSTR VTS_BSTR;

    InvokeHelper(0x1, DISPATCH_METHOD, VT_BOOL, (void*)&result, parms,

        lpszPDFFile, lpszUserPwd, lpszOwnerPwd);

    return result;

}



void CPdfview::ClosePDF()

{

    InvokeHelper(0x2, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



long CPdfview::RunCommand(long nCode, long nPara1, long nPara2, long nPara3)

{

    long result;

    static BYTE parms[] =

        VTS_I4 VTS_I4 VTS_I4 VTS_I4;

    InvokeHelper(0x3, DISPATCH_METHOD, VT_I4, (void*)&result, parms,

        nCode, nPara1, nPara2, nPara3);

    return result;

}



void CPdfview::SetFindText(LPCTSTR lpszFindText)

{

    static BYTE parms[] =

        VTS_BSTR;

    InvokeHelper(0x4, DISPATCH_METHOD, VT_EMPTY, NULL, parms,

         lpszFindText);

}



void CPdfview::SetViewMode(long nViewMode)

{

    static BYTE parms[] =

        VTS_I4;

    InvokeHelper(0x5, DISPATCH_METHOD, VT_EMPTY, NULL, parms,

         nViewMode);

}



void CPdfview::RotateViewLeft()

{

    InvokeHelper(0x6, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::RotateViewRight()

{

    InvokeHelper(0x7, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::ViewNextPage()

{

    InvokeHelper(0x8, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::ViewPreviousPage()

{

    InvokeHelper(0x9, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::ViewFirstPage()

{

    InvokeHelper(0xa, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::ViewLastPage()

{

    InvokeHelper(0xb, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::ViewPage()

{

    InvokeHelper(0xc, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::FindPreviousText()

{

    InvokeHelper(0xd, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::FindNextText()

{

    InvokeHelper(0xe, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::ZoomFitPage()

{

    InvokeHelper(0xf, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::ZoomActualPage()

{

    InvokeHelper(0x10, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::ZoomFitWidth()

{

    InvokeHelper(0x11, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::Zoom(float nZoom)

{

    static BYTE parms[] =

        VTS_R4;

    InvokeHelper(0x12, DISPATCH_METHOD, VT_EMPTY, NULL, parms,

         nZoom);

}



void CPdfview::ViewModeSinglePage()

{

    InvokeHelper(0x13, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::ViewModeFacing()

{

    InvokeHelper(0x14, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::ViewModeContinuous()

{

    InvokeHelper(0x15, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::ViewModeContinuousFacing()

{

    InvokeHelper(0x16, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::ShowHideBookmarks()

{

    InvokeHelper(0x17, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::SetRegCode(LPCTSTR lpszRegCode)

{

    static BYTE parms[] =

        VTS_BSTR;

    InvokeHelper(0x18, DISPATCH_METHOD, VT_EMPTY, NULL, parms,

         lpszRegCode);

}



void CPdfview::ZoomIn()

{

    InvokeHelper(0x19, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::ZoomOut()

{

    InvokeHelper(0x1a, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



void CPdfview::ViewGotoPage(long nPageIndex)

{

    static BYTE parms[] =

        VTS_I4;

    InvokeHelper(0x1b, DISPATCH_METHOD, VT_EMPTY, NULL, parms,

         nPageIndex);

}



long CPdfview::SetGotoPageNumber(long nPageIndex)

{

    long result;

    static BYTE parms[] =

        VTS_I4;

    InvokeHelper(0x1c, DISPATCH_METHOD, VT_I4, (void*)&result, parms,

        nPageIndex);

    return result;

}



long CPdfview::GetCurrentPage()

{

    long result;

    InvokeHelper(0x1d, DISPATCH_METHOD, VT_I4, (void*)&result, NULL);

    return result;

}



long CPdfview::GetPageTotalCount()

{

    long result;

    InvokeHelper(0x1e, DISPATCH_METHOD, VT_I4, (void*)&result, NULL);

    return result;

}



float CPdfview::GetCurrentZoom()

{

    float result;

    InvokeHelper(0x1f, DISPATCH_METHOD, VT_R4, (void*)&result, NULL);

    return result;

}



void CPdfview::SetMsgCallbackWnd(long hMsgWnd)

{

    static BYTE parms[] =

        VTS_I4;

    InvokeHelper(0x20, DISPATCH_METHOD, VT_EMPTY, NULL, parms,

         hMsgWnd);

}



long CPdfview::FlattenPDF(LPCTSTR lpszInPDF, LPCTSTR lpszOutPDF)

{

    long result;

    static BYTE parms[] =

        VTS_BSTR VTS_BSTR;

    InvokeHelper(0x21, DISPATCH_METHOD, VT_I4, (void*)&result, parms,

        lpszInPDF, lpszOutPDF);

    return result;

}



BOOL CPdfview::EnableAnnotations(BOOL bEnable)

{

    BOOL result;

    static BYTE parms[] =

        VTS_BOOL;

    InvokeHelper(0x22, DISPATCH_METHOD, VT_BOOL, (void*)&result, parms,

        bEnable);

    return result;

}



BOOL CPdfview::OpenPDFFromMem(long lpPDFData, long nPDFDataLen, LPCTSTR lpszUserPwd, LPCTSTR lpszOwnerPwd)

{

    BOOL result;

    static BYTE parms[] =

        VTS_I4 VTS_I4 VTS_BSTR VTS_BSTR;

    InvokeHelper(0x23, DISPATCH_METHOD, VT_BOOL, (void*)&result, parms,

        lpPDFData, nPDFDataLen, lpszUserPwd, lpszOwnerPwd);

    return result;

}



long CPdfview::EnableLaunchLink(long bEnable)

{

    long result;

    static BYTE parms[] =

        VTS_I4;

    InvokeHelper(0x24, DISPATCH_METHOD, VT_I4, (void*)&result, parms,

        bEnable);

    return result;

}



long CPdfview::EnableMouseWhellInFacingMode(long bEnable)

{

    long result;

    static BYTE parms[] =

        VTS_I4;

    InvokeHelper(0x25, DISPATCH_METHOD, VT_I4, (void*)&result, parms,

        bEnable);

    return result;

}



long CPdfview::GetScrollBar()

{

    long result;

    InvokeHelper(0x26, DISPATCH_METHOD, VT_I4, (void*)&result, NULL);

    return result;

}



void CPdfview::ViewModeBook()

{

    InvokeHelper(0x27, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}



long CPdfview::ShowScrollBar(BOOL bShow)

{

    long result;

    static BYTE parms[] =

        VTS_BOOL;

    InvokeHelper(0x28, DISPATCH_METHOD, VT_I4, (void*)&result, parms,

        bShow);

    return result;

}



BOOL CPdfview::IsScrollBarShown()

{

    BOOL result;

    InvokeHelper(0x29, DISPATCH_METHOD, VT_BOOL, (void*)&result, NULL);

    return result;

}



long CPdfview::ShowContextMenu(BOOL bShow)

{

    long result;

    static BYTE parms[] =

        VTS_BOOL;

    InvokeHelper(0x2a, DISPATCH_METHOD, VT_I4, (void*)&result, parms,

        bShow);

    return result;

}



BOOL CPdfview::IsContextMenuShown()

{

    BOOL result;

    InvokeHelper(0x2b, DISPATCH_METHOD, VT_BOOL, (void*)&result, NULL);

    return result;

}



void CPdfview::AboutBox()

{

    InvokeHelper(0xfffffdd8, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);

}




pdfviewerocx/CPP/pdfview.h
// Machine generated IDispatch wrapper class(es) created by Microsoft Visual C++

// NOTE: Do not modify the contents of this file.  If this class is regenerated by
//  Microsoft Visual C++, your modifications will be overwritten.

/////////////////////////////////////////////////////////////////////////////
// CPdfview wrapper class

class CPdfview : public CWnd
{
protected:
	DECLARE_DYNCREATE(CPdfview)
public:
	CLSID const& GetClsid()
	{
		static CLSID const clsid
			= { 0x433268d7, 0x2cd4, 0x43e6, { 0xaa, 0x24, 0x21, 0x88, 0x67, 0x2e, 0x72, 0x52 } };
		return clsid;
	}
	virtual BOOL Create(LPCTSTR lpszClassName,
		LPCTSTR lpszWindowName, DWORD dwStyle,
		const RECT& rect,
		CWnd* pParentWnd, UINT nID,
		CCreateContext* pContext = NULL)
	{ return CreateControl(GetClsid(), lpszWindowName, dwStyle, rect, pParentWnd, nID); }

    BOOL Create(LPCTSTR lpszWindowName, DWORD dwStyle,
		const RECT& rect, CWnd* pParentWnd, UINT nID,
		CFile* pPersist = NULL, BOOL bStorage = FALSE,
		BSTR bstrLicKey = NULL)
	{ return CreateControl(GetClsid(), lpszWindowName, dwStyle, rect, pParentWnd, nID,
		pPersist, bStorage, bstrLicKey); }

// Attributes
public:

// Operations
public:
	BOOL OpenPDF(LPCTSTR lpszPDFFile, LPCTSTR lpszUserPwd, LPCTSTR lpszOwnerPwd);
	void ClosePDF();
	long RunCommand(long nCode, long nPara1, long nPara2, long nPara3);
	void SetFindText(LPCTSTR lpszFindText);
	void SetViewMode(long nViewMode);
	void RotateViewLeft();
	void RotateViewRight();
	void ViewNextPage();
	void ViewPreviousPage();
	void ViewFirstPage();
	void ViewLastPage();
	void ViewPage();
	void FindPreviousText();
	void FindNextText();
	void ZoomFitPage();
	void ZoomActualPage();
	void ZoomFitWidth();
	void Zoom(float nZoom);
	void ViewModeSinglePage();
	void ViewModeFacing();
	void ViewModeContinuous();
	void ViewModeContinuousFacing();
	void ShowHideBookmarks();
	void SetRegCode(LPCTSTR lpszRegCode);
	void ZoomIn();
	void ZoomOut();
	void ViewGotoPage(long nPageIndex);
	long SetGotoPageNumber(long nPageIndex);
	long GetCurrentPage();
	long GetPageTotalCount();
	float GetCurrentZoom();
	void SetMsgCallbackWnd(long hMsgWnd);
	long FlattenPDF(LPCTSTR lpszInPDF, LPCTSTR lpszOutPDF);
	BOOL EnableAnnotations(BOOL bEnable);
	BOOL OpenPDFFromMem(long lpPDFData, long nPDFDataLen, LPCTSTR lpszUserPwd, LPCTSTR lpszOwnerPwd);
	long EnableLaunchLink(long bEnable);
	long EnableMouseWhellInFacingMode(long bEnable);
	long GetScrollBar();
	void ViewModeBook();
	long ShowScrollBar(BOOL bShow);
	BOOL IsScrollBarShown();
	long ShowContextMenu(BOOL bShow);
	BOOL IsContextMenuShown();
	void AboutBox();
};
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pdfviewerocx/CPP/pdfviewer.clw
; CLW file contains information for the MFC ClassWizard

[General Info]
Version=1
LastClass=CPdfviewerDlg
LastTemplate=CDialog
NewFileInclude1=#include "stdafx.h"
NewFileInclude2=#include "pdfviewer.h"

ClassCount=3
Class1=CPdfviewerApp
Class2=CPdfviewerDlg
Class3=CAboutDlg

ResourceCount=5
Resource1=IDD_ABOUTBOX
Resource2=IDR_MAINFRAME
Resource3=IDD_PDFVIEWER_DIALOG
Resource4=IDD_ABOUTBOX (English (U.S.))
Resource5=IDD_PDFVIEWER_DIALOG (English (U.S.))

[CLS:CPdfviewerApp]
Type=0
HeaderFile=pdfviewer.h
ImplementationFile=pdfviewer.cpp
Filter=N

[CLS:CPdfviewerDlg]
Type=0
HeaderFile=pdfviewerDlg.h
ImplementationFile=pdfviewerDlg.cpp
Filter=D
BaseClass=cdxCSizingDialog
VirtualFilter=dWC
LastObject=CPdfviewerDlg

[CLS:CAboutDlg]
Type=0
HeaderFile=pdfviewerDlg.h
ImplementationFile=pdfviewerDlg.cpp
Filter=D

[DLG:IDD_ABOUTBOX]
Type=1
ControlCount=4
Control1=IDC_STATIC,static,1342177283
Control2=IDC_STATIC,static,1342308352
Control3=IDC_STATIC,static,1342308352
Control4=IDOK,button,1342373889
Class=CAboutDlg


[DLG:IDD_PDFVIEWER_DIALOG]
Type=1
ControlCount=3
Control1=IDOK,button,1342242817
Control2=IDCANCEL,button,1342242816
Control3=IDC_STATIC,static,1342308352
Class=CPdfviewerDlg

[DLG:IDD_PDFVIEWER_DIALOG (English (U.S.))]
Type=1
Class=CPdfviewerDlg
ControlCount=25
Control1=IDC_PDFVIEWCTRL1,{433268D7-2CD4-43E6-AA24-2188672E7252},1342242816
Control2=IDC_BUTTON_OPEN,button,1342242816
Control3=IDC_BUTTON_NEXTPAGE,button,1342242816
Control4=IDC_BUTTON_PREVIOUSPAGE,button,1342242816
Control5=IDC_BUTTON_ACTUALSIZE,button,1342242816
Control6=IDC_BUTTON_FITPAGE,button,1342242816
Control7=IDC_BUTTON_FITWIDTH,button,1342242816
Control8=IDC_BUTTON_ZOOMIN,button,1342242816
Control9=IDC_BUTTON_VIEW_MODE,button,1342242816
Control10=IDC_BUTTON_ROTATELEFT,button,1342242816
Control11=IDC_BUTTON_ROTATERIGHT,button,1342242816
Control12=IDC_EDIT_SEARCHSTRING,edit,1350631552
Control13=IDC_STATIC_SEARCH,static,1342308352
Control14=IDC_BUTTON_SEARCH,button,1342242816
Control15=IDC_BUTTON_SEARCH_NEXT,button,1342242816
Control16=IDC_BUTTON_SEARCH_PREVIOUS,button,1342242816
Control17=IDC_BUTTON_ZOOMOUT,button,1342242816
Control18=IDC_EDIT_GOTOPAGE,edit,1350631552
Control19=IDC_BUTTON_GOTOPAGE,button,1342242816
Control20=IDC_BUTTON_GETPAGEINFO,button,1342242816
Control21=IDC_EDIT_ZOOM,edit,1350631552
Control22=IDC_BUTTON_ZOOM,button,1342242816
Control23=IDC_LIST_INFO,listbox,1353777409
Control24=IDC_BUTTON_SCROOLBAR,button,1342242816
Control25=IDC_BUTTON_ContextMenu,button,1342242816

[DLG:IDD_ABOUTBOX (English (U.S.))]
Type=1
Class=?
ControlCount=4
Control1=IDC_STATIC,static,1342177283
Control2=IDC_STATIC,static,1342308480
Control3=IDC_STATIC,static,1342308352
Control4=IDOK,button,1342373889
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pdfviewerocx/CPP/pdfviewer.cpp
// pdfviewer.cpp : Defines the class behaviors for the application.

//



#include "stdafx.h"

#include "pdfviewer.h"

#include "pdfviewerDlg.h"



#ifdef _DEBUG

#define new DEBUG_NEW

#undef THIS_FILE

static char THIS_FILE[] = __FILE__;

#endif



/////////////////////////////////////////////////////////////////////////////

// CPdfviewerApp



BEGIN_MESSAGE_MAP(CPdfviewerApp, CWinApp)

    //{{AFX_MSG_MAP(CPdfviewerApp)

        // NOTE - the ClassWizard will add and remove mapping macros here.

        //    DO NOT EDIT what you see in these blocks of generated code!

    //}}AFX_MSG

    ON_COMMAND(ID_HELP, CWinApp::OnHelp)

END_MESSAGE_MAP()



/////////////////////////////////////////////////////////////////////////////

// CPdfviewerApp construction



CPdfviewerApp::CPdfviewerApp()

{

    // TODO: add construction code here,

    // Place all significant initialization in InitInstance

}



/////////////////////////////////////////////////////////////////////////////

// The one and only CPdfviewerApp object



CPdfviewerApp theApp;



/////////////////////////////////////////////////////////////////////////////

// CPdfviewerApp initialization



BOOL CPdfviewerApp::InitInstance()

{

    AfxEnableControlContainer();



    // Standard initialization

    // If you are not using these features and wish to reduce the size

    //  of your final executable, you should remove from the following

    //  the specific initialization routines you do not need.



#ifdef _AFXDLL

    Enable3dControls();         // Call this when using MFC in a shared DLL

#else

    Enable3dControlsStatic();   // Call this when linking to MFC statically

#endif



    CPdfviewerDlg dlg;

    m_pMainWnd = &dlg;

    int nResponse = dlg.DoModal();

    if (nResponse == IDOK)

    {

        // TODO: Place code here to handle when the dialog is

        //  dismissed with OK

    }

    else if (nResponse == IDCANCEL)

    {

        // TODO: Place code here to handle when the dialog is

        //  dismissed with Cancel

    }



    // Since the dialog has been closed, return FALSE so that we exit the

    //  application, rather than start the application's message pump.

    return FALSE;

}
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# Microsoft Developer Studio Project File - Name="pdfviewer" - Package Owner=<4>
# Microsoft Developer Studio Generated Build File, Format Version 6.00
# ** DO NOT EDIT **

# TARGTYPE "Win32 (x86) Application" 0x0101

CFG=pdfviewer - Win32 Debug
!MESSAGE This is not a valid makefile. To build this project using NMAKE,
!MESSAGE use the Export Makefile command and run
!MESSAGE 
!MESSAGE NMAKE /f "pdfviewer.mak".
!MESSAGE 
!MESSAGE You can specify a configuration when running NMAKE
!MESSAGE by defining the macro CFG on the command line. For example:
!MESSAGE 
!MESSAGE NMAKE /f "pdfviewer.mak" CFG="pdfviewer - Win32 Debug"
!MESSAGE 
!MESSAGE Possible choices for configuration are:
!MESSAGE 
!MESSAGE "pdfviewer - Win32 Release" (based on "Win32 (x86) Application")
!MESSAGE "pdfviewer - Win32 Debug" (based on "Win32 (x86) Application")
!MESSAGE 

# Begin Project
# PROP AllowPerConfigDependencies 0
# PROP Scc_ProjName ""
# PROP Scc_LocalPath ""
CPP=cl.exe
MTL=midl.exe
RSC=rc.exe

!IF  "$(CFG)" == "pdfviewer - Win32 Release"

# PROP BASE Use_MFC 6
# PROP BASE Use_Debug_Libraries 0
# PROP BASE Output_Dir "Release"
# PROP BASE Intermediate_Dir "Release"
# PROP BASE Target_Dir ""
# PROP Use_MFC 6
# PROP Use_Debug_Libraries 0
# PROP Output_Dir "Release"
# PROP Intermediate_Dir "Release"
# PROP Ignore_Export_Lib 0
# PROP Target_Dir ""
# ADD BASE CPP /nologo /MD /W3 /GX /O2 /D "WIN32" /D "NDEBUG" /D "_WINDOWS" /D "_AFXDLL" /Yu"stdafx.h" /FD /c
# ADD CPP /nologo /MD /W3 /GX /O2 /D "WIN32" /D "NDEBUG" /D "_WINDOWS" /D "_AFXDLL" /D "_MBCS" /Yu"stdafx.h" /FD /c
# ADD BASE MTL /nologo /D "NDEBUG" /mktyplib203 /win32
# ADD MTL /nologo /D "NDEBUG" /mktyplib203 /win32
# ADD BASE RSC /l 0x804 /d "NDEBUG" /d "_AFXDLL"
# ADD RSC /l 0x804 /d "NDEBUG" /d "_AFXDLL"
BSC32=bscmake.exe
# ADD BASE BSC32 /nologo
# ADD BSC32 /nologo
LINK32=link.exe
# ADD BASE LINK32 /nologo /subsystem:windows /machine:I386
# ADD LINK32 /nologo /subsystem:windows /machine:I386 /out:"../bin/pdfviewer.exe"

!ELSEIF  "$(CFG)" == "pdfviewer - Win32 Debug"

# PROP BASE Use_MFC 6
# PROP BASE Use_Debug_Libraries 1
# PROP BASE Output_Dir "Debug"
# PROP BASE Intermediate_Dir "Debug"
# PROP BASE Target_Dir ""
# PROP Use_MFC 6
# PROP Use_Debug_Libraries 1
# PROP Output_Dir "Debug"
# PROP Intermediate_Dir "Debug"
# PROP Ignore_Export_Lib 0
# PROP Target_Dir ""
# ADD BASE CPP /nologo /MDd /W3 /Gm /GX /ZI /Od /D "WIN32" /D "_DEBUG" /D "_WINDOWS" /D "_AFXDLL" /Yu"stdafx.h" /FD /GZ /c
# ADD CPP /nologo /MDd /W3 /Gm /GX /ZI /Od /D "WIN32" /D "_DEBUG" /D "_WINDOWS" /D "_AFXDLL" /D "_MBCS" /Yu"stdafx.h" /FD /GZ /c
# ADD BASE MTL /nologo /D "_DEBUG" /mktyplib203 /win32
# ADD MTL /nologo /D "_DEBUG" /mktyplib203 /win32
# ADD BASE RSC /l 0x804 /d "_DEBUG" /d "_AFXDLL"
# ADD RSC /l 0x804 /d "_DEBUG" /d "_AFXDLL"
BSC32=bscmake.exe
# ADD BASE BSC32 /nologo
# ADD BSC32 /nologo
LINK32=link.exe
# ADD BASE LINK32 /nologo /subsystem:windows /debug /machine:I386 /pdbtype:sept
# ADD LINK32 /nologo /subsystem:windows /debug /machine:I386 /out:"../bin/pdfviewer.exe" /pdbtype:sept

!ENDIF 

# Begin Target

# Name "pdfviewer - Win32 Release"
# Name "pdfviewer - Win32 Debug"
# Begin Group "Source Files"

# PROP Default_Filter "cpp;c;cxx;rc;def;r;odl;idl;hpj;bat"
# Begin Source File

SOURCE=.\cdxCSizingDialog.cpp
# End Source File
# Begin Source File

SOURCE=.\pdfview.cpp
# End Source File
# Begin Source File

SOURCE=.\pdfviewer.cpp
# End Source File
# Begin Source File

SOURCE=.\pdfviewer.rc
# End Source File
# Begin Source File

SOURCE=.\pdfviewerDlg.cpp
# End Source File
# Begin Source File

SOURCE=.\StdAfx.cpp
# ADD CPP /Yc"stdafx.h"
# End Source File
# End Group
# Begin Group "Header Files"

# PROP Default_Filter "h;hpp;hxx;hm;inl"
# Begin Source File

SOURCE=.\cdxCSizingDialog.h
# End Source File
# Begin Source File

SOURCE=.\pdfview.h
# End Source File
# Begin Source File

SOURCE=.\pdfviewer.h
# End Source File
# Begin Source File

SOURCE=.\pdfviewerDlg.h
# End Source File
# Begin Source File

SOURCE=.\Resource.h
# End Source File
# Begin Source File

SOURCE=.\StdAfx.h
# End Source File
# End Group
# Begin Group "Resource Files"

# PROP Default_Filter "ico;cur;bmp;dlg;rc2;rct;bin;rgs;gif;jpg;jpeg;jpe"
# Begin Source File

SOURCE=.\res\pdfviewer.ico
# End Source File
# Begin Source File

SOURCE=.\res\pdfviewer.rc2
# End Source File
# End Group
# Begin Source File

SOURCE=.\ReadMe.txt
# End Source File
# End Target
# End Project
# Section pdfviewer : {433268D7-2CD4-43E6-AA24-2188672E7252}
# 	2:21:DefaultSinkHeaderFile:pdfview.h
# 	2:16:DefaultSinkClass:CPdfview
# End Section
# Section pdfviewer : {284C477D-342D-41E0-A5D1-8A29E4EFEBA0}
# 	2:5:Class:CPdfview
# 	2:10:HeaderFile:pdfview.h
# 	2:8:ImplFile:pdfview.cpp
# End Section
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Microsoft Developer Studio Workspace File, Format Version 6.00
# WARNING: DO NOT EDIT OR DELETE THIS WORKSPACE FILE!

###############################################################################

Project: "pdfviewer"=.\pdfviewer.dsp - Package Owner=<4>

Package=<5>
{{{
}}}

Package=<4>
{{{
}}}

###############################################################################

Global:

Package=<5>
{{{
}}}

Package=<3>
{{{
    {433268D7-2CD4-43E6-AA24-2188672E7252}
}}}

###############################################################################
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// pdfviewer.h : main header file for the PDFVIEWER application
//

#if !defined(AFX_PDFVIEWER_H__BD960C1B_16D0_4451_A7E8_C95C6B5FCBAD__INCLUDED_)
#define AFX_PDFVIEWER_H__BD960C1B_16D0_4451_A7E8_C95C6B5FCBAD__INCLUDED_

#if _MSC_VER > 1000
#pragma once
#endif // _MSC_VER > 1000

#ifndef __AFXWIN_H__
	#error include 'stdafx.h' before including this file for PCH
#endif

#include "resource.h"		// main symbols

/////////////////////////////////////////////////////////////////////////////
// CPdfviewerApp:
// See pdfviewer.cpp for the implementation of this class
//

class CPdfviewerApp : public CWinApp
{
public:
	CPdfviewerApp();

// Overrides
	// ClassWizard generated virtual function overrides
	//{{AFX_VIRTUAL(CPdfviewerApp)
	public:
	virtual BOOL InitInstance();
	//}}AFX_VIRTUAL

// Implementation

	//{{AFX_MSG(CPdfviewerApp)
		// NOTE - the ClassWizard will add and remove member functions here.
		//    DO NOT EDIT what you see in these blocks of generated code !
	//}}AFX_MSG
	DECLARE_MESSAGE_MAP()
};


/////////////////////////////////////////////////////////////////////////////

//{{AFX_INSERT_LOCATION}}
// Microsoft Visual C++ will insert additional declarations immediately before the previous line.

#endif // !defined(AFX_PDFVIEWER_H__BD960C1B_16D0_4451_A7E8_C95C6B5FCBAD__INCLUDED_)
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Build Log



--------------------Configuration: pdfviewer - Win32 Release--------------------



Command Lines


Creating command line "rc.exe /l 0x804 /fo"Release/pdfviewer.res" /d "NDEBUG" /d "_AFXDLL" "E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\CPP\pdfviewer.rc"" 
Creating temporary file "C:\Users\xueheng\AppData\Local\Temp\RSP67E4.tmp" with contents
[
/nologo /MD /W3 /GX /O2 /D "WIN32" /D "NDEBUG" /D "_WINDOWS" /D "_AFXDLL" /D "_MBCS" /Fp"Release/pdfviewer.pch" /Yu"stdafx.h" /Fo"Release/" /Fd"Release/" /FD /c 
"E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\CPP\cdxCSizingDialog.cpp"
"E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\CPP\pdfview.cpp"
"E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\CPP\pdfviewer.cpp"
"E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\CPP\pdfviewerDlg.cpp"
]
Creating command line "cl.exe @C:\Users\xueheng\AppData\Local\Temp\RSP67E4.tmp" 
Creating temporary file "C:\Users\xueheng\AppData\Local\Temp\RSP67E5.tmp" with contents
[
/nologo /MD /W3 /GX /O2 /D "WIN32" /D "NDEBUG" /D "_WINDOWS" /D "_AFXDLL" /D "_MBCS" /Fp"Release/pdfviewer.pch" /Yc"stdafx.h" /Fo"Release/" /Fd"Release/" /FD /c 
"E:\pdfpsinter\PDFViewer\product_release\pdfviewerocx\CPP\StdAfx.cpp"
]
Creating command line "cl.exe @C:\Users\xueheng\AppData\Local\Temp\RSP67E5.tmp" 
Creating temporary file "C:\Users\xueheng\AppData\Local\Temp\RSP67E6.tmp" with contents
[
/nologo /subsystem:windows /incremental:no /pdb:"Release/pdfviewer.pdb" /machine:I386 /out:"../bin/pdfviewer.exe" 
.\Release\cdxCSizingDialog.obj
.\Release\pdfview.obj
.\Release\pdfviewer.obj
.\Release\pdfviewerDlg.obj
.\Release\StdAfx.obj
.\Release\pdfviewer.res
]
Creating command line "link.exe @C:\Users\xueheng\AppData\Local\Temp\RSP67E6.tmp"
Output Window


Compiling resources...
Compiling...
StdAfx.cpp
Compiling...
cdxCSizingDialog.cpp
pdfview.cpp
pdfviewer.cpp
pdfviewerDlg.cpp
Generating Code...
Linking...



Results


pdfviewer.exe - 0 error(s), 0 warning(s)
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//Microsoft Developer Studio generated resource script.
//
#include "resource.h"

#define APSTUDIO_READONLY_SYMBOLS
/////////////////////////////////////////////////////////////////////////////
//
// Generated from the TEXTINCLUDE 2 resource.
//
#include "afxres.h"

/////////////////////////////////////////////////////////////////////////////
#undef APSTUDIO_READONLY_SYMBOLS

/////////////////////////////////////////////////////////////////////////////
// Chinese (P.R.C.) resources

#if !defined(AFX_RESOURCE_DLL) || defined(AFX_TARG_CHS)
#ifdef _WIN32
LANGUAGE LANG_CHINESE, SUBLANG_CHINESE_SIMPLIFIED
#pragma code_page(936)
#endif //_WIN32

#ifdef APSTUDIO_INVOKED
/////////////////////////////////////////////////////////////////////////////
//
// TEXTINCLUDE
//

1 TEXTINCLUDE DISCARDABLE 
BEGIN
    "resource.h\0"
END

2 TEXTINCLUDE DISCARDABLE 
BEGIN
    "#include ""afxres.h""\r\n"
    "\0"
END

3 TEXTINCLUDE DISCARDABLE 
BEGIN
    "#define _AFX_NO_SPLITTER_RESOURCES\r\n"
    "#define _AFX_NO_OLE_RESOURCES\r\n"
    "#define _AFX_NO_TRACKER_RESOURCES\r\n"
    "#define _AFX_NO_PROPERTY_RESOURCES\r\n"
    "\r\n"
    "#if !defined(AFX_RESOURCE_DLL) || defined(AFX_TARG_ENU)\r\n"
    "#ifdef _WIN32\r\n"
    "LANGUAGE 9, 1\r\n"
    "#pragma code_page(1252)\r\n"
    "#endif //_WIN32\r\n"
    "#include ""res\\pdfviewer.rc2""  // non-Microsoft Visual C++ edited resources\r\n"
    "#include ""afxres.rc""         // Standard components\r\n"
    "#endif\r\n"
    "\0"
END

#endif    // APSTUDIO_INVOKED


/////////////////////////////////////////////////////////////////////////////
//
// Icon
//

// Icon with lowest ID value placed first to ensure application icon
// remains consistent on all systems.
IDR_MAINFRAME           ICON    DISCARDABLE     "res\\pdfviewer.ico"
#endif    // Chinese (P.R.C.) resources
/////////////////////////////////////////////////////////////////////////////


/////////////////////////////////////////////////////////////////////////////
// English (U.S.) resources

#if !defined(AFX_RESOURCE_DLL) || defined(AFX_TARG_ENU)
#ifdef _WIN32
LANGUAGE LANG_ENGLISH, SUBLANG_ENGLISH_US
#pragma code_page(1252)
#endif //_WIN32

/////////////////////////////////////////////////////////////////////////////
//
// Dialog
//

IDD_ABOUTBOX DIALOG DISCARDABLE  0, 0, 235, 55
STYLE DS_MODALFRAME | WS_POPUP | WS_CAPTION | WS_SYSMENU
CAPTION "About pdfviewer"
FONT 8, "MS Sans Serif"
BEGIN
    ICON            IDR_MAINFRAME,IDC_STATIC,11,17,20,20
    LTEXT           "pdfviewer Version 1.0",IDC_STATIC,40,10,119,8,
                    SS_NOPREFIX
    LTEXT           "Copyright (C) 2008",IDC_STATIC,40,25,119,8
    DEFPUSHBUTTON   "OK",IDOK,178,7,50,14,WS_GROUP
END

IDD_PDFVIEWER_DIALOG DIALOGEX 0, 0, 556, 439
STYLE WS_MINIMIZEBOX | WS_MAXIMIZEBOX | WS_POPUP | WS_VISIBLE | WS_CAPTION | 
    WS_SYSMENU | WS_THICKFRAME
EXSTYLE WS_EX_APPWINDOW
CAPTION "pdfviewer"
FONT 8, "MS Sans Serif"
BEGIN
    CONTROL         "",IDC_PDFVIEWCTRL1,
                    "{433268D7-2CD4-43E6-AA24-2188672E7252}",WS_TABSTOP,7,7,
                    469,354
    PUSHBUTTON      "Open",IDC_BUTTON_OPEN,481,7,68,16
    PUSHBUTTON      "Next Page",IDC_BUTTON_NEXTPAGE,481,25,68,16
    PUSHBUTTON      "Previous Page",IDC_BUTTON_PREVIOUSPAGE,481,42,68,16
    PUSHBUTTON      "Actual Size",IDC_BUTTON_ACTUALSIZE,481,115,68,16
    PUSHBUTTON      "Fit Page",IDC_BUTTON_FITPAGE,481,133,68,16
    PUSHBUTTON      "Fit Width",IDC_BUTTON_FITWIDTH,481,151,68,16
    PUSHBUTTON      "Zoom In",IDC_BUTTON_ZOOMIN,481,169,68,16
    PUSHBUTTON      "View Mode",IDC_BUTTON_VIEW_MODE,481,223,68,16
    PUSHBUTTON      "Rotate Left",IDC_BUTTON_ROTATELEFT,481,241,68,16
    PUSHBUTTON      "Rotate Right",IDC_BUTTON_ROTATERIGHT,481,259,68,16
    EDITTEXT        IDC_EDIT_SEARCHSTRING,481,289,68,12,ES_AUTOHSCROLL
    LTEXT           "Search String:",IDC_STATIC_SEARCH,481,278,68,8
    PUSHBUTTON      "Search",IDC_BUTTON_SEARCH,481,303,68,16
    PUSHBUTTON      "Search Next",IDC_BUTTON_SEARCH_NEXT,481,320,68,16
    PUSHBUTTON      "Search Previous",IDC_BUTTON_SEARCH_PREVIOUS,481,338,68,
                    16
    PUSHBUTTON      "Zoom Out",IDC_BUTTON_ZOOMOUT,481,187,68,16
    EDITTEXT        IDC_EDIT_GOTOPAGE,482,62,36,12,ES_AUTOHSCROLL
    PUSHBUTTON      "Goto",IDC_BUTTON_GOTOPAGE,522,60,27,16
    PUSHBUTTON      "Show Page Info",IDC_BUTTON_GETPAGEINFO,481,78,68,16
    EDITTEXT        IDC_EDIT_ZOOM,482,207,36,12,ES_AUTOHSCROLL
    PUSHBUTTON      "Zoom",IDC_BUTTON_ZOOM,522,205,27,16
    LISTBOX         IDC_LIST_INFO,7,364,469,68,LBS_NOINTEGRALHEIGHT | 
                    WS_VSCROLL | WS_HSCROLL | WS_TABSTOP
    PUSHBUTTON      "Test Scrollbar",IDC_BUTTON_SCROOLBAR,481,357,68,16
    PUSHBUTTON      "HideContextMenu",IDC_BUTTON_ContextMenu,481,97,68,16
END


#ifndef _MAC
/////////////////////////////////////////////////////////////////////////////
//
// Version
//

VS_VERSION_INFO VERSIONINFO
 FILEVERSION 1,0,0,1
 PRODUCTVERSION 1,0,0,1
 FILEFLAGSMASK 0x3fL
#ifdef _DEBUG
 FILEFLAGS 0x1L
#else
 FILEFLAGS 0x0L
#endif
 FILEOS 0x4L
 FILETYPE 0x1L
 FILESUBTYPE 0x0L
BEGIN
    BLOCK "StringFileInfo"
    BEGIN
        BLOCK "040904B0"
        BEGIN
            VALUE "CompanyName", "\0"
            VALUE "FileDescription", "pdfviewer MFC Application\0"
            VALUE "FileVersion", "1, 0, 0, 1\0"
            VALUE "InternalName", "pdfviewer\0"
            VALUE "LegalCopyright", "Copyright (C) 2008\0"
            VALUE "LegalTrademarks", "\0"
            VALUE "OriginalFilename", "pdfviewer.EXE\0"
            VALUE "ProductName", "pdfviewer Application\0"
            VALUE "ProductVersion", "1, 0, 0, 1\0"
        END
    END
    BLOCK "VarFileInfo"
    BEGIN
        VALUE "Translation", 0x409, 1200
    END
END

#endif    // !_MAC


/////////////////////////////////////////////////////////////////////////////
//
// DESIGNINFO
//

#ifdef APSTUDIO_INVOKED
GUIDELINES DESIGNINFO DISCARDABLE 
BEGIN
    IDD_ABOUTBOX, DIALOG
    BEGIN
        LEFTMARGIN, 7
        RIGHTMARGIN, 228
        TOPMARGIN, 7
        BOTTOMMARGIN, 48
    END

    IDD_PDFVIEWER_DIALOG, DIALOG
    BEGIN
        LEFTMARGIN, 7
        RIGHTMARGIN, 549
        TOPMARGIN, 7
        BOTTOMMARGIN, 432
    END
END
#endif    // APSTUDIO_INVOKED


/////////////////////////////////////////////////////////////////////////////
//
// Dialog Info
//

IDD_PDFVIEWER_DIALOG DLGINIT
BEGIN
    IDC_PDFVIEWCTRL1, 0x376, 28, 0
0x0000, 0x0000, 0x0000, 0x0001, 0x48c3, 0x0000, 0x3255, 0x0000, 0x0000, 
0x0000, 0x0000, 0x0000, 0x0000, 0x0000, 
    0
END


/////////////////////////////////////////////////////////////////////////////
//
// String Table
//

STRINGTABLE DISCARDABLE 
BEGIN
    IDS_ABOUTBOX            "&About pdfviewer..."
END

#endif    // English (U.S.) resources
/////////////////////////////////////////////////////////////////////////////



#ifndef APSTUDIO_INVOKED
/////////////////////////////////////////////////////////////////////////////
//
// Generated from the TEXTINCLUDE 3 resource.
//
#define _AFX_NO_SPLITTER_RESOURCES
#define _AFX_NO_OLE_RESOURCES
#define _AFX_NO_TRACKER_RESOURCES
#define _AFX_NO_PROPERTY_RESOURCES

#if !defined(AFX_RESOURCE_DLL) || defined(AFX_TARG_ENU)
#ifdef _WIN32
LANGUAGE 9, 1
#pragma code_page(1252)
#endif //_WIN32
#include "res\pdfviewer.rc2"  // non-Microsoft Visual C++ edited resources
#include "afxres.rc"         // Standard components
#endif

/////////////////////////////////////////////////////////////////////////////
#endif    // not APSTUDIO_INVOKED





pdfviewerocx/CPP/pdfviewer.sln

Microsoft Visual Studio Solution File, Format Version 11.00
# Visual Studio 2010
Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "pdfviewer", "pdfviewer.vcxproj", "{337E2902-6EB2-1C12-0E5D-8568E3E3D262}"
EndProject
Global
	GlobalSection(SolutionConfigurationPlatforms) = preSolution
		Debug|Win32 = Debug|Win32
		Release|Win32 = Release|Win32
	EndGlobalSection
	GlobalSection(ProjectConfigurationPlatforms) = postSolution
		{337E2902-6EB2-1C12-0E5D-8568E3E3D262}.Debug|Win32.ActiveCfg = Debug|Win32
		{337E2902-6EB2-1C12-0E5D-8568E3E3D262}.Debug|Win32.Build.0 = Debug|Win32
		{337E2902-6EB2-1C12-0E5D-8568E3E3D262}.Release|Win32.ActiveCfg = Release|Win32
		{337E2902-6EB2-1C12-0E5D-8568E3E3D262}.Release|Win32.Build.0 = Release|Win32
	EndGlobalSection
	GlobalSection(SolutionProperties) = preSolution
		HideSolutionNode = FALSE
	EndGlobalSection
EndGlobal
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pdfviewerocx/CPP/pdfviewerDlg.cpp

pdfviewerocx/CPP/pdfviewerDlg.cpp
// pdfviewerDlg.cpp : implementation file

//



#include "stdafx.h"

#include "pdfviewer.h"

#include "pdfviewerDlg.h"



#ifdef _DEBUG

#define new DEBUG_NEW

#undef THIS_FILE

static char THIS_FILE[] = __FILE__;

#endif



/////////////////////////////////////////////////////////////////////////////

// CAboutDlg dialog used for App About



class CAboutDlg : public CDialog

{

public:

    CAboutDlg();



// Dialog Data

    //{{AFX_DATA(CAboutDlg)

    enum { IDD = IDD_ABOUTBOX };

    //}}AFX_DATA



    // ClassWizard generated virtual function overrides

    //{{AFX_VIRTUAL(CAboutDlg)

    protected:

    virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support

    //}}AFX_VIRTUAL



// Implementation

protected:

    //{{AFX_MSG(CAboutDlg)

    //}}AFX_MSG

    DECLARE_MESSAGE_MAP()

};



CAboutDlg::CAboutDlg() : CDialog(CAboutDlg::IDD)

{

    //{{AFX_DATA_INIT(CAboutDlg)

    //}}AFX_DATA_INIT

}



void CAboutDlg::DoDataExchange(CDataExchange* pDX)

{

    CDialog::DoDataExchange(pDX);

    //{{AFX_DATA_MAP(CAboutDlg)

    //}}AFX_DATA_MAP

}



BEGIN_MESSAGE_MAP(CAboutDlg, CDialog)

    //{{AFX_MSG_MAP(CAboutDlg)

        // No message handlers

    //}}AFX_MSG_MAP

END_MESSAGE_MAP()



/////////////////////////////////////////////////////////////////////////////

// CPdfviewerDlg dialog



CPdfviewerDlg::CPdfviewerDlg(CWnd* pParent /*=NULL*/)

    : cdxCSizingDialog(CPdfviewerDlg::IDD, pParent)

{

    //{{AFX_DATA_INIT(CPdfviewerDlg)

    m_strText = _T("");

    m_nGotoPage = 1;

    m_fZoom = 100.0f;

    //}}AFX_DATA_INIT

    // Note that LoadIcon does not require a subsequent DestroyIcon in Win32

    m_hIcon = AfxGetApp()->LoadIcon(IDR_MAINFRAME);

    nViewMode = 0;

}



void CPdfviewerDlg::DoDataExchange(CDataExchange* pDX)

{

    cdxCSizingDialog::DoDataExchange(pDX);

    //{{AFX_DATA_MAP(CPdfviewerDlg)

    DDX_Control(pDX, IDC_LIST_INFO, m_ctrlInfo);

    DDX_Control(pDX, IDC_PDFVIEWCTRL1, m_wndPDFViewer);

    DDX_Text(pDX, IDC_EDIT_SEARCHSTRING, m_strText);

    DDX_Text(pDX, IDC_EDIT_GOTOPAGE, m_nGotoPage);

    DDX_Text(pDX, IDC_EDIT_ZOOM, m_fZoom);

    //}}AFX_DATA_MAP

}



BEGIN_MESSAGE_MAP(CPdfviewerDlg, cdxCSizingDialog)

    //{{AFX_MSG_MAP(CPdfviewerDlg)

    ON_WM_SYSCOMMAND()

    ON_WM_PAINT()

    ON_WM_QUERYDRAGICON()

    ON_BN_CLICKED(IDC_BUTTON_OPEN, OnButtonOpen)

    ON_BN_CLICKED(IDC_BUTTON_ACTUALSIZE, OnButtonActualsize)

    ON_BN_CLICKED(IDC_BUTTON_NEXTPAGE, OnButtonNextpage)

    ON_BN_CLICKED(IDC_BUTTON_PREVIOUSPAGE, OnButtonPreviouspage)

    ON_BN_CLICKED(IDC_BUTTON_FITPAGE, OnButtonFitpage)

    ON_BN_CLICKED(IDC_BUTTON_FITWIDTH, OnButtonFitwidth)

    ON_BN_CLICKED(IDC_BUTTON_VIEW_MODE, OnButtonViewMode)

    ON_BN_CLICKED(IDC_BUTTON_ROTATELEFT, OnButtonRotateleft)

    ON_BN_CLICKED(IDC_BUTTON_ROTATERIGHT, OnButtonRotateright)

    ON_BN_CLICKED(IDC_BUTTON_SEARCH, OnButtonSearch)

    ON_BN_CLICKED(IDC_BUTTON_SEARCH_NEXT, OnButtonSearchNext)

    ON_BN_CLICKED(IDC_BUTTON_SEARCH_PREVIOUS, OnButtonSearchPrevious)

    ON_BN_CLICKED(IDC_BUTTON_ZOOMIN, OnButtonZoomin)

    ON_BN_CLICKED(IDC_BUTTON_ZOOMOUT, OnButtonZoomout)

    ON_BN_CLICKED(IDC_BUTTON_GOTOPAGE, OnButtonGotopage)

    ON_BN_CLICKED(IDC_BUTTON_GETPAGEINFO, OnButtonGetpageinfo)

    ON_BN_CLICKED(IDC_BUTTON_ZOOM, OnButtonZoom)

    ON_WM_LBUTTONDBLCLK()

    ON_WM_MOUSEMOVE()

    ON_WM_MOUSEWHEEL()

    ON_WM_LBUTTONDOWN()

    ON_WM_LBUTTONUP()

    ON_WM_RBUTTONDBLCLK()

    ON_WM_RBUTTONDOWN()

    ON_WM_RBUTTONUP()

    ON_WM_KEYDOWN()

    ON_WM_KEYUP()

    ON_WM_CHAR()

    ON_WM_COPYDATA()

    ON_WM_SIZE()

    ON_WM_HSCROLL()

    ON_WM_VSCROLL()

    ON_BN_CLICKED(IDC_BUTTON_SCROOLBAR, OnButtonScroolbar)

    ON_BN_CLICKED(IDC_BUTTON_ContextMenu, OnBUTTONContextMenu)

    //}}AFX_MSG_MAP

END_MESSAGE_MAP()



/////////////////////////////////////////////////////////////////////////////

// CPdfviewerDlg message handlers



BOOL CPdfviewerDlg::OnInitDialog()

{

    cdxCSizingDialog::OnInitDialog();



    // Add "About..." menu item to system menu.



    // IDM_ABOUTBOX must be in the system command range.

    ASSERT((IDM_ABOUTBOX & 0xFFF0) == IDM_ABOUTBOX);

    ASSERT(IDM_ABOUTBOX < 0xF000);



    CMenu* pSysMenu = GetSystemMenu(FALSE);

    if (pSysMenu != NULL)

    {

        CString strAboutMenu;

        strAboutMenu.LoadString(IDS_ABOUTBOX);

        if (!strAboutMenu.IsEmpty())

        {

            pSysMenu->AppendMenu(MF_SEPARATOR);

            pSysMenu->AppendMenu(MF_STRING, IDM_ABOUTBOX, strAboutMenu);

        }

    }



    // Set the icon for this dialog.  The framework does this automatically

    //  when the application's main window is not a dialog

    SetIcon(m_hIcon, TRUE);         // Set big icon

    SetIcon(m_hIcon, FALSE);        // Set small icon

    

    // TODO: Add extra initialization here

    AddSzControl(*GetDlgItem(IDC_BUTTON_OPEN),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_NEXTPAGE),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_PREVIOUSPAGE),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_EDIT_GOTOPAGE),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_GOTOPAGE),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_GETPAGEINFO),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_ACTUALSIZE),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_FITPAGE),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_FITWIDTH),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_ZOOMIN),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_ZOOMOUT),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_EDIT_ZOOM),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_ZOOM),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_VIEW_MODE),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_ROTATELEFT),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_ROTATERIGHT),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_STATIC_SEARCH),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_EDIT_SEARCHSTRING),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_SEARCH),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_SEARCH_NEXT),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_SEARCH_PREVIOUS),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_BUTTON_SCROOLBAR),mdRepos,mdNone);

    AddSzControl(*GetDlgItem(IDC_LIST_INFO),mdResize,mdRepos);

    AddSzControl(*GetDlgItem(IDC_PDFVIEWCTRL1),mdResize,mdResize);

    return TRUE;  // return TRUE  unless you set the focus to a control

}



void CPdfviewerDlg::OnSysCommand(UINT nID, LPARAM lParam)

{

    if ((nID & 0xFFF0) == IDM_ABOUTBOX)

    {

        CAboutDlg dlgAbout;

        dlgAbout.DoModal();

    }

    else

    {

        cdxCSizingDialog::OnSysCommand(nID, lParam);

    }

}



// If you add a minimize button to your dialog, you will need the code below

//  to draw the icon.  For MFC applications using the document/view model,

//  this is automatically done for you by the framework.



void CPdfviewerDlg::OnPaint() 

{

    if (IsIconic())

    {

        CPaintDC dc(this); // device context for painting



        SendMessage(WM_ICONERASEBKGND, (WPARAM) dc.GetSafeHdc(), 0);



        // Center icon in client rectangle

        int cxIcon = GetSystemMetrics(SM_CXICON);

        int cyIcon = GetSystemMetrics(SM_CYICON);

        CRect rect;

        GetClientRect(&rect);

        int x = (rect.Width() - cxIcon + 1) / 2;

        int y = (rect.Height() - cyIcon + 1) / 2;



        // Draw the icon

        dc.DrawIcon(x, y, m_hIcon);

    }

    else

    {

        cdxCSizingDialog::OnPaint();

    }

}



// The system calls this to obtain the cursor to display while the user drags

//  the minimized window.

HCURSOR CPdfviewerDlg::OnQueryDragIcon()

{

    return (HCURSOR) m_hIcon;

}



void CPdfviewerDlg::OnButtonOpen() 

{

    char szFilter[] ="PDF File (*.pdf)|*.pdf||";

    CFileDialog  fSaveDlg(TRUE,"","",

        OFN_HIDEREADONLY | OFN_OVERWRITEPROMPT,

        szFilter,this);

    if(fSaveDlg.DoModal() != IDOK)

        return;

    CString strFileName = fSaveDlg.GetPathName();

    m_wndPDFViewer.SetRegCode("XXXXXXXXXXXXXXXXXXXX");

    m_wndPDFViewer.OpenPDF(strFileName, "", "");

    m_wndPDFViewer.SetMsgCallbackWnd((long)m_hWnd);

    m_wndPDFViewer.EnableLaunchLink(0);



    m_wndPDFViewer.EnableMouseWhellInFacingMode(1);

}



void CPdfviewerDlg::OnButtonActualsize() 

{

    m_wndPDFViewer.ZoomActualPage();

}



void CPdfviewerDlg::OnButtonNextpage() 

{

    m_wndPDFViewer.ViewNextPage();  

}



void CPdfviewerDlg::OnButtonPreviouspage() 

{

    m_wndPDFViewer.ViewPreviousPage();

}



void CPdfviewerDlg::OnButtonFitpage() 

{

    m_wndPDFViewer.ZoomFitPage();   

}



void CPdfviewerDlg::OnButtonFitwidth() 

{

    // TODO: Add your control notification handler code here

    m_wndPDFViewer.ZoomFitWidth();  

}



void CPdfviewerDlg::OnButtonViewMode() 

{

    if(0)

    {

        if(nViewMode == 0)

            m_wndPDFViewer.ViewModeSinglePage();

        else if(nViewMode == 1)

            m_wndPDFViewer.ViewModeFacing();

        else if(nViewMode == 2)

            m_wndPDFViewer.ViewModeContinuous();

        else if(nViewMode == 3)

            m_wndPDFViewer.ViewModeContinuousFacing();

    }

    else

    {

        m_wndPDFViewer.SetViewMode(nViewMode);

    }

    nViewMode++;

    if(nViewMode >= 6)

        nViewMode = 0;

}



void CPdfviewerDlg::OnButtonRotateleft() 

{

    m_wndPDFViewer.RotateViewLeft();    

}



void CPdfviewerDlg::OnButtonRotateright() 

{

    m_wndPDFViewer.RotateViewRight();   

}



void CPdfviewerDlg::OnButtonSearch() 

{

    UpdateData();

    if(m_strText.GetLength() == 0)

        return;

    m_wndPDFViewer.SetFindText(m_strText);  

    m_wndPDFViewer.FindNextText();  

}



void CPdfviewerDlg::OnButtonSearchNext() 

{

    m_wndPDFViewer.FindNextText();

}



void CPdfviewerDlg::OnButtonSearchPrevious() 

{

    m_wndPDFViewer.FindPreviousText();  

}



void CPdfviewerDlg::OnButtonZoomin() 

{

    // TODO: Add your control notification handler code here

    m_wndPDFViewer.ZoomIn();

}



void CPdfviewerDlg::OnButtonZoomout() 

{

    // TODO: Add your control notification handler code here

    m_wndPDFViewer.ZoomOut();

}



void CPdfviewerDlg::OnButtonGotopage() 

{

    UpdateData();

    m_wndPDFViewer.ViewGotoPage(m_nGotoPage);

}



void CPdfviewerDlg::OnButtonGetpageinfo() 

{

    int nCurPage = m_wndPDFViewer.GetCurrentPage();

    int nPageCount = m_wndPDFViewer.GetPageTotalCount();

    float nZoom = m_wndPDFViewer.GetCurrentZoom();

    CString strMsg;

    strMsg.Format("%d of %d, zoom = %f", nCurPage, nPageCount, nZoom);

    AfxMessageBox(strMsg);  

}



void CPdfviewerDlg::OnButtonZoom() 

{

    UpdateData();

    if(m_fZoom > 0)

        m_wndPDFViewer.Zoom(m_fZoom);

}

void CPdfviewerDlg::InsertString(CString strMsg)

{

    m_ctrlInfo.InsertString(-1, strMsg);

    int nCount = m_ctrlInfo.GetCount();

    if (nCount > 0)

        m_ctrlInfo.SetCurSel(nCount-1);

}



void CPdfviewerDlg::OnLButtonDblClk(UINT nFlags, CPoint point) 

{

    // TODO: Add your message handler code here and/or call default

    CString strMsg;

    strMsg.Format("OnLButtonDblClk, nFlags = 0x%x, point = (%d, %d)", nFlags, point.x, point.y);

    InsertString(strMsg);

    cdxCSizingDialog::OnLButtonDblClk(nFlags, point);

}



void CPdfviewerDlg::OnMouseMove(UINT nFlags, CPoint point) 

{

    CString strMsg;

    strMsg.Format("OnMouseMove, nFlags = 0x%x, point = (%d, %d)", nFlags, point.x, point.y);

    InsertString(strMsg);

    cdxCSizingDialog::OnMouseMove(nFlags, point);

}



BOOL CPdfviewerDlg::OnMouseWheel(UINT nFlags, short zDelta, CPoint pt) 

{

    CString strMsg;

    strMsg.Format("OnMouseWheel, nFlags = 0x%x, point = (%d, %d)", nFlags, pt.x, pt.y);

    InsertString(strMsg);

    return cdxCSizingDialog::OnMouseWheel(nFlags, zDelta, pt);

}



void CPdfviewerDlg::OnLButtonDown(UINT nFlags, CPoint point) 

{

    CString strMsg;

    strMsg.Format("OnLButtonDown, nFlags = 0x%x, point = (%d, %d)", nFlags, point.x, point.y);

    InsertString(strMsg);

    cdxCSizingDialog::OnLButtonDown(nFlags, point);

}



void CPdfviewerDlg::OnLButtonUp(UINT nFlags, CPoint point) 

{

    CString strMsg;

    strMsg.Format("OnLButtonUp, nFlags = 0x%x, point = (%d, %d)", nFlags, point.x, point.y);

    InsertString(strMsg);

    cdxCSizingDialog::OnLButtonUp(nFlags, point);

}



void CPdfviewerDlg::OnRButtonDblClk(UINT nFlags, CPoint point) 

{

    CString strMsg;

    strMsg.Format("OnRButtonDblClk, nFlags = 0x%x, point = (%d, %d)", nFlags, point.x, point.y);

    InsertString(strMsg);

    cdxCSizingDialog::OnRButtonDblClk(nFlags, point);

}



void CPdfviewerDlg::OnRButtonDown(UINT nFlags, CPoint point) 

{

    CString strMsg;

    strMsg.Format("OnRButtonDown, nFlags = 0x%x, point = (%d, %d)", nFlags, point.x, point.y);

    InsertString(strMsg);

    cdxCSizingDialog::OnRButtonDown(nFlags, point);

}



void CPdfviewerDlg::OnRButtonUp(UINT nFlags, CPoint point) 

{

    CString strMsg;

    strMsg.Format("OnRButtonUp, nFlags = 0x%x, point = (%d, %d)", nFlags, point.x, point.y);

    InsertString(strMsg);

    cdxCSizingDialog::OnRButtonUp(nFlags, point);

}



void CPdfviewerDlg::OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) 

{

    CString strMsg;

    strMsg.Format("OnKeyDown, nChar = %c, nRepCnt = %d, nFlags = %d", nChar, nRepCnt, nFlags);

    InsertString(strMsg);

    cdxCSizingDialog::OnKeyDown(nChar, nRepCnt, nFlags);

}



void CPdfviewerDlg::OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) 

{

    CString strMsg;

    strMsg.Format("OnKeyUp, nChar = %c, nRepCnt = %d, nFlags = %d", nChar, nRepCnt, nFlags);

    InsertString(strMsg);

    cdxCSizingDialog::OnKeyUp(nChar, nRepCnt, nFlags);

}



void CPdfviewerDlg::OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) 

{

    CString strMsg;

    strMsg.Format("OnChar, nChar = %c, nRepCnt = %d, nFlags = %d", nChar, nRepCnt, nFlags);

    InsertString(strMsg);

    cdxCSizingDialog::OnChar(nChar, nRepCnt, nFlags);

}

BOOL CPdfviewerDlg::OnCopyData(CWnd* pWnd, COPYDATASTRUCT* pCopyDataStruct) 

{

    // TODO: Add your message handler code here and/or call default

    if(pCopyDataStruct == NULL)

        return FALSE;

    switch(pCopyDataStruct->dwData)

    {

    case IDMSG_GET_LAUNCH_URL:

        {

            CString strURL((char*)pCopyDataStruct->lpData, pCopyDataStruct->cbData);

            InsertString(strURL);

            break;

        }

    case IDMSG_PAGE_CHANGED:

        {

            CString strCurrentPage((char*)pCopyDataStruct->lpData, pCopyDataStruct->cbData);

            SetDlgItemText(IDC_EDIT_GOTOPAGE, strCurrentPage);

            CString strMsg = "Current page is: ";

            strMsg += strCurrentPage;

            InsertString(strMsg);

            break;

        }

    }   

    return cdxCSizingDialog::OnCopyData(pWnd, pCopyDataStruct);

}



void CPdfviewerDlg::OnSize(UINT nType, int cx, int cy) 

{

    cdxCSizingDialog::OnSize(nType, cx, cy);

}



void CPdfviewerDlg::OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar) 

{

    // TODO: Add your message handler code here and/or call default

    HWND hWndScrollBar = (HWND)m_wndPDFViewer.GetScrollBar();

    CString strMsg;

    strMsg.Format("OnHScroll, nSBCode = %d, nPos = %d, hWndScrollBar = 0x%X", nSBCode, nPos, hWndScrollBar);

    InsertString(strMsg);   

    cdxCSizingDialog::OnHScroll(nSBCode, nPos, pScrollBar);

}



void CPdfviewerDlg::OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar) 

{

    HWND hWndScrollBar = (HWND)m_wndPDFViewer.GetScrollBar();

    CString strMsg;

    strMsg.Format("OnVScroll, nSBCode = %d, nPos = %d, hWndScrollBar = 0x%X", nSBCode, nPos, hWndScrollBar);

    InsertString(strMsg);   

    cdxCSizingDialog::OnVScroll(nSBCode, nPos, pScrollBar);

}



BOOL CPdfviewerDlg::PreTranslateMessage(MSG* pMsg) 

{

    // TODO: Add your specialized code here and/or call the base class

    if(pMsg->message == WM_VSCROLL)

    {

//      HWND hVScroll = (HWND)pMsg->lParam;

    }

    

    return cdxCSizingDialog::PreTranslateMessage(pMsg);

}



void CPdfviewerDlg::OnButtonScroolbar() 

{

    HWND hWndScrollBar = (HWND)m_wndPDFViewer.GetScrollBar();

    if(hWndScrollBar == NULL)

        return;



#define MENU_SCROLLBAR_VERT_HIDE        100000

#define MENU_SCROLLBAR_VERT_SHOW        100001

#define MENU_SCROLLBAR_VERT_LINEDOWN    100002

#define MENU_SCROLLBAR_VERT_LINEUP      100003

#define MENU_SCROLLBAR_VERT_BOTTOM      100004

#define MENU_SCROLLBAR_VERT_TOP         100005

#define MENU_SCROLLBAR_VERT_PAGEDOWN    100006

#define MENU_SCROLLBAR_VERT_PAGEUP      100007



#define MENU_SCROLLBAR_HORZ_HIDE        100010

#define MENU_SCROLLBAR_HORZ_SHOW        100011

#define MENU_SCROLLBAR_HORZ_LINEDOWN    100012

#define MENU_SCROLLBAR_HORZ_LINEUP      100013

#define MENU_SCROLLBAR_HORZ_BOTTOM      100014

#define MENU_SCROLLBAR_HORZ_TOP         100015

#define MENU_SCROLLBAR_HORZ_PAGEDOWN    100016

#define MENU_SCROLLBAR_HORZ_PAGEUP      100017

#define MENU_SCROLLBAR_HIDE_SHOW        100018



    POINT point;

    GetCursorPos(&point);

    HMENU hMenu;

    hMenu = CreatePopupMenu();

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_VERT_HIDE,      "Vertical Scrollbar Hide");

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_VERT_SHOW,      "Vertical Scrollbar Show");

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_VERT_LINEDOWN,  "Vertical Scrollbar LineDown");

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_VERT_LINEUP,    "Vertical Scrollbar Up");

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_VERT_BOTTOM,    "Vertical Scrollbar Bottom");

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_VERT_TOP,       "Vertical Scrollbar Top");

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_VERT_PAGEDOWN,  "Vertical Scrollbar PageDown");

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_VERT_PAGEUP,    "Vertical Scrollbar PageUp");

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_HORZ_HIDE,      "Horizontal Scrollbar Hide");

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_HORZ_SHOW,      "Horizontal Scrollbar Show");

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_HORZ_LINEDOWN,  "Horizontal Scrollbar LineDown");

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_HORZ_LINEUP,    "Horizontal Scrollbar Up");

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_HORZ_BOTTOM,    "Horizontal Scrollbar Bottom");

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_HORZ_TOP,       "Horizontal Scrollbar Top");

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_HORZ_PAGEDOWN,  "Horizontal Scrollbar PageDown");

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_HORZ_PAGEUP,    "Horizontal Scrollbar PageUp");

    AppendMenu(hMenu, MF_STRING, MENU_SCROLLBAR_HIDE_SHOW,      "Hide or Show Scrollbars");



    int nCmd = TrackPopupMenu(hMenu, TPM_RETURNCMD, point.x+5, point.y+5, 0, m_hWnd, NULL);

    switch(nCmd)

    {

    case MENU_SCROLLBAR_VERT_HIDE:

        ::ShowScrollBar(hWndScrollBar, SB_VERT, FALSE);

        break;

    case MENU_SCROLLBAR_VERT_SHOW:

        ::ShowScrollBar(hWndScrollBar, SB_VERT, TRUE);

        break;

    case MENU_SCROLLBAR_VERT_LINEDOWN:

        ::SendMessage(hWndScrollBar, WM_VSCROLL, SB_LINEDOWN, 0);

        break;

    case MENU_SCROLLBAR_VERT_LINEUP:

        ::SendMessage(hWndScrollBar, WM_VSCROLL, SB_LINEUP, 0);

        break;

    case MENU_SCROLLBAR_VERT_BOTTOM:

        ::SendMessage(hWndScrollBar, WM_VSCROLL, SB_BOTTOM, 0);

        break;

    case MENU_SCROLLBAR_VERT_TOP:

        ::SendMessage(hWndScrollBar, WM_VSCROLL, SB_TOP, 0);

        break;

    case MENU_SCROLLBAR_VERT_PAGEDOWN:

        ::SendMessage(hWndScrollBar, WM_VSCROLL, SB_PAGEDOWN, 0);

        break;

    case MENU_SCROLLBAR_VERT_PAGEUP:

        ::SendMessage(hWndScrollBar, WM_VSCROLL, SB_PAGEUP, 0);

        break;



    case MENU_SCROLLBAR_HORZ_HIDE:

        ::ShowScrollBar(hWndScrollBar, SB_HORZ, FALSE);

        break;

    case MENU_SCROLLBAR_HORZ_SHOW:

        ::ShowScrollBar(hWndScrollBar, SB_HORZ, TRUE);

        break;

    case MENU_SCROLLBAR_HORZ_LINEDOWN:

        ::SendMessage(hWndScrollBar, WM_HSCROLL, SB_LINEDOWN, 0);

        break;

    case MENU_SCROLLBAR_HORZ_LINEUP:

        ::SendMessage(hWndScrollBar, WM_HSCROLL, SB_LINEUP, 0);

        break;

    case MENU_SCROLLBAR_HORZ_BOTTOM:

        ::SendMessage(hWndScrollBar, WM_HSCROLL, SB_BOTTOM, 0);

        break;

    case MENU_SCROLLBAR_HORZ_TOP:

        ::SendMessage(hWndScrollBar, WM_HSCROLL, SB_TOP, 0);

        break;

    case MENU_SCROLLBAR_HORZ_PAGEDOWN:

        ::SendMessage(hWndScrollBar, WM_HSCROLL, SB_PAGEDOWN, 0);

        break;

    case MENU_SCROLLBAR_HORZ_PAGEUP:

        ::SendMessage(hWndScrollBar, WM_HSCROLL, SB_PAGEUP, 0);

        break;

    case MENU_SCROLLBAR_HIDE_SHOW:

        {

            BOOL bShow = m_wndPDFViewer.IsScrollBarShown();

            m_wndPDFViewer.ShowScrollBar(!bShow);

            break;

        }

    }

    DestroyMenu(hMenu);

}



void CPdfviewerDlg::OnBUTTONContextMenu() 

{

    BOOL bEnable = m_wndPDFViewer.IsContextMenuShown();

    bEnable = !bEnable;

    m_wndPDFViewer.ShowContextMenu(bEnable);

    if(bEnable)

        SetDlgItemText(IDC_BUTTON_ContextMenu, "HideContextMenu");

    else

        SetDlgItemText(IDC_BUTTON_ContextMenu, "ShowContextMenu");

}




pdfviewerocx/CPP/pdfviewerDlg.h
// pdfviewerDlg.h : header file
//
//{{AFX_INCLUDES()
#include "pdfview.h"
//}}AFX_INCLUDES

#if !defined(AFX_PDFVIEWERDLG_H__B57D56BC_3CE3_4566_8814_558DFCCED516__INCLUDED_)
#define AFX_PDFVIEWERDLG_H__B57D56BC_3CE3_4566_8814_558DFCCED516__INCLUDED_

#if _MSC_VER > 1000
#pragma once
#endif // _MSC_VER > 1000

#include "cdxCSizingDialog.h"

#define IDMSG_GET_LAUNCH_URL		(WM_USER+8895)
#define IDMSG_PAGE_CHANGED			(WM_USER+8896)
/////////////////////////////////////////////////////////////////////////////
// CPdfviewerDlg dialog

class CPdfviewerDlg : public cdxCSizingDialog
{
// Construction
public:
	CPdfviewerDlg(CWnd* pParent = NULL);	// standard constructor

	void InsertString(CString strMsg);
	int nViewMode;
// Dialog Data
	//{{AFX_DATA(CPdfviewerDlg)
	enum { IDD = IDD_PDFVIEWER_DIALOG };
	CListBox	m_ctrlInfo;
	CPdfview	m_wndPDFViewer;
	CString	m_strText;
	UINT	m_nGotoPage;
	float	m_fZoom;
	//}}AFX_DATA

	// ClassWizard generated virtual function overrides
	//{{AFX_VIRTUAL(CPdfviewerDlg)
	public:
	virtual BOOL PreTranslateMessage(MSG* pMsg);
	protected:
	virtual void DoDataExchange(CDataExchange* pDX);	// DDX/DDV support
	//}}AFX_VIRTUAL

// Implementation
protected:
	HICON m_hIcon;

	// Generated message map functions
	//{{AFX_MSG(CPdfviewerDlg)
	virtual BOOL OnInitDialog();
	afx_msg void OnSysCommand(UINT nID, LPARAM lParam);
	afx_msg void OnPaint();
	afx_msg HCURSOR OnQueryDragIcon();
	afx_msg void OnButtonOpen();
	afx_msg void OnButtonActualsize();
	afx_msg void OnButtonNextpage();
	afx_msg void OnButtonPreviouspage();
	afx_msg void OnButtonFitpage();
	afx_msg void OnButtonFitwidth();
	afx_msg void OnButtonViewMode();
	afx_msg void OnButtonRotateleft();
	afx_msg void OnButtonRotateright();
	afx_msg void OnButtonSearch();
	afx_msg void OnButtonSearchNext();
	afx_msg void OnButtonSearchPrevious();
	afx_msg void OnButtonZoomin();
	afx_msg void OnButtonZoomout();
	afx_msg void OnButtonGotopage();
	afx_msg void OnButtonGetpageinfo();
	afx_msg void OnButtonZoom();
	afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
	afx_msg void OnMouseMove(UINT nFlags, CPoint point);
	afx_msg BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
	afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
	afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
	afx_msg void OnRButtonDblClk(UINT nFlags, CPoint point);
	afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
	afx_msg void OnRButtonUp(UINT nFlags, CPoint point);
	afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
	afx_msg void OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
	afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
	afx_msg BOOL OnCopyData(CWnd* pWnd, COPYDATASTRUCT* pCopyDataStruct);
	afx_msg void OnSize(UINT nType, int cx, int cy);
	afx_msg void OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
	afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
	afx_msg void OnButtonScroolbar();
	afx_msg void OnBUTTONContextMenu();
	//}}AFX_MSG
	DECLARE_MESSAGE_MAP()
};

//{{AFX_INSERT_LOCATION}}
// Microsoft Visual C++ will insert additional declarations immediately before the previous line.

#endif // !defined(AFX_PDFVIEWERDLG_H__B57D56BC_3CE3_4566_8814_558DFCCED516__INCLUDED_)




pdfviewerocx/CPP/ReadMe.txt
========================================================================
       MICROSOFT FOUNDATION CLASS LIBRARY : pdfviewer
========================================================================


AppWizard has created this pdfviewer application for you.  This application
not only demonstrates the basics of using the Microsoft Foundation classes
but is also a starting point for writing your application.

This file contains a summary of what you will find in each of the files that
make up your pdfviewer application.

pdfviewer.dsp
    This file (the project file) contains information at the project level and
    is used to build a single project or subproject. Other users can share the
    project (.dsp) file, but they should export the makefiles locally.

pdfviewer.h
    This is the main header file for the application.  It includes other
    project specific headers (including Resource.h) and declares the
    CPdfviewerApp application class.

pdfviewer.cpp
    This is the main application source file that contains the application
    class CPdfviewerApp.

pdfviewer.rc
    This is a listing of all of the Microsoft Windows resources that the
    program uses.  It includes the icons, bitmaps, and cursors that are stored
    in the RES subdirectory.  This file can be directly edited in Microsoft
	Visual C++.

pdfviewer.clw
    This file contains information used by ClassWizard to edit existing
    classes or add new classes.  ClassWizard also uses this file to store
    information needed to create and edit message maps and dialog data
    maps and to create prototype member functions.

res\pdfviewer.ico
    This is an icon file, which is used as the application's icon.  This
    icon is included by the main resource file pdfviewer.rc.

res\pdfviewer.rc2
    This file contains resources that are not edited by Microsoft 
	Visual C++.  You should place all resources not editable by
	the resource editor in this file.




/////////////////////////////////////////////////////////////////////////////

AppWizard creates one dialog class:

pdfviewerDlg.h, pdfviewerDlg.cpp - the dialog
    These files contain your CPdfviewerDlg class.  This class defines
    the behavior of your application's main dialog.  The dialog's
    template is in pdfviewer.rc, which can be edited in Microsoft
	Visual C++.


/////////////////////////////////////////////////////////////////////////////
Other standard files:

StdAfx.h, StdAfx.cpp
    These files are used to build a precompiled header (PCH) file
    named pdfviewer.pch and a precompiled types file named StdAfx.obj.

Resource.h
    This is the standard header file, which defines new resource IDs.
    Microsoft Visual C++ reads and updates this file.

/////////////////////////////////////////////////////////////////////////////
Other notes:

AppWizard uses "TODO:" to indicate parts of the source code you
should add to or customize.

If your application uses MFC in a shared DLL, and your application is 
in a language other than the operating system's current language, you
will need to copy the corresponding localized resources MFC42XXX.DLL
from the Microsoft Visual C++ CD-ROM onto the system or system32 directory,
and rename it to be MFCLOC.DLL.  ("XXX" stands for the language abbreviation.
For example, MFC42DEU.DLL contains resources translated to German.)  If you
don't do this, some of the UI elements of your application will remain in the
language of the operating system.

/////////////////////////////////////////////////////////////////////////////




pdfviewerocx/CPP/res/pdfviewer.ico


pdfviewerocx/CPP/res/pdfviewer.rc2
//
// PDFVIEWER.RC2 - resources Microsoft Visual C++ does not edit directly
//

#ifdef APSTUDIO_INVOKED
	#error this file is not editable by Microsoft Visual C++
#endif //APSTUDIO_INVOKED


/////////////////////////////////////////////////////////////////////////////
// Add manually edited resources here...

/////////////////////////////////////////////////////////////////////////////




pdfviewerocx/CPP/resource.h
//{{NO_DEPENDENCIES}}
// Microsoft Developer Studio generated include file.
// Used by pdfviewer.rc
//
#define IDM_ABOUTBOX                    0x0010
#define IDD_ABOUTBOX                    100
#define IDS_ABOUTBOX                    101
#define IDD_PDFVIEWER_DIALOG            102
#define IDR_MAINFRAME                   128
#define IDC_PDFVIEWCTRL1                1000
#define IDC_BUTTON_OPEN                 1001
#define IDC_BUTTON_NEXTPAGE             1002
#define IDC_BUTTON_PREVIOUSPAGE         1003
#define IDC_BUTTON_ACTUALSIZE           1004
#define IDC_BUTTON_FITPAGE              1005
#define IDC_BUTTON_FITWIDTH             1006
#define IDC_BUTTON_ZOOMIN               1007
#define IDC_BUTTON_VIEW_MODE            1008
#define IDC_BUTTON_ROTATELEFT           1009
#define IDC_BUTTON_ROTATERIGHT          1010
#define IDC_EDIT_SEARCHSTRING           1011
#define IDC_BUTTON_SEARCH               1012
#define IDC_BUTTON_SEARCH_NEXT          1013
#define IDC_BUTTON_SEARCH_PREVIOUS      1014
#define IDC_BUTTON_ZOOMOUT              1015
#define IDC_EDIT_GOTOPAGE               1016
#define IDC_BUTTON_GOTOPAGE             1017
#define IDC_EDIT_ZOOM                   1018
#define IDC_BUTTON_GETPAGEINFO          1019
#define IDC_BUTTON_ZOOM                 1020
#define IDC_BUTTON_ContextMenu          1021
#define IDC_LIST_INFO                   1022
#define IDC_STATIC_SEARCH               1023
#define IDC_BUTTON_SCROOLBAR            1024

// Next default values for new objects
// 
#ifdef APSTUDIO_INVOKED
#ifndef APSTUDIO_READONLY_SYMBOLS
#define _APS_NEXT_RESOURCE_VALUE        130
#define _APS_NEXT_COMMAND_VALUE         32771
#define _APS_NEXT_CONTROL_VALUE         1025
#define _APS_NEXT_SYMED_VALUE           101
#endif
#endif




pdfviewerocx/CPP/StdAfx.cpp

pdfviewerocx/CPP/StdAfx.cpp
// stdafx.cpp : source file that includes just the standard includes

//  pdfviewer.pch will be the pre-compiled header

//  stdafx.obj will contain the pre-compiled type information



#include "stdafx.h"










pdfviewerocx/CPP/StdAfx.h
// stdafx.h : include file for standard system include files,
//  or project specific include files that are used frequently, but
//      are changed infrequently
//

#if !defined(AFX_STDAFX_H__2EAEFEFB_81A7_4142_9C94_44AFE595FE99__INCLUDED_)
#define AFX_STDAFX_H__2EAEFEFB_81A7_4142_9C94_44AFE595FE99__INCLUDED_

#if _MSC_VER > 1000
#pragma once
#endif // _MSC_VER > 1000

#define VC_EXTRALEAN		// Exclude rarely-used stuff from Windows headers

#include <afxwin.h>         // MFC core and standard components
#include <afxext.h>         // MFC extensions
#include <afxdisp.h>        // MFC Automation classes
#include <afxdtctl.h>		// MFC support for Internet Explorer 4 Common Controls
#ifndef _AFX_NO_AFXCMN_SUPPORT
#include <afxcmn.h>			// MFC support for Windows Common Controls
#endif // _AFX_NO_AFXCMN_SUPPORT


//{{AFX_INSERT_LOCATION}}
// Microsoft Visual C++ will insert additional declarations immediately before the previous line.

#endif // !defined(AFX_STDAFX_H__2EAEFEFB_81A7_4142_9C94_44AFE595FE99__INCLUDED_)
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pdfviewerocx/VB/pdfviewer.exe


pdfviewerocx/VB/pdfviewer.frm
VERSION 5.00
Object = "{67D235FE-3459-4C6E-B730-5C5028FBBC25}#1.0#0"; "pdfview.ocx"
Object = "{F9043C88-F6F2-101A-A3C9-08002B2F49FB}#1.2#0"; "COMDLG32.OCX"
Begin VB.Form Form1 
   Caption         =   "Form1"
   ClientHeight    =   8850
   ClientLeft      =   60
   ClientTop       =   450
   ClientWidth     =   12075
   LinkTopic       =   "Form1"
   ScaleHeight     =   8850
   ScaleWidth      =   12075
   StartUpPosition =   3  'Windows Default
   Begin VB.CommandButton ShowHideContextMenu 
      Caption         =   "Show/Hide Context Menu"
      Height          =   495
      Left            =   10080
      TabIndex        =   18
      Top             =   5880
      Width           =   1815
   End
   Begin VB.CommandButton OpenPDFURL 
      Caption         =   "Open PDF URL"
      Height          =   375
      Left            =   10080
      TabIndex        =   17
      Top             =   120
      Width           =   1815
   End
   Begin VB.CommandButton ZoomOut 
      Caption         =   "ZoomOut"
      Height          =   375
      Left            =   10080
      TabIndex        =   16
      Top             =   3960
      Width           =   1815
   End
   Begin VB.CommandButton SetSearchText 
      Caption         =   "Set Search Text"
      Height          =   495
      Left            =   10080
      TabIndex        =   15
      Top             =   7320
      Width           =   1815
   End
   Begin MSComDlg.CommonDialog CommonDialog1 
      Left            =   9840
      Top             =   600
      _ExtentX        =   847
      _ExtentY        =   847
      _Version        =   393216
   End
   Begin VB.CommandButton SearchPrevious 
      Caption         =   "Search Previous"
      Height          =   375
      Left            =   10080
      TabIndex        =   14
      Top             =   8400
      Width           =   1815
   End
   Begin VB.CommandButton SearchNext 
      Caption         =   "SearchNext"
      Height          =   375
      Left            =   10080
      TabIndex        =   13
      Top             =   7920
      Width           =   1815
   End
   Begin VB.TextBox SearchText 
      Height          =   375
      Left            =   10080
      TabIndex        =   11
      Text            =   "Text1"
      Top             =   6840
      Width           =   1815
   End
   Begin VB.CommandButton RotateRight 
      Caption         =   "Rotate Right"
      Height          =   375
      Left            =   10080
      TabIndex        =   10
      Top             =   5400
      Width           =   1815
   End
   Begin VB.CommandButton RotateLeft 
      Caption         =   "Rotate Left"
      Height          =   375
      Left            =   10080
      TabIndex        =   9
      Top             =   4920
      Width           =   1815
   End
   Begin VB.CommandButton ViewMode 
      Caption         =   "View Mode"
      Height          =   375
      Left            =   10080
      TabIndex        =   8
      Top             =   4440
      Width           =   1815
   End
   Begin VB.CommandButton ZoomIn 
      Caption         =   "Zoom In"
      Height          =   375
      Left            =   10080
      TabIndex        =   7
      Top             =   3480
      Width           =   1815
   End
   Begin VB.CommandButton FitWidth 
      Caption         =   "Fit Width"
      Height          =   375
      Left            =   10080
      TabIndex        =   6
      Top             =   3000
      Width           =   1815
   End
   Begin VB.CommandButton FitPage 
      Caption         =   "Fit Page"
      Height          =   375
      Left            =   10080
      TabIndex        =   5
      Top             =   2520
      Width           =   1815
   End
   Begin VB.CommandButton ActualSize 
      Caption         =   "Actual Size"
      Height          =   375
      Left            =   10080
      TabIndex        =   4
      Top             =   2040
      Width           =   1815
   End
   Begin VB.CommandButton PreviousPage 
      Caption         =   "Previous Page"
      Height          =   375
      Left            =   10080
      TabIndex        =   3
      Top             =   1560
      Width           =   1815
   End
   Begin VB.CommandButton NextPage 
      Caption         =   "Next Page"
      Height          =   375
      Left            =   10080
      TabIndex        =   2
      Top             =   1080
      Width           =   1815
   End
   Begin VB.CommandButton Open 
      Caption         =   "Open PDF File"
      Height          =   375
      Left            =   10080
      TabIndex        =   1
      Top             =   600
      Width           =   1815
   End
   Begin PDFVIEWLib.Pdfview PDFViewOCX 
      Height          =   8775
      Left            =   0
      TabIndex        =   0
      Top             =   0
      Width           =   9735
      _Version        =   65536
      _ExtentX        =   17171
      _ExtentY        =   15478
      _StockProps     =   0
   End
   Begin VB.Label SearchString 
      Caption         =   "Search String:"
      Height          =   255
      Left            =   10080
      TabIndex        =   12
      Top             =   6480
      Width           =   1815
   End
End
Attribute VB_Name = "Form1"
Attribute VB_GlobalNameSpace = False
Attribute VB_Creatable = False
Attribute VB_PredeclaredId = True
Attribute VB_Exposed = False
Dim nViewMode As Integer
Private Sub ActualSize_Click()
  PDFViewOCX.ZoomActualPage
End Sub

Private Sub FitPage_Click()
  PDFViewOCX.ZoomFitPage
End Sub

Private Sub FitWidth_Click()
  PDFViewOCX.ZoomFitWidth
End Sub

Private Sub NextPage_Click()
  PDFViewOCX.ViewNextPage
End Sub

Private Sub Open_Click()
  On Error GoTo EH
  CommonDialog1.CancelError = True
  CommonDialog1.Filter = "PDF Files (*.pdf)|*.pdf|"
  CommonDialog1.ShowOpen
  PDFViewOCX.OpenPDF CommonDialog1.FileName, "", ""
  nViewMode = 0
EH:

End Sub

Private Sub OpenPDFURL_Click()
   strPDFURL = InputBox("Enter a URL for PDF file", "Open PDF from Web", "")
   If strPDFURL <> "" Then
        PDFViewOCX.OpenPDF strPDFURL, "", ""
   End If
End Sub

Private Sub PreviousPage_Click()
  PDFViewOCX.ViewPreviousPage
End Sub


Private Sub RotateLeft_Click()
    PDFViewOCX.RotateViewLeft
End Sub

Private Sub RotateRight_Click()
    PDFViewOCX.RotateViewRight
End Sub

Private Sub SearchNext_Click()
    PDFViewOCX.FindNextText
End Sub

Private Sub SearchPrevious_Click()
    PDFViewOCX.FindPreviousText
End Sub

Private Sub SetSearchText_Click()
    PDFViewOCX.SetFindText SearchText.Text
End Sub

Private Sub ShowHideContextMenu_Click()
    bIsShow = PDFViewOCX.IsContextMenuShown()
    If bIsShow Then
        bIsShow = 0
    Else
        bIsShow = 1
    End If
    PDFViewOCX.ShowContextMenu (bIsShow)
End Sub

Private Sub ViewMode_Click()
    If nViewMode = 0 Then
        PDFViewOCX.ViewModeSinglePage
    ElseIf nViewMode = 1 Then
        PDFViewOCX.ViewModeFacing
    ElseIf nViewMode = 2 Then
        PDFViewOCX.ViewModeContinuous
    ElseIf nViewMode = 3 Then
        PDFViewOCX.ViewModeContinuousFacing
    End If
    nViewMode = nViewMode + 1
    If nViewMode >= 4 Then
        nViewMode = 0
    End If
  
End Sub

Private Sub ZoomRatio_Click()
  PDFViewOCX.Zoom 100
End Sub

Private Sub ZoomIn_Click()
  PDFViewOCX.ZoomIn
End Sub

Private Sub ZoomOut_Click()
  PDFViewOCX.ZoomOut
End Sub




pdfviewerocx/VB/pdfviewer.vbp
Type=Exe
Reference=*\G{00020430-0000-0000-C000-000000000046}#2.0#0#C:\Windows\SysWOW64\stdole2.tlb#OLE Automation
Object={67D235FE-3459-4C6E-B730-5C5028FBBC25}#1.0#0; pdfview.ocx
Form=pdfviewer.frm
Object={F9043C88-F6F2-101A-A3C9-08002B2F49FB}#1.2#0; COMDLG32.OCX
Startup="Form1"
ExeName32="pdfviewer.exe"
Command32=""
Name="Project1"
HelpContextID="0"
CompatibleMode="0"
MajorVer=1
MinorVer=0
RevisionVer=0
AutoIncrementVer=0
ServerSupportFiles=0
VersionCompanyName="Microsoft"
CompilationType=0
OptimizationType=0
FavorPentiumPro(tm)=0
CodeViewDebugInfo=0
NoAliasing=0
BoundsCheck=0
OverflowCheck=0
FlPointCheck=0
FDIVCheck=0
UnroundedFP=0
StartMode=0
Unattended=0
Retained=0
ThreadPerObject=0
MaxNumberOfThreads=1

[MS Transaction Server]
AutoRefresh=1
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// Machine generated IDispatch wrapper class(es) created by Microsoft Visual C++



// NOTE: Do not modify the contents of this file.  If this class is regenerated by

//  Microsoft Visual C++, your modifications will be overwritten.





#include "stdafx.h"

#include "pdfviewctrl1.h"



/////////////////////////////////////////////////////////////////////////////

// CPdfviewctrl1



IMPLEMENT_DYNCREATE(CPdfviewctrl1, CWnd)



/////////////////////////////////////////////////////////////////////////////

// CPdfviewctrl1 properties



/////////////////////////////////////////////////////////////////////////////

// CPdfviewctrl1 operations




pdfviewerocx/vs2008/SampleDlg/pdfviewctrl1.h
#pragma once

// Machine generated IDispatch wrapper class(es) created by Microsoft Visual C++

// NOTE: Do not modify the contents of this file.  If this class is regenerated by
//  Microsoft Visual C++, your modifications will be overwritten.

/////////////////////////////////////////////////////////////////////////////
// CPdfviewctrl1 wrapper class

class CPdfviewctrl1 : public CWnd
{
protected:
	DECLARE_DYNCREATE(CPdfviewctrl1)
public:
	CLSID const& GetClsid()
	{
		static CLSID const clsid
			= { 0x433268D7, 0x2CD4, 0x43E6, { 0xAA, 0x24, 0x21, 0x88, 0x67, 0x2E, 0x72, 0x52 } };
		return clsid;
	}
	virtual BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
						const RECT& rect, CWnd* pParentWnd, UINT nID, 
						CCreateContext* pContext = NULL)
	{ 
		return CreateControl(GetClsid(), lpszWindowName, dwStyle, rect, pParentWnd, nID); 
	}

    BOOL Create(LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, 
				UINT nID, CFile* pPersist = NULL, BOOL bStorage = FALSE,
				BSTR bstrLicKey = NULL)
	{ 
		return CreateControl(GetClsid(), lpszWindowName, dwStyle, rect, pParentWnd, nID,
		pPersist, bStorage, bstrLicKey); 
	}

// Attributes
public:


// Operations
public:

// _DPdfview

// Functions
//

	BOOL OpenPDF(LPCTSTR lpszPDFFile, LPCTSTR lpszUserPwd, LPCTSTR lpszOwnerPwd)
	{
		BOOL result;
		static BYTE parms[] = VTS_BSTR VTS_BSTR VTS_BSTR ;
		InvokeHelper(0x1, DISPATCH_METHOD, VT_BOOL, (void*)&result, parms, lpszPDFFile, lpszUserPwd, lpszOwnerPwd);
		return result;
	}
	void ClosePDF()
	{
		InvokeHelper(0x2, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	long RunCommand(long nCode, long nPara1, long nPara2, long nPara3)
	{
		long result;
		static BYTE parms[] = VTS_I4 VTS_I4 VTS_I4 VTS_I4 ;
		InvokeHelper(0x3, DISPATCH_METHOD, VT_I4, (void*)&result, parms, nCode, nPara1, nPara2, nPara3);
		return result;
	}
	void SetFindText(LPCTSTR lpszFindText)
	{
		static BYTE parms[] = VTS_BSTR ;
		InvokeHelper(0x4, DISPATCH_METHOD, VT_EMPTY, NULL, parms, lpszFindText);
	}
	void SetViewMode(long nViewMode)
	{
		static BYTE parms[] = VTS_I4 ;
		InvokeHelper(0x5, DISPATCH_METHOD, VT_EMPTY, NULL, parms, nViewMode);
	}
	void RotateViewLeft()
	{
		InvokeHelper(0x6, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void RotateViewRight()
	{
		InvokeHelper(0x7, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void ViewNextPage()
	{
		InvokeHelper(0x8, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void ViewPreviousPage()
	{
		InvokeHelper(0x9, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void ViewFirstPage()
	{
		InvokeHelper(0xa, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void ViewLastPage()
	{
		InvokeHelper(0xb, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void ViewPage()
	{
		InvokeHelper(0xc, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void FindPreviousText()
	{
		InvokeHelper(0xd, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void FindNextText()
	{
		InvokeHelper(0xe, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void ZoomFitPage()
	{
		InvokeHelper(0xf, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void ZoomActualPage()
	{
		InvokeHelper(0x10, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void ZoomFitWidth()
	{
		InvokeHelper(0x11, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void Zoom(float nZoom)
	{
		static BYTE parms[] = VTS_R4 ;
		InvokeHelper(0x12, DISPATCH_METHOD, VT_EMPTY, NULL, parms, nZoom);
	}
	void ViewModeSinglePage()
	{
		InvokeHelper(0x13, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void ViewModeFacing()
	{
		InvokeHelper(0x14, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void ViewModeContinuous()
	{
		InvokeHelper(0x15, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void ViewModeContinuousFacing()
	{
		InvokeHelper(0x16, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void ShowHideBookmarks()
	{
		InvokeHelper(0x17, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void SetRegCode(LPCTSTR lpszRegCode)
	{
		static BYTE parms[] = VTS_BSTR ;
		InvokeHelper(0x18, DISPATCH_METHOD, VT_EMPTY, NULL, parms, lpszRegCode);
	}
	void ZoomIn()
	{
		InvokeHelper(0x19, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void ZoomOut()
	{
		InvokeHelper(0x1a, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}
	void ViewGotoPage(long nPageIndex)
	{
		static BYTE parms[] = VTS_I4 ;
		InvokeHelper(0x1b, DISPATCH_METHOD, VT_EMPTY, NULL, parms, nPageIndex);
	}
	long SetGotoPageNumber(long nPageIndex)
	{
		long result;
		static BYTE parms[] = VTS_I4 ;
		InvokeHelper(0x1c, DISPATCH_METHOD, VT_I4, (void*)&result, parms, nPageIndex);
		return result;
	}
	long GetCurrentPage()
	{
		long result;
		InvokeHelper(0x1d, DISPATCH_METHOD, VT_I4, (void*)&result, NULL);
		return result;
	}
	long GetPageTotalCount()
	{
		long result;
		InvokeHelper(0x1e, DISPATCH_METHOD, VT_I4, (void*)&result, NULL);
		return result;
	}
	float GetCurrentZoom()
	{
		float result;
		InvokeHelper(0x1f, DISPATCH_METHOD, VT_R4, (void*)&result, NULL);
		return result;
	}
	void SetMsgCallbackWnd(long hMsgWnd)
	{
		static BYTE parms[] = VTS_I4 ;
		InvokeHelper(0x20, DISPATCH_METHOD, VT_EMPTY, NULL, parms, hMsgWnd);
	}
	long FlattenPDF(LPCTSTR lpszInPDF, LPCTSTR lpszOutPDF)
	{
		long result;
		static BYTE parms[] = VTS_BSTR VTS_BSTR ;
		InvokeHelper(0x21, DISPATCH_METHOD, VT_I4, (void*)&result, parms, lpszInPDF, lpszOutPDF);
		return result;
	}
	BOOL EnableAnnotations(BOOL bEnable)
	{
		BOOL result;
		static BYTE parms[] = VTS_BOOL ;
		InvokeHelper(0x22, DISPATCH_METHOD, VT_BOOL, (void*)&result, parms, bEnable);
		return result;
	}
	BOOL OpenPDFFromMem(long lpPDFData, long nPDFDataLen, LPCTSTR lpszUserPwd, LPCTSTR lpszOwnerPwd)
	{
		BOOL result;
		static BYTE parms[] = VTS_I4 VTS_I4 VTS_BSTR VTS_BSTR ;
		InvokeHelper(0x23, DISPATCH_METHOD, VT_BOOL, (void*)&result, parms, lpPDFData, nPDFDataLen, lpszUserPwd, lpszOwnerPwd);
		return result;
	}
	void AboutBox()
	{
		InvokeHelper(DISPID_ABOUTBOX, DISPATCH_METHOD, VT_EMPTY, NULL, NULL);
	}

// Properties
//



};
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================================================================================
    MICROSOFT FOUNDATION CLASS LIBRARY : SampleDlg Project Overview
===============================================================================

The application wizard has created this SampleDlg application for
you.  This application not only demonstrates the basics of using the Microsoft
Foundation Classes but is also a starting point for writing your application.

This file contains a summary of what you will find in each of the files that
make up your SampleDlg application.

SampleDlg.vcproj
    This is the main project file for VC++ projects generated using an application wizard.
    It contains information about the version of Visual C++ that generated the file, and
    information about the platforms, configurations, and project features selected with the
    application wizard.

SampleDlg.h
    This is the main header file for the application.  It includes other
    project specific headers (including Resource.h) and declares the
    CSampleDlgApp application class.

SampleDlg.cpp
    This is the main application source file that contains the application
    class CSampleDlgApp.

SampleDlg.rc
    This is a listing of all of the Microsoft Windows resources that the
    program uses.  It includes the icons, bitmaps, and cursors that are stored
    in the RES subdirectory.  This file can be directly edited in Microsoft
    Visual C++. Your project resources are in 1033.

res\SampleDlg.ico
    This is an icon file, which is used as the application's icon.  This
    icon is included by the main resource file SampleDlg.rc.

res\SampleDlg.rc2
    This file contains resources that are not edited by Microsoft
    Visual C++. You should place all resources not editable by
    the resource editor in this file.


/////////////////////////////////////////////////////////////////////////////

The application wizard creates one dialog class:

SampleDlgDlg.h, SampleDlgDlg.cpp - the dialog
    These files contain your CSampleDlgDlg class.  This class defines
    the behavior of your application's main dialog.  The dialog's template is
    in SampleDlg.rc, which can be edited in Microsoft Visual C++.


/////////////////////////////////////////////////////////////////////////////

Other Features:

ActiveX Controls
    The application includes support to use ActiveX controls.

Printing and Print Preview support
    The application wizard has generated code to handle the print, print setup, and print preview
    commands by calling member functions in the CView class from the MFC library.

/////////////////////////////////////////////////////////////////////////////

Other standard files:

StdAfx.h, StdAfx.cpp
    These files are used to build a precompiled header (PCH) file
    named SampleDlg.pch and a precompiled types file named StdAfx.obj.

Resource.h
    This is the standard header file, which defines new resource IDs.
    Microsoft Visual C++ reads and updates this file.

SampleDlg.manifest
	Application manifest files are used by Windows XP to describe an applications
	dependency on specific versions of Side-by-Side assemblies. The loader uses this
	information to load the appropriate assembly from the assembly cache or private
	from the application. The Application manifest  maybe included for redistribution
	as an external .manifest file that is installed in the same folder as the application
	executable or it may be included in the executable in the form of a resource.
/////////////////////////////////////////////////////////////////////////////

Other notes:

The application wizard uses "TODO:" to indicate parts of the source code you
should add to or customize.

If your application uses MFC in a shared DLL, you will need
to redistribute the MFC DLLs. If your application is in a language
other than the operating system's locale, you will also have to
redistribute the corresponding localized resources MFC90XXX.DLL.
For more information on both of these topics, please see the section on
redistributing Visual C++ applications in MSDN documentation.

/////////////////////////////////////////////////////////////////////////////
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//
// SampleDlg.RC2 - resources Microsoft Visual C++ does not edit directly
//

#ifdef APSTUDIO_INVOKED
#error this file is not editable by Microsoft Visual C++
#endif //APSTUDIO_INVOKED


/////////////////////////////////////////////////////////////////////////////
// Add manually edited resources here...

/////////////////////////////////////////////////////////////////////////////




pdfviewerocx/vs2008/SampleDlg/resource.h
//{{NO_DEPENDENCIES}}
// Microsoft Visual C++ generated include file.
// Used by SampleDlg.rc
//
#define IDM_ABOUTBOX                    0x0010
#define IDD_ABOUTBOX                    100
#define IDS_ABOUTBOX                    101
#define IDD_SAMPLEDLG_DIALOG            102
#define IDR_MAINFRAME                   128
#define IDC_PDFVIEWCTRL1                1000
#define IDC_BUTTON1                     1001
#define IDC_BUTTON_OPEN                 1001

// Next default values for new objects
// 
#ifdef APSTUDIO_INVOKED
#ifndef APSTUDIO_READONLY_SYMBOLS
#define _APS_NEXT_RESOURCE_VALUE        130
#define _APS_NEXT_COMMAND_VALUE         32771
#define _APS_NEXT_CONTROL_VALUE         1002
#define _APS_NEXT_SYMED_VALUE           101
#endif
#endif
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pdfviewerocx/vs2008/SampleDlg/SampleDlg.cpp
// SampleDlg.cpp : Defines the class behaviors for the application.

//



#include "stdafx.h"

#include "SampleDlg.h"

#include "SampleDlgDlg.h"



#ifdef _DEBUG

#define new DEBUG_NEW

#endif





// CSampleDlgApp



BEGIN_MESSAGE_MAP(CSampleDlgApp, CWinApp)

    ON_COMMAND(ID_HELP, &CWinApp::OnHelp)

END_MESSAGE_MAP()





// CSampleDlgApp construction



CSampleDlgApp::CSampleDlgApp()

{

    // TODO: add construction code here,

    // Place all significant initialization in InitInstance

}





// The one and only CSampleDlgApp object



CSampleDlgApp theApp;





// CSampleDlgApp initialization



BOOL CSampleDlgApp::InitInstance()

{

    // InitCommonControlsEx() is required on Windows XP if an application

    // manifest specifies use of ComCtl32.dll version 6 or later to enable

    // visual styles.  Otherwise, any window creation will fail.

    INITCOMMONCONTROLSEX InitCtrls;

    InitCtrls.dwSize = sizeof(InitCtrls);

    // Set this to include all the common control classes you want to use

    // in your application.

    InitCtrls.dwICC = ICC_WIN95_CLASSES;

    InitCommonControlsEx(&InitCtrls);



    CWinApp::InitInstance();



    AfxEnableControlContainer();



    // Standard initialization

    // If you are not using these features and wish to reduce the size

    // of your final executable, you should remove from the following

    // the specific initialization routines you do not need

    // Change the registry key under which our settings are stored

    // TODO: You should modify this string to be something appropriate

    // such as the name of your company or organization

    SetRegistryKey(_T("Local AppWizard-Generated Applications"));



    CSampleDlgDlg dlg;

    m_pMainWnd = &dlg;

    INT_PTR nResponse = dlg.DoModal();

    if (nResponse == IDOK)

    {

        // TODO: Place code here to handle when the dialog is

        //  dismissed with OK

    }

    else if (nResponse == IDCANCEL)

    {

        // TODO: Place code here to handle when the dialog is

        //  dismissed with Cancel

    }



    // Since the dialog has been closed, return FALSE so that we exit the

    //  application, rather than start the application's message pump.

    return FALSE;

}
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# Microsoft Developer Studio Project File - Name="SampleDlg" - Package Owner=<4>
# Microsoft Developer Studio Generated Build File, Format Version 6.00
# ** DO NOT EDIT **

# TARGTYPE "Win32 (x86) Application" 0x0101

CFG=SampleDlg - Win32 Debug
!MESSAGE This is not a valid makefile. To build this project using NMAKE,
!MESSAGE use the Export Makefile command and run
!MESSAGE 
!MESSAGE NMAKE /f "SampleDlg.mak".
!MESSAGE 
!MESSAGE You can specify a configuration when running NMAKE
!MESSAGE by defining the macro CFG on the command line. For example:
!MESSAGE 
!MESSAGE NMAKE /f "SampleDlg.mak" CFG="SampleDlg - Win32 Debug"
!MESSAGE 
!MESSAGE Possible choices for configuration are:
!MESSAGE 
!MESSAGE "SampleDlg - Win32 Debug" (based on "Win32 (x86) Application")
!MESSAGE "SampleDlg - Win32 Release" (based on "Win32 (x86) Application")
!MESSAGE 

# Begin Project
# PROP AllowPerConfigDependencies 0
# PROP Scc_ProjName ""
# PROP Scc_LocalPath ""
CPP=cl.exe
MTL=midl.exe
RSC=rc.exe

!IF  "$(CFG)" == "SampleDlg - Win32 Debug"

# PROP BASE Use_MFC 5
# PROP BASE Use_Debug_Libraries 1
# PROP BASE Output_Dir "$(SolutionDir)$(ConfigurationName)"
# PROP BASE Intermediate_Dir "$(ConfigurationName)"
# PROP BASE Target_Dir ""
# PROP Use_MFC 5
# PROP Use_Debug_Libraries 1
# PROP Output_Dir "$(SolutionDir)$(ConfigurationName)"
# PROP Intermediate_Dir "$(ConfigurationName)"
# PROP Target_Dir ""
# ADD BASE CPP /nologo /MTd /ZI /W3 /Od /D "WIN32" /D "_WINDOWS" /D "_DEBUG" /D "_MBCS" /Gm /YX /GZ /c /GX 
# ADD CPP /nologo /MTd /ZI /W3 /Od /D "WIN32" /D "_WINDOWS" /D "_DEBUG" /D "_MBCS" /Gm /YX /GZ /c /GX 
# ADD BASE MTL /nologo /D"_DEBUG" /robust /win32 
# ADD MTL /nologo /D"_DEBUG" /robust /win32 
# ADD BASE RSC /l 1033 /d "_DEBUG" /i "$(IntDir)" 
# ADD RSC /l 1033 /d "_DEBUG" /i "$(IntDir)" 
BSC32=bscmake.exe
# ADD BASE BSC32 /nologo 
# ADD BSC32 /nologo 
LINK32=link.exe
# ADD BASE LINK32 kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib odbc32.lib odbccp32.lib /nologo /incremental:yes /debug /pdbtype:sept /subsystem:windows /machine:ix86 
# ADD LINK32 kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib odbc32.lib odbccp32.lib /nologo /incremental:yes /debug /pdbtype:sept /subsystem:windows /machine:ix86 

!ELSEIF  "$(CFG)" == "SampleDlg - Win32 Release"

# PROP BASE Use_MFC 5
# PROP BASE Use_Debug_Libraries 0
# PROP BASE Output_Dir "$(SolutionDir)$(ConfigurationName)"
# PROP BASE Intermediate_Dir "$(ConfigurationName)"
# PROP BASE Target_Dir ""
# PROP Use_MFC 5
# PROP Use_Debug_Libraries 0
# PROP Output_Dir "$(SolutionDir)$(ConfigurationName)"
# PROP Intermediate_Dir "$(ConfigurationName)"
# PROP Target_Dir ""
# ADD BASE CPP /nologo /MT /Zi /W3 /O2 /Oi /D "WIN32" /D "_WINDOWS" /D "NDEBUG" /D "_MBCS" /Gy /YX /c /GX 
# ADD CPP /nologo /MT /Zi /W3 /O2 /Oi /D "WIN32" /D "_WINDOWS" /D "NDEBUG" /D "_MBCS" /Gy /YX /c /GX 
# ADD BASE MTL /nologo /D"NDEBUG" /robust /win32 
# ADD MTL /nologo /D"NDEBUG" /robust /win32 
# ADD BASE RSC /l 1033 /d "NDEBUG" /i "$(IntDir)" 
# ADD RSC /l 1033 /d "NDEBUG" /i "$(IntDir)" 
BSC32=bscmake.exe
# ADD BASE BSC32 /nologo 
# ADD BSC32 /nologo 
LINK32=link.exe
# ADD BASE LINK32 kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib odbc32.lib odbccp32.lib /nologo /incremental:no /debug /pdbtype:sept /subsystem:windows /opt:ref /opt:icf /machine:ix86 
# ADD LINK32 kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib odbc32.lib odbccp32.lib /nologo /incremental:no /debug /pdbtype:sept /subsystem:windows /opt:ref /opt:icf /machine:ix86 

!ENDIF

# Begin Target

# Name "SampleDlg - Win32 Debug"
# Name "SampleDlg - Win32 Release"
# Begin Group "Source Files"

# PROP Default_Filter "cpp;c;cc;cxx;def;odl;idl;hpj;bat;asm;asmx"
# Begin Source File

SOURCE=.\pdfviewctrl1.cpp
# End Source File
# Begin Source File

SOURCE=.\SampleDlg.cpp
# End Source File
# Begin Source File

SOURCE=.\SampleDlgDlg.cpp
# End Source File
# Begin Source File

SOURCE=.\stdafx.cpp

!IF  "$(CFG)" == "SampleDlg - Win32 Debug"

# ADD CPP /nologo /Yc"stdafx.h" /GZ /GX 
!ELSEIF  "$(CFG)" == "SampleDlg - Win32 Release"

# ADD CPP /nologo /Yc"stdafx.h" /GX 
!ENDIF

# End Source File
# End Group
# Begin Group "Header Files"

# PROP Default_Filter "h;hpp;hxx;hm;inl;inc;xsd"
# Begin Source File

SOURCE=.\pdfviewctrl1.h
# End Source File
# Begin Source File

SOURCE=.\Resource.h
# End Source File
# Begin Source File

SOURCE=.\SampleDlg.h
# End Source File
# Begin Source File

SOURCE=.\SampleDlgDlg.h
# End Source File
# Begin Source File

SOURCE=.\stdafx.h
# End Source File
# Begin Source File

SOURCE=.\targetver.h
# End Source File
# End Group
# Begin Group "Resource Files"

# PROP Default_Filter "rc;ico;cur;bmp;dlg;rc2;rct;bin;rgs;gif;jpg;jpeg;jpe;resx;tiff;tif;png;wav"
# Begin Source File

SOURCE=.\res\SampleDlg.ico
# End Source File
# Begin Source File

SOURCE=.\SampleDlg.rc
# End Source File
# Begin Source File

SOURCE=.\res\SampleDlg.rc2
# End Source File
# End Group
# Begin Source File

SOURCE=.\ReadMe.txt
# End Source File
# End Target
# End Project
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// SampleDlg.h : main header file for the PROJECT_NAME application
//

#pragma once

#ifndef __AFXWIN_H__
	#error "include 'stdafx.h' before including this file for PCH"
#endif

#include "resource.h"		// main symbols


// CSampleDlgApp:
// See SampleDlg.cpp for the implementation of this class
//

class CSampleDlgApp : public CWinApp
{
public:
	CSampleDlgApp();

// Overrides
	public:
	virtual BOOL InitInstance();

// Implementation

	DECLARE_MESSAGE_MAP()
};

extern CSampleDlgApp theApp;
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// Microsoft Visual C++ generated resource script.
//
#include "resource.h"

#define APSTUDIO_READONLY_SYMBOLS
/////////////////////////////////////////////////////////////////////////////
//
// Generated from the TEXTINCLUDE 2 resource.
//
#ifndef APSTUDIO_INVOKED
#include "targetver.h"
#endif
#include "afxres.h"

/////////////////////////////////////////////////////////////////////////////
#undef APSTUDIO_READONLY_SYMBOLS

/////////////////////////////////////////////////////////////////////////////
// Korean resources

#if !defined(AFX_RESOURCE_DLL) || defined(AFX_TARG_KOR)
#ifdef _WIN32
LANGUAGE LANG_KOREAN, SUBLANG_DEFAULT
#pragma code_page(949)
#endif //_WIN32

#ifdef APSTUDIO_INVOKED
/////////////////////////////////////////////////////////////////////////////
//
// TEXTINCLUDE
//

1 TEXTINCLUDE 
BEGIN
    "resource.h\0"
END

2 TEXTINCLUDE 
BEGIN
    "#ifndef APSTUDIO_INVOKED\r\n"
    "#include ""targetver.h""\r\n"
    "#endif\r\n"
    "#include ""afxres.h""\r\n"
    "\0"
END

3 TEXTINCLUDE 
BEGIN
    "#define _AFX_NO_SPLITTER_RESOURCES\r\n"
    "#define _AFX_NO_OLE_RESOURCES\r\n"
    "#define _AFX_NO_TRACKER_RESOURCES\r\n"
    "#define _AFX_NO_PROPERTY_RESOURCES\r\n"
    "\r\n"
    "#if !defined(AFX_RESOURCE_DLL) || defined(AFX_TARG_ENU)\r\n"
    "LANGUAGE 9, 1\r\n"
    "#pragma code_page(1252)\r\n"
    "#include ""res\\SampleDlg.rc2""  // non-Microsoft Visual C++ edited resources\r\n"
    "#include ""afxres.rc""     // Standard components\r\n"
    "#endif\r\n"
    "\0"
END

#endif    // APSTUDIO_INVOKED


/////////////////////////////////////////////////////////////////////////////
//
// Icon
//

// Icon with lowest ID value placed first to ensure application icon
// remains consistent on all systems.
IDR_MAINFRAME           ICON                    "res\\SampleDlg.ico"
#endif    // Korean resources
/////////////////////////////////////////////////////////////////////////////


/////////////////////////////////////////////////////////////////////////////
// English (U.S.) resources

#if !defined(AFX_RESOURCE_DLL) || defined(AFX_TARG_ENU)
#ifdef _WIN32
LANGUAGE LANG_ENGLISH, SUBLANG_ENGLISH_US
#pragma code_page(1252)
#endif //_WIN32

/////////////////////////////////////////////////////////////////////////////
//
// Dialog
//

IDD_ABOUTBOX DIALOGEX 0, 0, 170, 62
STYLE DS_SETFONT | DS_MODALFRAME | DS_FIXEDSYS | WS_POPUP | WS_CAPTION | WS_SYSMENU
CAPTION "About SampleDlg"
FONT 8, "MS Shell Dlg", 0, 0, 0x1
BEGIN
    ICON            IDR_MAINFRAME,IDC_STATIC,14,14,21,20
    LTEXT           "SampleDlg, Version 1.0",IDC_STATIC,42,14,114,8,SS_NOPREFIX
    LTEXT           "Copyright (C) 2009",IDC_STATIC,42,26,114,8
    DEFPUSHBUTTON   "OK",IDOK,113,41,50,14,WS_GROUP
END

IDD_SAMPLEDLG_DIALOG DIALOGEX 0, 0, 309, 265
STYLE DS_SETFONT | DS_MODALFRAME | DS_FIXEDSYS | WS_POPUP | WS_VISIBLE | WS_CAPTION | WS_SYSMENU
EXSTYLE WS_EX_APPWINDOW
CAPTION "SampleDlg"
FONT 8, "MS Shell Dlg", 0, 0, 0x1
BEGIN
    DEFPUSHBUTTON   "OK",IDOK,252,244,50,14
    CONTROL         "",IDC_PDFVIEWCTRL1,
                    "{433268D7-2CD4-43E6-AA24-2188672E7252}",WS_TABSTOP,7,7,295,222
    PUSHBUTTON      "Open",IDC_BUTTON_OPEN,7,244,50,14
END


/////////////////////////////////////////////////////////////////////////////
//
// Version
//

VS_VERSION_INFO VERSIONINFO
 FILEVERSION 1,0,0,1
 PRODUCTVERSION 1,0,0,1
 FILEFLAGSMASK 0x3fL
#ifdef _DEBUG
 FILEFLAGS 0x1L
#else
 FILEFLAGS 0x0L
#endif
 FILEOS 0x4L
 FILETYPE 0x1L
 FILESUBTYPE 0x0L
BEGIN
    BLOCK "StringFileInfo"
    BEGIN
        BLOCK "040904e4"
        BEGIN
            VALUE "CompanyName", "TODO: <Company name>"
            VALUE "FileDescription", "TODO: <File description>"
            VALUE "FileVersion", "1.0.0.1"
            VALUE "InternalName", "SampleDlg.exe"
            VALUE "LegalCopyright", "TODO: (c) <Company name>.  All rights reserved."
            VALUE "OriginalFilename", "SampleDlg.exe"
            VALUE "ProductName", "TODO: <Product name>"
            VALUE "ProductVersion", "1.0.0.1"
        END
    END
    BLOCK "VarFileInfo"
    BEGIN
        VALUE "Translation", 0x409, 1252
    END
END


/////////////////////////////////////////////////////////////////////////////
//
// DESIGNINFO
//

#ifdef APSTUDIO_INVOKED
GUIDELINES DESIGNINFO 
BEGIN
    IDD_ABOUTBOX, DIALOG
    BEGIN
        LEFTMARGIN, 7
        RIGHTMARGIN, 163
        TOPMARGIN, 7
        BOTTOMMARGIN, 55
    END

    IDD_SAMPLEDLG_DIALOG, DIALOG
    BEGIN
        LEFTMARGIN, 7
        RIGHTMARGIN, 302
        TOPMARGIN, 7
        BOTTOMMARGIN, 258
    END
END
#endif    // APSTUDIO_INVOKED


/////////////////////////////////////////////////////////////////////////////
//
// Dialog Info
//

IDD_SAMPLEDLG_DIALOG DLGINIT
BEGIN
    IDC_PDFVIEWCTRL1, 0x376, 20, 0
0x0000, 0x0000, 0x0000, 0x0001, 0x2dc9, 0x0000, 0x254f, 0x0000, 0x0000, 
0x0000, 
    0
END


/////////////////////////////////////////////////////////////////////////////
//
// String Table
//

STRINGTABLE 
BEGIN
    IDS_ABOUTBOX            "&About SampleDlg..."
END

#endif    // English (U.S.) resources
/////////////////////////////////////////////////////////////////////////////



#ifndef APSTUDIO_INVOKED
/////////////////////////////////////////////////////////////////////////////
//
// Generated from the TEXTINCLUDE 3 resource.
//
#define _AFX_NO_SPLITTER_RESOURCES
#define _AFX_NO_OLE_RESOURCES
#define _AFX_NO_TRACKER_RESOURCES
#define _AFX_NO_PROPERTY_RESOURCES

#if !defined(AFX_RESOURCE_DLL) || defined(AFX_TARG_ENU)
LANGUAGE 9, 1
#pragma code_page(1252)
#include "res\SampleDlg.rc2"  // non-Microsoft Visual C++ edited resources
#include "afxres.rc"     // Standard components
#endif

/////////////////////////////////////////////////////////////////////////////
#endif    // not APSTUDIO_INVOKED
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// SampleDlgDlg.cpp : implementation file

//



#include "stdafx.h"

#include "SampleDlg.h"

#include "SampleDlgDlg.h"



#ifdef _DEBUG

#define new DEBUG_NEW

#endif





// CAboutDlg dialog used for App About



class CAboutDlg : public CDialog

{

public:

    CAboutDlg();



// Dialog Data

    enum { IDD = IDD_ABOUTBOX };



    protected:

    virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support



// Implementation

protected:

    DECLARE_MESSAGE_MAP()

};



CAboutDlg::CAboutDlg() : CDialog(CAboutDlg::IDD)

{

}



void CAboutDlg::DoDataExchange(CDataExchange* pDX)

{

    CDialog::DoDataExchange(pDX);

}



BEGIN_MESSAGE_MAP(CAboutDlg, CDialog)

END_MESSAGE_MAP()





// CSampleDlgDlg dialog









CSampleDlgDlg::CSampleDlgDlg(CWnd* pParent /*=NULL*/)

    : CDialog(CSampleDlgDlg::IDD, pParent)

{

    m_hIcon = AfxGetApp()->LoadIcon(IDR_MAINFRAME);

}



void CSampleDlgDlg::DoDataExchange(CDataExchange* pDX)

{

    CDialog::DoDataExchange(pDX);

    DDX_Control(pDX, IDC_PDFVIEWCTRL1, m_PDFViewer);

}



BEGIN_MESSAGE_MAP(CSampleDlgDlg, CDialog)

    ON_WM_SYSCOMMAND()

    ON_WM_PAINT()

    ON_WM_QUERYDRAGICON()

    //}}AFX_MSG_MAP

    ON_BN_CLICKED(IDC_BUTTON_OPEN, &CSampleDlgDlg::OnBnClickedButtonOpen)

END_MESSAGE_MAP()





// CSampleDlgDlg message handlers



BOOL CSampleDlgDlg::OnInitDialog()

{

    CDialog::OnInitDialog();



    // Add "About..." menu item to system menu.



    // IDM_ABOUTBOX must be in the system command range.

    ASSERT((IDM_ABOUTBOX & 0xFFF0) == IDM_ABOUTBOX);

    ASSERT(IDM_ABOUTBOX < 0xF000);



    CMenu* pSysMenu = GetSystemMenu(FALSE);

    if (pSysMenu != NULL)

    {

        CString strAboutMenu;

        strAboutMenu.LoadString(IDS_ABOUTBOX);

        if (!strAboutMenu.IsEmpty())

        {

            pSysMenu->AppendMenu(MF_SEPARATOR);

            pSysMenu->AppendMenu(MF_STRING, IDM_ABOUTBOX, strAboutMenu);

        }

    }



    // Set the icon for this dialog.  The framework does this automatically

    //  when the application's main window is not a dialog

    SetIcon(m_hIcon, TRUE);         // Set big icon

    SetIcon(m_hIcon, FALSE);        // Set small icon



    // TODO: Add extra initialization here



    return TRUE;  // return TRUE  unless you set the focus to a control

}



void CSampleDlgDlg::OnSysCommand(UINT nID, LPARAM lParam)

{

    if ((nID & 0xFFF0) == IDM_ABOUTBOX)

    {

        CAboutDlg dlgAbout;

        dlgAbout.DoModal();

    }

    else

    {

        CDialog::OnSysCommand(nID, lParam);

    }

}



// If you add a minimize button to your dialog, you will need the code below

//  to draw the icon.  For MFC applications using the document/view model,

//  this is automatically done for you by the framework.



void CSampleDlgDlg::OnPaint()

{

    if (IsIconic())

    {

        CPaintDC dc(this); // device context for painting



        SendMessage(WM_ICONERASEBKGND, reinterpret_cast<WPARAM>(dc.GetSafeHdc()), 0);



        // Center icon in client rectangle

        int cxIcon = GetSystemMetrics(SM_CXICON);

        int cyIcon = GetSystemMetrics(SM_CYICON);

        CRect rect;

        GetClientRect(&rect);

        int x = (rect.Width() - cxIcon + 1) / 2;

        int y = (rect.Height() - cyIcon + 1) / 2;



        // Draw the icon

        dc.DrawIcon(x, y, m_hIcon);

    }

    else

    {

        CDialog::OnPaint();

    }

}



// The system calls this function to obtain the cursor to display while the user drags

//  the minimized window.

HCURSOR CSampleDlgDlg::OnQueryDragIcon()

{

    return static_cast<HCURSOR>(m_hIcon);

}





void CSampleDlgDlg::OnBnClickedButtonOpen()

{

    char szFilter[] ="PDF File (*.pdf)|*.pdf||";

    CFileDialog  fSaveDlg(TRUE,"","",

        OFN_HIDEREADONLY | OFN_OVERWRITEPROMPT,

        szFilter,this);

    if(fSaveDlg.DoModal() != IDOK)

        return;

    CString strFileName = fSaveDlg.GetPathName();



#if 0

    m_PDFViewer.OpenPDF(strFileName, "", "");

    

#else

    //----------------------------------------------------------------

    //

    // Memory Open

    //

    //----------------------------------------------------------------

    CString tmp = _T( "" );

    HANDLE  hFile = ::CreateFile( strFileName, GENERIC_READ, 0, NULL, OPEN_EXISTING, FILE_ATTRIBUTE_NORMAL, NULL );

    if ( hFile == INVALID_HANDLE_VALUE )

    {

        tmp.Format( _T( "CreateFile ERROR [CODE = %d]" ), GetLastError() );

        AfxMessageBox( tmp );

        return;

    }



    DWORD   dwRead;

    DWORD   dwSize = ::GetFileSize( hFile, NULL );

    BYTE*   pBuffer = new BYTE[ dwSize ];

    memset(pBuffer, 0, dwSize);



    if ( !::ReadFile( hFile, (LPVOID)pBuffer, dwSize, &dwRead, NULL ) )

    {

        tmp.Format( _T( "ReadFile ERROR [CODE = %d]" ), GetLastError() );

        AfxMessageBox( tmp );



        ::CloseHandle( hFile );

        return;

    }



    ::CloseHandle( hFile );



    BOOL bRes = m_PDFViewer.OpenPDFFromMem((long)pBuffer, dwSize, "", "" );

    if ( !bRes )

    {

        AfxMessageBox( _T( "Open error!" ) );

    }

#endif



    CString csCurrentPage = _T( "" );

    csCurrentPage.Format( _T( "Currnet Page : %d" ), m_PDFViewer.GetCurrentPage() );

    AfxMessageBox( csCurrentPage );



    m_PDFViewer.SetMsgCallbackWnd((long)m_hWnd);

}
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// SampleDlgDlg.h : header file
//

#pragma once
#include "pdfviewctrl1.h"


// CSampleDlgDlg dialog
class CSampleDlgDlg : public CDialog
{
// Construction
public:
	CSampleDlgDlg(CWnd* pParent = NULL);	// standard constructor

// Dialog Data
	enum { IDD = IDD_SAMPLEDLG_DIALOG };

	protected:
	virtual void DoDataExchange(CDataExchange* pDX);	// DDX/DDV support


// Implementation
protected:
	HICON m_hIcon;

	// Generated message map functions
	virtual BOOL OnInitDialog();
	afx_msg void OnSysCommand(UINT nID, LPARAM lParam);
	afx_msg void OnPaint();
	afx_msg HCURSOR OnQueryDragIcon();
	DECLARE_MESSAGE_MAP()
public:
	CPdfviewctrl1 m_PDFViewer;
	afx_msg void OnBnClickedButtonOpen();
};
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// stdafx.cpp : source file that includes just the standard includes

// SampleDlg.pch will be the pre-compiled header

// stdafx.obj will contain the pre-compiled type information



#include "stdafx.h"
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// stdafx.h : include file for standard system include files,
// or project specific include files that are used frequently,
// but are changed infrequently

#pragma once

#ifndef _SECURE_ATL
#define _SECURE_ATL 1
#endif

#ifndef VC_EXTRALEAN
#define VC_EXTRALEAN            // Exclude rarely-used stuff from Windows headers
#endif

#include "targetver.h"

#define _ATL_CSTRING_EXPLICIT_CONSTRUCTORS      // some CString constructors will be explicit

// turns off MFC's hiding of some common and often safely ignored warning messages
#define _AFX_ALL_WARNINGS

#include <afxwin.h>         // MFC core and standard components
#include <afxext.h>         // MFC extensions


#include <afxdisp.h>        // MFC Automation classes



#ifndef _AFX_NO_OLE_SUPPORT
#include <afxdtctl.h>           // MFC support for Internet Explorer 4 Common Controls
#endif
#ifndef _AFX_NO_AFXCMN_SUPPORT
#include <afxcmn.h>                     // MFC support for Windows Common Controls
#endif // _AFX_NO_AFXCMN_SUPPORT









#ifdef _UNICODE
#if defined _M_IX86
#pragma comment(linker,"/manifestdependency:\"type='win32' name='Microsoft.Windows.Common-Controls' version='6.0.0.0' processorArchitecture='x86' publicKeyToken='6595b64144ccf1df' language='*'\"")
#elif defined _M_IA64
#pragma comment(linker,"/manifestdependency:\"type='win32' name='Microsoft.Windows.Common-Controls' version='6.0.0.0' processorArchitecture='ia64' publicKeyToken='6595b64144ccf1df' language='*'\"")
#elif defined _M_X64
#pragma comment(linker,"/manifestdependency:\"type='win32' name='Microsoft.Windows.Common-Controls' version='6.0.0.0' processorArchitecture='amd64' publicKeyToken='6595b64144ccf1df' language='*'\"")
#else
#pragma comment(linker,"/manifestdependency:\"type='win32' name='Microsoft.Windows.Common-Controls' version='6.0.0.0' processorArchitecture='*' publicKeyToken='6595b64144ccf1df' language='*'\"")
#endif
#endif
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#pragma once

// The following macros define the minimum required platform.  The minimum required platform
// is the earliest version of Windows, Internet Explorer etc. that has the necessary features to run 
// your application.  The macros work by enabling all features available on platform versions up to and 
// including the version specified.

// Modify the following defines if you have to target a platform prior to the ones specified below.
// Refer to MSDN for the latest info on corresponding values for different platforms.
#ifndef WINVER                          // Specifies that the minimum required platform is Windows Vista.
#define WINVER 0x0600           // Change this to the appropriate value to target other versions of Windows.
#endif

#ifndef _WIN32_WINNT            // Specifies that the minimum required platform is Windows Vista.
#define _WIN32_WINNT 0x0600     // Change this to the appropriate value to target other versions of Windows.
#endif

#ifndef _WIN32_WINDOWS          // Specifies that the minimum required platform is Windows 98.
#define _WIN32_WINDOWS 0x0410 // Change this to the appropriate value to target Windows Me or later.
#endif

#ifndef _WIN32_IE                       // Specifies that the minimum required platform is Internet Explorer 7.0.
#define _WIN32_IE 0x0700        // Change this to the appropriate value to target other versions of IE.
#endif
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Microsoft Visual Studio Solution File, Format Version 10.00
# Visual Studio 2008
Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "SampleDlg", "SampleDlg\SampleDlg.vcproj", "{667E7123-805D-4B4E-AA2A-0FCC31BE5717}"
EndProject
Global
	GlobalSection(SolutionConfigurationPlatforms) = preSolution
		Debug|Win32 = Debug|Win32
		Release|Win32 = Release|Win32
	EndGlobalSection
	GlobalSection(ProjectConfigurationPlatforms) = postSolution
		{667E7123-805D-4B4E-AA2A-0FCC31BE5717}.Debug|Win32.ActiveCfg = Debug|Win32
		{667E7123-805D-4B4E-AA2A-0FCC31BE5717}.Debug|Win32.Build.0 = Debug|Win32
		{667E7123-805D-4B4E-AA2A-0FCC31BE5717}.Release|Win32.ActiveCfg = Release|Win32
		{667E7123-805D-4B4E-AA2A-0FCC31BE5717}.Release|Win32.Build.0 = Release|Win32
	EndGlobalSection
	GlobalSection(SolutionProperties) = preSolution
		HideSolutionNode = FALSE
	EndGlobalSection
EndGlobal
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